Zoznamujeme sa s prostredím

Revelation Natural Art – Predstavy z farieb a vzorov (čítaj revelejšn nečrl árt, skrátene RNA) je moderné grafické prostredie so širokým použitím, špeciálne určené pre mladších používateľov. Ponúka jednoduché, intuitívne a prirodzené, zároveň však silné a bohaté prostredie na kreslenie, tvorbu a umelecké vyžitie. Je vhodné pre žiakov, študentov a učiteľov – od úplných začiatočníkov cez mierne pokročilých a domácich používateľov až k pokročilým používateľom s bohatými skúsenosťami, vysokými nárokmi a očakávaniami a veľkými zručnosťami v umení a v používaní počítačov.

RNA je výkonné prostredie na prácu s bitmapami a animáciami. Či už sa používa samostatne alebo spolu s prostredím Imagine, umožňuje nám vytvárať a upravovať obrázky, ktoré si môžu nájsť svoje miesto ako umelecké výtvory v našej galérii, ktoré môžeme vytlačiť ako dekoráciu, použiť ich pre naše webové stránky, ako obrázky na pozadí v projektoch Imagine a rôznymi ďalšími spôsobmi. Okrem toho nám RNA ponúka možnosť vytvárať a upravovať série obrázkov – animácie pre prostredie Imagine ako tvary korytnačiek či ako animované GIFy pre naše webové stránky, animované kurzory pre Windows, alebo ako zložené pečiatky pre vlastné RNA.

RNA poskytuje širokú škálu umeleckých štetcov a iných nástrojov na kreslenie a maľovanie, písanie, vkladanie pečiatok či jednoduchých geometrických tvarov (akými sú napr. čiary, kruhy, obdĺžniky, elipsy, mnohouholníky a krivky), vypĺňanie farbami alebo zvoleným motívom atď.

Môžeme tu tiež vytvárať a upravovať štandardné ikony a kurzory pre prostredie Windows a využívať jeho pamäťovú schránku. RNA nám umožňuje meniť veľkosti, otáčať, zošikmovať, skrúcať, vyfarbovať a inak transformovať rastrové obrázky. Tiež nám poskytuje pôsobivé nástroje na vytváranie a pretváranie animácií či animovaných filmov, t.j. sérii fáz. Podporuje aj mnohé iné pokročilé grafické úkony a akceptuje (pri otváraní a ukladaní) mnohé najčastejšie používané grafické formáty súborov.

Popri mnohých ďalších úžasných funkciách a vlastnostiach ponúka RNA veľa možností na prispôsobovanie prostredia vlastným potrebám používateľa. Môžeme určovať rozloženie celej obrazovky, vybrať si alebo vytvoriť vlastnú konfiguráciu. Podporuje nás pri vytváraní vlastných panelov a okien s nástrojmi, schovávaní nástrojov, ktoré práve teraz nepotrebujeme, výbere príkazov v ponuke a vytváraní svojich vlastných klávesových skratiek.

  • Prvky prostredia RNA
  • RNA, Imagine a Comenius Logo
  • Nástroje, ktoré ponúka RNA
  • Myš a tablet v prostredí RNA


Prvky prostredia RNA

Keď začneme vytvárať vlastný obrázok, môže nám pri hľadaní skupín nástrojov a nastavení ponúkaných RNA pomôcť nasledujúci diagram. Rýchlo sa naučíme väčšinu z možností účinne používať, pretože RNA ponúka svoje nástroje a funkcie veľmi prirodzenou cestou.


RNA, Imagine a Comenius Logo

RNA predstavuje ďalší odvážny krok v línii od obrázkového editora v prostredí Comenius Logo, cez editor LogoMotion v prostredí Imagine k novej generácii univerzálneho editora na prácu s bitmapami a animáciami, vhodnej pre tvorivú prácu žiakov a ich učiteľov.

Obrázkový editor v prostredí Comenius Logo dovoľoval vytvárať malé a jednoduché animované tvary pre korytnačky. LogoMotion ide ďalej a ponúka prekvapujúco silné – a zároveň intuitívne jednoduché nástroje na vytváranie bitmapových obrázkov a animácií. Spolupracuje s prostredím a jazykom Imagine a dovoľuje vytvárať a modifikovať jeho obrázky (pozri ilustráciu dolu). RNA podstatne rozšírilo paletu nástrojov pre kreslenie a maľovanie, jednoduchým spôsobom dáva do rúk mladých – a možno sprvu aj neskúsených používateľov – nástroje na výtvarné vyjadrenie sa na profesionálnej úrovni.


Nástroje, ktoré ponúka RNA

RNA je novou generáciou editorov bitmáp a animácii. Ponúka nám vzrušujúce nástroje, ako napríklad:

  • Širokú paletu umeleckých štetcov na vytváranie prirodzene vyzerajúcich malieb.
  • Pohodlné a neobvyklé spôsoby na zvolenie si požadovanej farby.

  • Prirodzené a intuitívne prepojenie používania myši a tabletu s grafickým perom a podložkou citlivou na tlak.
  • Knižnicu pečiatok, ktoré nám umožňujú pridávať do obrázkov jednoduché alebo zložené obrázky.
  • Niekoľko možností nastavenia súmernosti.
  • Motívy na vypĺňanie plôch, ako ďalšiu alternatívu k obyčajným farbám.
  • Škálu efektov.
  • Silnú podporu pri vytváraní a upravovaní sérií obrázkov, t.j. animácií pre Imagine a iné.
  • Transformácie, ktoré môžeme použiť pri jednoduchých alebo zložených obrázkoch.
  • Interaktívny nástroj na organizovanie obrázkov, ich záberov a fáz.
  • Výnimočne rozsiahle možnosti pri prispôsobovaní prostredia vlastným potrebám používateľa.


Myš a tablet v prostredí RNA

V RNA môžeme používať buď myš alebo tablet – grafické pero s podložkou. Aj keď je myš postačujúca na ovládanie prostredia, naše obrázky budú vyzerať prirodzenejšie, ak použijeme tablet. Dôvodom je to, že niektoré štetce dostupné v RNA sú citlivé na tlak vyvinutý perom – môžeme ním vytvárať ťahy plynule meniace hrúbku a sýtosť farby. Preto odporúčame pripojiť si k počítaču aj tablet s podložkou citlivou na tlak, aby sme dokázali zužitkovať všetko, čo nám ponúka RNA.

Existuje mnoho značiek tabletov. Môžeme použiť ľubovoľnú z nich za predpokladu, že je citlivá na meniaci sa tlak. (Kým začneme v RNA používať tablet, presvedčme sa, že je správne zapojený a nainštalovaný.) Vo väčšine značiek nájdeme v dodávke tri základné prvky – podložku (vlastný tablet), grafické pero a bezdrôtovú myš. Tablet obvykle obsahuje miesto na odloženie pera, ďalej stavovú LED-ku a povrch s aktívnou plochou. Grafické pero je na tlak citlivý nástroj do ruky, ktorým môžeme kresliť, maľovať a ovládať celé prostredie. Skladá sa z hrotu (ukazovateľ), tlačidla (alebo prepínača) a z gumy na druhom konci pera. Pero používame – rovnako ako myš – na označovanie a ukazovanie, klikanie, dvojklikanie, ťahanie a klikanie pravým tlačidlom myši.

Grafické pero držíme ako normálne pero v prirodzenej pozícii tak, aby sme ním mohli kresliť na aktívnej ploche podložky – resp. tesne nad ňou. Pamätajme si, že pero je aktívne hneď ako ho priložíme nad aktívnu plochu. Umožňuje nám to pohybovať obrazovkovým kurzorom bez kontaktu hrotu pera s podložkou. Pero sa aktivuje pri vzdialenosti približne 5 mm od podložky.

Bezdrôtová myš, ktorá býva ďalším prvkom dodávky, sa niekedy používaná na riadenie v prostredí a manévrovanie, najmä pomocou programovateľného stredného tlačidla a kolieska myši.

Nasledujúci prehľad popisuje, ako sa tabletom vykonávajú bežné operácie (všimnime si, že niektoré z týchto funkcií sa dajú nastaviť, prípadne aj zrušiť v ovládacom paneli tabletu):

  • Ukazovanie. Pero môžeme používať na pohybovanie kurzorom (ukazovateľom) po obrazovke. Aktívna plocha podložky zodpovedá obrazovke počítača. Keď sa dotkneme perom podložky, kurzor sa premiestni na toto miesto na obrazovke. Kurzorom môžeme v RNA pohybovať zdvíhaním pera a položením do novej pozície. Kurzor vtedy preskočí do novej polohy.
  • Klikanie. Aby sme perom klikli, môžeme buď ťuknúť hrotom pera na podložku, alebo zatlačiť hrot pera dostatočnou silou, aby sa kliknutie zaregistrovalo.
  • Dvojklikanie. Ťuknime hrotom pera na podložku dvakrát na rovnaké miesto.
  • Používanie tlačidla. Obvykle má (jednu alebo dve) programovateľné funkcie, ktoré môžeme zvoliť na ovládacom paneli. Tlačidlo môžeme použiť, aj keď je hrot v tesnej blízkosti k podložke. Znamená to, že sa nemusíme dotýkať podložky, aby sme mohli použiť tlačidlo. Funkcia tlačidla býva zväčša prednastavená ako kliknutie pravým tlačidlom myši.
  • Ťahanie. Používa sa na označovanie a pohybovanie predmetmi po obrazovke. Najprv ukážeme kurzorom na predmet, potom zatlačíme perom na podložku a kĺžeme ním po povrchu.
  • Kreslenie s využívaním prítlaku. Podložka reaguje na tlak pera, ktorý vytvárame rukou. Tým nám umožňuje vytvárať v RNA prirodzene vyzerajúce ťahy štetcom. Znamená to, že takto môžeme meniť hrúbku a sýtosť farby. Aby sme si vyskúšali citlivosť na tlak, zvoľme si štetec, ťahajme ním po povrchu podložky a meňme pri tom tlak pôsobiaci na podložku. Tlačme silnejšie a získame hrubšie a sýtejšie čiary, jemným tlakom dostaneme čiary tenšie a bledšie.

  • Gumovanie. Guma na pere (na jeho opačnom konci) funguje ako guma na ceruzke. Vďaka tomu môžeme gumovať intuitívne a prirodzene. Všimnime si však, že gumovať môžeme tak isto aj myšou so stlačeným pravým tlačidlom, alebo perom so stlačeným tlačidlom. Tiež si uvedomme, že pri takomto gumovaní sa zachovajú všetky naše predošlé nastavenia (napr. zvolený štetec, veľkosť jeho hrotu, farba, priesvitnosť atď.) – čo neplatí pri používaní nástroja guma.


Vytvárame a upravujeme obrázky

Táto kapitola ponúka úvodnú prehliadku po celom RNA, jeho prostredí a nástrojoch. Prejdeme zjednodušeným pracovným cyklom cez celé prostredie. Začneme prázdnou stránkou, budeme pokračovať výberom farieb a nástrojov, používaním efektov, postupom na vrátenie krokov, vystrihovaním a prilepovaním, vkladaním tvarov, textu a pečiatok a skončíme pri tlači obrázka, jeho ukladaní a opätovnom načítaní. Zistíme, ako narábať s jednoduchými obrázkami, ale aj so sériou obrázkov – animáciami. Naučíme sa, ako môžeme nastavovať konfigurácie a ako môžeme prispôsobiť prostredie RNA svojim vlastným potrebám. Táto krátka prehliadka bude obsahovať:

  • Vytváranie nových obrázkov
  • Možnosti nastavenia papiera
  • Základné príkazy: Nový, Otvoriť, Tlačiť a Uložiť
  • Práca s niekoľkými obrázkami
  • Základné informácie o konfiguráciách a úprave prostredia pre potreby používateľa
  • Ako zatvoriť RNA

Neskôr sa naučíme viac o detailoch, ďalších funkciách a pokročilejších technikách. Pri našom experimentovaní nám pomôžu nasledujúce kapitoly:

  • Skúmame pracovný priestor
  • Pracujeme s jednotlivým obrázkom
  • Pracujeme so sériou obrázkov. Animácie
  • Upravujeme prostredie RNA podľa svojich potrieb
  • Tabuľka klávesových skratiek
  • RNA v príkazovom riadku


Základné príkazy: Nový, Otvoriť, Tlačiť a Uložiť

Ak chceme obrázok uložiť

  • V ponuke Súbor vyberieme možnosť Súbor/Uložiť ako... .
  • Napíšeme názov nášho obrázka a uložíme ho.

Môžeme si vybrať jeden z niekoľkých podporovaných grafických formátov súborov, podľa toho, ako budeme chcieť ďalej obrázok použiť. Predvolený formát je obrázok RNA.

Neskôr môžeme pokračovať v práci na svojom obrázku

  • Znovu zapneme RNA a vyberieme možnosť Súbor/Otvoriť... .

Toto nám umožní otvoriť naše vlastné obrázky, načítať fotografie alebo obrázky stiahnuté z internetu atď. Tieto obrázky a fotografie môžu byť vo formáte RNA, BMP, GIF, vo formáte obrázkov prostredia Imagine alebo v niektorom inom podporovanom grafickom formáte.

Ak chceme kresliť nový obrázok

  • Vyberme možnosť Súbor/Nový.
  • Po výbere tejto možnosti sa v hlavnom okne RNA objaví nový list papiera. Jeho veľkosť a farba pozadia budú rovnaké ako tie, ktoré sme naposledy nastavili v dialógovom okne Nastavenie papiera. Ak sme ešte neuskutočnili nijaké nastavenia v tomto dialógovom okne, papier bude mať predvolené nastavenie, ktoré obsahuje bielu farbu pozadia.

Svoj obrázok si môžeme kedykoľvek vytlačiť

  • Vyberme možnosť Súbor/Tlačiť... a otvorí sa dialógové okno Tlačiť.
  • Kliknime na tlačidlo Nastaviť tlačiareň, kde môžeme zmeniť orientáciu papiera z Portrét na Krajina alebo naopak.
  • Zaškrtnime možnosť Roztiahnuť na stranu, ak chceme, aby obrázok pokryl celý list papiera.


Vytváranie nových obrázkov

Keď zapneme RNA, uvidíme pôsobivé prostredie, ktoré ponúka viacero okien a panelov s nástrojmi. Prvý pohľad bude asi takýto:

Vyskúšajme takýto postup:

  • Zoznámme sa s prostredím a skúsme vytvoriť prvú kresbičku v RNA. Na ľavej strane sa nachádza zvislý panel nástrojov, ktorý obsahuje ikony dvanástich rôznych umeleckých štetcov. Klikajme na ne jeden po druhom a vyskúšajme ich na papieri. Môžeme vyskúšať aj nasledujúce klávesové skratky:
  • F5 zobrazí alebo skryje panel obsahujúci vybraný typ štetca v rôznych farbách.
  • F7 zobrazí alebo skryje paletu farieb na spodu obrazovky.
  • F8 zobrazí alebo skryje okno s lupou.

Ďalej:

  • Experimentujme so základnými nástrojmi. Vyskúšajme si kreslenie myšou a grafickým perom citlivým na tlak (ak ho máme k dispozícii). Rýchlo zistíme, že zmenou tlaku grafického pera na podložku dosiahneme čiary rôznych hrúbok a sýtostí.
  • Kliknutím a potiahnutím šedého okraja ktoréhokoľvek okna alebo panelu s nástrojmi panel uvoľníme z ukotvenia a stane sa z neho voľne plávajúce okno. Takto môžeme usporiadať obrazovku tak, ako nám to vyhovuje. Panely a okná môžeme nechať voľne alebo ich ukotviť na opačnú stranu obrazovky. V kapitole Prispôsobovanie prostredia RNA potrebám používateľa sa naučíme, ako meniť horizontálne panely na vertikálne a naopak.

  • Vyskúšajme rozličné štetce a farby. Všimnime si, že zo súčasnej farby na štetci a farieb na palete môžeme namiešať novú farbu.
  • Nájdime panel nástrojov Hroty a vyskúšajme rôzne typy hrotov. Pri niektorých typoch štetca sa pri dlhom ťahu farba pomaly míňa a bledne. Ak zdvihneme štetec z podložky a začneme nový ťah, je to, ako by sme štetec znovu namočili do farby – stopa bude opäť sýta.

  • Klikajme na tlačidlá v paneli nástrojov Tvary pre vkladanie obdĺžnikov, kruhov, mnohouholníkov atď. a použime ich prirodzeným spôsobom.
  • Kliknime na tlačidlo Text a napíšme do Textového okienka krátku správu. Vyberme si písmo, farbu, veľkosť a štýl a potiahnime textový rámik na ľubovoľnú pozíciu. Potom kliknime v textovom okienku na tlačidlo Napísať text alebo kliknime mimo okienka – tým vložíme text do obrázka.
  • Stlačením Alt+F7 otvoríme pomôcku pre voľbu farby a môžeme si vyskúšať rozličné úrovne priesvitnosti farieb.
  • Zvoľme Zobrazenie/Pečiatky – zobrazí sa tak okno Pečiatky. Vyberme si pečiatku, ktorá sa nám páči, kliknime na ňu a potom na papier. Môžeme tiež vyskúšať kresliť s kurzorom na papier.


Možnosti nastavenia papiera

Ak chceme nastaviť alebo preskúmať niektoré vlastnosti papiera:

  • Vyberme možnosť Zobrazenie/Nastaviť papier... alebo kliknime na tlačidlo Nastaviť papier na Hlavnom paneli. Otvorí sa dialógové okno Nastavenie papiera.
  • Môžeme v ňom zmeniť veľkosť papiera, s ktorým pracujeme. Buď si vyberieme jednu zo štandardných veľkostí, alebo určíme vlastnú veľkosť v bodoch. Môžeme tiež určiť farbu pozadia papiera alebo obrázok, ktorý RNA vloží na pozadie papiera. Niekedy je to užitočné, pretože takto môžeme vymazať časti obrázka, a tým sčasti obnoviť pôvodnú farbu pozadia.

Na nasledujúcom obrázku sme nastavili jemnú farbu pozadia papiera a potom sme kreslili s olejovými pastelkami a lúčmi na špeciálny povrch papiera. Nakoniec sme použili gumu, čím sme pridali do obrázka čiastočne priesvitný vyplnený kruh. Tak sme vytvorili miesto, na ktoré môžeme teraz napr. vložiť text.


Práca s niekoľkými obrázkami

Niekedy je užitočné pracovať s niekoľkými obrázkami súčasne. Umožní nám to kopírovať časti jedného obrázka do druhého, spracúvať niekoľko obrázkov rovnakým spôsobom, porovnávať ich, kombinovať navzájom atď. V RNA môžeme opakovane zvoliť možnosť Súbor/Otvoriť.... Môžeme tiež vložiť iné obrázky alebo snímky obrazovky zo schránky. Tiež môžeme niekoľkokrát zvoliť možnosť Súbor/Nový, a tak vytvoriť niekoľko nových obrázkov.

Len čo začneme pracovať s viacerými obrázkami súbežne, musíme si ich usporiadať:

  • Po stlačení F4 sa otvorí špeciálny nástroj, ktorý nám s usporadúvaním pomôže – okno Obsah. V tomto okne má každý obrázok, ktorý sme otvorili v RNA, svoju záložku.
  • Kliknime na záložku obrázka, na ktorom chceme práve pracovať.
  • Kliknime na tlačidlo Oblasť na Hlavnom paneli a označme časť jedného obrázka.
  • Stlačením Ctrl+C skopírujeme označený obdĺžnikový výber do schránky.
  • Potom prejdime k ďalšiemu obrázku a stlačením Ctrl+V sem vložme označený a skopírovaný výber.

  • Všimnime si, že jednotlivé záložky v okne Obsah sú pomenované podľa názvu obrázka, ktorý zastupujú. Ak je obrázok v pôvodnom formáte Revelation Natural Art (t.j. RNA), prípona formátu nie je zobrazená. V ostatných prípadoch je formát obrázka uvedený spolu s jeho názvom, napríklad Julo.gif alebo strecha.bmp. Ak vytvoríme v RNA nový obrázok, jeho dočasné meno bude Obrázok 1, Obrázok 2 ... atď., až kým ho nepomenujeme pomocou Súbor/Uložiť ako....

Všetky obrázky, s ktorými sme doteraz pracovali, boli jednoduché. RNA je však výborným nástrojom aj na vytváranie a upravovanie sérií obrázkov. Zvyčajne sú to animované časti grafiky ako napríklad animované gify, obrázky Imagine, ktoré sa zvyčajne používajú ako tvary pre korytnačky, animované kurzory pre Windows, alebo zložené pečiatky pre vlastné RNA. Tieto animované obrázky zvyčajne pozostávajú z niekoľkých záberov. Každý záber sa skladá buď z jednoduchého obrázka, alebo zo série obrázkov, ktoré sa nazývajú fázy. Každá séria obrázkov vytvára druh animovaného filmu, ktorý vyjadruje napr. pohyb určitej postavy nejakým smerom (ako napr. chôdzu doprava, chôdzu smerom k nám, chôdzu doľava a chôdzu smerom od nás).

Otvorme jeden alebo niekoľko LGF, GIF, alebo ANI súborov. Okno Obsah nám opäť pomôže pri usporadúvaní týchto animovaných obrázkov. Môžeme k nim vložiť nové fázy, presúvať ich z jedného záberu do druhého, použiť niektorú zložitú transformáciu na niekoľko obrázkov v jednom kroku atď. Toto by nebolo možné bez silného nástroja, akým je RNA.


Základné informácie o konfiguráciách a úprave prostredia pre potreby používateľa

RNA si môžeme predstaviť ako stavebnicu, ktorá pozostáva zo stoviek drobných prvkov nazvaných komponenty. Preto je toto prostredie mimoriadne vhodné na to, aby sme ho prispôsobovali našim vlastným potrebám. Na čokoľvek tento program používame, celé prostredie môžeme prestavať tak, aby viac vyhovovalo našej momentálnej práci.

  • Zvoľme možnosť Zobrazenie/Iné/Nastavenie prostredia... alebo stlačme Ctr+Alt+Medzera a otvorí sa nám okno Nastavenie prostredia.
  • Overme si, či je zobrazená prvá záložka s názvom Konfigurácie. Zobrazí sa nám súbor vopred definovaných nastavení – vhodných pre začiatočníkov, mierne pokročilých aj pokročilých používateľov.
  • Kliknime na jednu z týchto možností a potom kliknime na tlačidlo Použiť. Toto je tiež spôsob, ako sa môžeme prepnúť na inú vopred definovanú úpravu (konfiguráciu) RNA.

Ak chceme vytvoriť náš vlastný nový panel:

  • Kliknime na záložku Okná a panely v okne Nastavenie prostredia a kliknime na tlačidlo Nový panel.
  • Vytvorí sa nový, prázdny panel. Presvedčme sa, že sa zobrazil.
  • Kliknime na tlačidlo Vlastnosti a napíšme nový nadpis pre náš panel.
  • Kliknime na Vertikálne rozloženie a potom zatvorme dialógové okno Vlastnosti kliknutím na tlačidlo OK.
  • Otvorme záložku Komponenty okna Nastavenie prostredia a začnime panel napĺňať tlačidlami a štetcami, ktoré si zvolíme.
  • Prejdime napríklad do skupiny Kreslenie a jej podskupiny Pripravené štetce. Nájdime položku Ceruzka, vyberme jej farbu a typ hrotu, potom potiahnime jej ikonu na vrch nášho nového panelu. Postup opakujme pre ostatné farby, tvary alebo pripravené štetce. Potom prejdime na ponuku Zobrazenie a pridajme niekoľko tlačidiel. Môžeme si otvoriť aj ostatné užitočné panely.

Takýmto spôsobom môžeme krok za krokom vytvoriť vlastnú podobu prostredia RNA.

  • Potom buď jednoducho zatvoríme okno Nastavenie prostredia, alebo uložíme svoje nastavenia ako našu vlastnú, používateľom vytvorenú konfiguráciu, ktorú môžeme neskôr znova použiť.

V rámci našej konfigurácie môžeme určiť vlastné klávesové skratky, ukryť nástroje, ktoré pre nás momentálne nie sú dôležité, skryť všetky možnosti ponuky, ktoré nepotrebujeme pri riešení tejto úlohe, vytvárať ďalšie panely a okná nástrojov a prerobiť celú obrazovku.

Môžeme si vytvoriť toľko vlastných, nami nastavených konfigurácií, koľko považujeme za užitočné.


Ako zatvoriť RNA

Buďme opatrní, aby sme neukončili RNA bez uloženia našej práce. Ak chceme ukončiť RNA, môžeme:

  • Vybrať možnosť Súbor/Skončiť alebo stlačiť Alt+X alebo Alt+F4 alebo kliknúť na tlačidlo Zatvoriť v hlavnom okne RNA. V každom z týchto prípadov nás RNA vyzve k uloženiu akéhokoľvek neuloženého obrázka. RNA sa potom ukončí.
  • Ak pracujeme s niekoľkými obrázkami súčasne a chceme zatvoriť iba ten, ktorý je práve zobrazený na papieri, vyberme možnosť Súbor/Zatvoriť alebo stlačme Ctrl+F4. Ak obrázok obsahuje akékoľvek neuložené zmeny, RNA nás vyzve, aby sme obrázok najprv uložili. Aplikácia ako taká sa neukončí. Ďalšou možnosťou je kliknúť pravým tlačidlom myši na záložku obrázka v okne Obsah a z otvorenej ponuky vybrať možnosť Zatvoriť.
  • Ak chceme naraz zatvoriť niekoľko obrázkov, ktoré idú po sebe (bez toho, aby sme ukončili RNA), vyberme jednotlivé záložky v okne Obsah tak, že na ne postupne klikneme so stlačeným klávesom Shift. Potom stlačme Ctrl+F4 alebo kliknime pravým tlačidlom myši na vybrané záložky a vyberme možnosť Zatvoriť.


Skúmame pracovný priestor

Ak sme už skúsenými používateľmi iných prostredí na kreslenie, pravdepodobne budeme používať RNA na pokročilej úrovni, takže budeme môcť naplno využívať jeho nástroje a funkcie. (Ak nie sme pokročilí používatelia, budeme sa zrejme chcieť naučiť viac o jednoduchej a mierne pokročilej úrovni RNA.) Keď zapneme RNA, otvorí sa nám prostredie s nasledujúcimi kľúčovými prvkami (niektoré z nich však môžu byť skryté alebo minimalizované):

  • Hlavná ponuka
  • Stránka
  • Okná a panely s nástrojmi

Čím viac používame RNA, tým zdatnejší budeme v prispôsobovaní si prostredia. RNA je prekvapujúco prístupné a flexibilné mierou, do akej môžeme upravovať a meniť komponenty na obrazovke, a tým vytvárať vyhovujúce prostredie zamerané na naše potreby. Na obrázku vidíme jedno z možných usporiadaní vhodných pre spracovanie fotografií (s niekoľkými panelmi skrytými a inými minimalizovanými).

Ak je panel alebo okno úplne skryté, môžeme ho zobraziť nasledujúcimi spôsobmi:

  • Otvorme ponuku Zobrazenie a zvoľme meno panela alebo okna, ktoré chceme zobraziť.
  • Stlačme príslušnú klávesovú skratku – ak existuje – napr. F4 pre Obsah, F8 pre okno Lupa atď.

Opakovaním tohto postupu môžeme znova skryť príslušný panel alebo okno. Ak je okno voľne položené na ploche (pozri nižšie), môžeme ho skryť aj kliknutím na krížik v jeho pravom hornom rohu alebo ho minimalizovať kliknutím na jeho malý trojuholník. Opätovným kliknutím na trojuholník sa okno znova zväčší.

Každé okno a panel nástrojov je orientované buď vodorovne alebo ako zvislo. Ak je okno alebo panel vodorovného typu, môžeme ho ukotviť na vrchnom alebo spodnom okraji hlavného okna RNA alebo k okraju iného, už ukotveného panela či okna. Ak je okno alebo panel zvislého typu, môžeme ho ukotviť na ľavom alebo na pravom okraji, alebo k iným, už ukotveným panelom či oknám.

Ak chceme uvoľniť ukotvené okno, kliknime na jeho šedý úzky titulný riadok a potiahnime ho. Ak chceme toto okno alebo panel opäť ukotviť, pritiahnime ho opatrne späť k okraju.

Ak zobrazíme a uvoľníme všetky bežné panely a okná RNA (v pokročilej úrovni), uvidíme takýto súbor nástrojov a komponentov:


Hlavná ponuka

Tento panel na vrchu obrazovky poskytuje ponuky Súbor, Úpravy, Zobrazenie, Maľovanie, Animácia a Pomoc. Každá z nich obsahuje zoznam príkazov, ktoré nižšie podrobne popíšeme. Niektoré z nich majú vľavo vedľa seba malé ikony, ktoré sa zhodujú s ikonami tlačidiel na hlavnom paneli, na paneli Maľovanie, alebo na niektorom inom paneli. V ponuke sú zobrazené preto, aby sme si uvedomili ich prepojenie so zodpovedajúcim tlačidlom.

  • Príkazy ponuky Súbor
  • Príkazy ponuky Úpravy
  • Príkazy ponuky Zobrazenie
  • Príkazy ponuky Maľovanie
  • Príkazy ponuky Animácia
  • Príkazy ponuky Pomoc


Príkazy ponuky Súbor

Ak sa chceme dozvedieť o príkaze, kliknime naň na obrázku myšou.


Príkazy ponuky Úpravy

Ak sa chceme dozvedieť o príkaze, kliknime naň na obrázku myšou.


Príkazy ponuky Zobrazenie

Ak sa chceme dozvedieť o príkaze v ponuke Zobrazenie, kliknime naň na obrázku myšou.


Príkazy ponuky Maľovanie

Ak sa chceme dozvedieť o príkaze v ponuke Maľovanie, kliknime naň na obrázku myšou.


Príkazy ponuky Animácia

Ak sa chceme dozvedieť o príkaze v ponuke Animácia, kliknime naň na obrázku myšou.


Príkazy ponuky Pomoc

Ukázať Pomocníka | Otvára úvodnú stránku Pomocníka.
Revelation Natural Art F1 | Otvára stránku Pomocníka, ktorá popisuje pokročilú úroveň RNA.
Zobraziť domovskú stránku… | Otvára webovú stránku obsahujúcu aktuálne informácie vydavateľstva o editore RNA.
O programe… | Otvára dialógové okno O programe RNA s informáciami o vydavateľovi.


Stránka

Strednú časť hlavného okna RNA tvorí jedna z týchto dvoch možností:

  • Stránka s obrázkom, na ktorom práve pracujeme (buď jednoduchý obrázok alebo jedna z fáz série obrázkov). Zobrazený obrázok môže byť buď zväčšený alebo zmenšený, alebo má normálnu veľkosť.
  • Ukážka animácie obrázka, na ktorom pracujeme.

Ak chceme prepínať medzi zobrazením obrázka a ukážkou animácie:

  • stlačme klávesovú skratku F9 alebo
  • zvoľme možnosť Zobrazenie/Ukážka animácie alebo
  • stlačme tlačidlo Prehrať normálne alebo Prehrať odzadu na paneli Animácia.

V ľavom okne vidíme zväčšené zobrazenie jedného obrázka, v pravom okne je zobrazený ten istý obrázok v režime Ukážka.

Každý list papiera má tieto nastavenia:

  • Veľkosť, t.j. šírka a výška
  • Farba pozadia
  • Obrázok na pozadí.

Okrem týchto nastavení si môžeme vybrať aj špeciálny povrch, ktorý sa použije, keď budeme kresliť alebo pridávať tvary a pod. Aj keď môžeme kedykoľvek meniť papier, bude to skôr funkcia maľovania alebo pridávania prvkov, ako vlastnosť papiera.

Pozri tiež:

  • Vytváranie nového listu papiera
  • Dialógové okno Nastavenie papiera
  • Priesvitné body


Vytváranie nového listu papiera

Ak chceme vytvoriť nový list papiera pre nový obrázok, vyberieme príkaz Súbor/Nový. Šírka, výška a farba pozadia nového obrázka budú rovnaké ako naposledy určené hodnoty týchto nastavení v dialógovom okne Nastavenie papiera. Nový papier bude pokrytý priesvitnými bodmi (pričom farba pozadia leží až za nimi).

Nový list papiera môžeme vložiť do už existujúceho obrázka, ak je tento obrázok sériou obrázkov, ako napr. animovaný GIF alebo animovaný obrázok pre Imagine, animovaný kurzor a pod. Môžeme to urobiť tak, že:

  • zvolíme príkaz Úpravy/Vložiť pred alebo Úpravy/Vložiť za, alebo
  • klikneme pravým tlačidlom myši na fázu a z ponuky Obsah fáz vyberieme možnosť Úpravy/Vložiť pred alebo Úpravy/Vložiť za, alebo
  • klikneme pravým tlačidlom myši na záber a z ponuky Obsah záberov vyberieme možnosť Úpravy/Vložiť pred alebo Úpravy/Vložiť za.

Pri každej z týchto alternatív je šírka, výška aj farba pozadia papiera rovnaká ako pri susednej fáze. Papier je pokrytý priesvitnými bodmi (pričom farba pozadia leží až za nimi).

Do obrázka môžeme prilepiť aj list papiera, ktorý sme predtým vystrihli alebo skopírovali do schránky. Prilepiť ho môžeme do akejkoľvek pozície – ako vsuvku do inej strany, ako nový obrázok, ako jednoduchý záber s jednou novou fázou alebo ako novú fázu medzi ostatné fázy. Ak chceme takto prilepiť papier, zvoľme príkaz Úpravy/Prilepiť pred alebo Úpravy/Prilepiť za z hlavnej ponuky, ponuky Obsah, Obsah fáz alebo ponuky Obsah záberov.

Nový (prilepený) papier si vždy zachová svoju veľkosť, farbu pozadia a obrázok na pozadí.

Vkladanie nového listu papiera medzi existujúce fázy.


Dialógové okno Nastavenie papiera

Ak chceme zmeniť nastavenia papiera, zvoľme príkaz Zobrazenie/Nastaviť papier.... Otvorí sa dialógové okno Nastavenie papiera, ktoré ukazuje súčasné nastavenie papiera, a to jeho štýl, šírku a výšku, farbu pozadia a obrázok pozadia.

Všetky tieto nastavenia môžeme kedykoľvek upraviť. Pôvodný obsah obrázka ostane zachovaný, ak nie je nová veľkosť papiera menšia ako jeho pôvodná veľkosť.


Štýl

Ak chceme zmeniť štýl z ponuky vyberme:

  • buď jeden z predvolených štýlov (napr. A4 Krajina, alebo A6 Portrét, alebo Strana pre Imagine atď.),
  • alebo jeden z našich vlastných štýlov, ktoré sme predtým definovali.

Výber štýlu znamená určenie výšky a šírky papiera, farby jeho pozadia, prípadne obrázka na pozadí.

Naše nastavenie papiera si môžeme uložiť:

  • Kliknime na symbol plus napravo od nastavenia Štýlu.
  • Pomenujme svoje aktuálne nastavenia.

Takto môžeme vytvoriť naše vlastné štýly papiera. Obrázok pozadia papiera však v štýle papiera zahrnutý nie je.

Ak chceme uložený štýl vymazať označme ho a kliknime na symbol krížik (vpravo od symbolu plus).


Farba pozadia

Farba pozadia papiera ukazuje momentálne nastavenie pozadia papiera. Uvedomme si, že táto farba nie je súčasťou obrázka. Preddefinovaná farba pozadia je biela, ako môžeme vidieť v obdĺžnikovej oblasti vedľa titulku Farba pozadia v dialógovom okne.

Ak chceme zmeniť farbu pozadia:

  • Kliknime na veľký obdĺžnik Farby pozadia.

Otvorí sa dialógové okno, v ktorom si môžeme vybrať ďalšiu farbu. Umožní nám zistiť alebo nastaviť aktuálnu farbu pozadia.


Obrázok pozadia

V okienku s názvom Obrázok pozadia môžeme vidieť ukážku obrázka, ktorý je zobrazený na pozadí papiera. Prednastavená hodnota je žiaden.

Ak chceme túto voľbu zmeniť:

  • Kliknime na oblasť ukážky. Otvorí sa štandardné dialógové okno Otvoriť, kde môžeme vybrať svoj obrázok.
  • Z ponuky napravo od ukážky Obrázok pozadia si vyberme buď:
    • možnosť Žiaden (bez obrázka na pozadí), alebo
    • jednu z možností Do stredu, Prispôsobiť, Natiahnuť a Kachličkovať, ktoré určujú, ako bude obrázok na pozadí umiestený.

Vyskúšajme si jednotlivé možnosti. Keď nastavíme obrázok ako pozadie papiera, RNA túto voľbu ihneď aplikuje, ale úmyselne si ju „nepamätá“ pri vytvorení nového papiera alebo pri budúcom použití.

Nezabudnime tiež, že obrázok na pozadí papiera nie je súčasťou nášho obrázka. Ak teda časť nášho obrázka vymažeme, na týchto miestach sa obnoví zvolené pozadie.


Priesvitné body

Keď začneme vytvárať obrázok v RNA, všetky body na papieri sú priesvitné. Môžeme sa o tom takto presvedčiť:

  • Nastavme zväčšenie obrázka aspoň na 400%.
  • Označme políčko Priesvitné body v okne Lupa.
  • Všetky priesvitné body sa potom zobrazia s bodkou v strede (bodka je len na vyjadrenie priesvitnosti, nie je súčasťou obrázka).

Keď pridávame do obrázka farby, meníme body z úplne priesvitných na farebné (s možnosťou určiť rôzne úrovne priesvitnosti zvolenej farby). Ak chceme zmeniť body späť na priesvitné, môžeme ich buď:

  • vygumovať, alebo
  • použiť akúkoľvek kombináciu tvarov, hrotov a nástrojov a maľovať, kresliť, pridávať tvary atď. so stlačeným pravým tlačidlom myši alebo pera (je to vlastne gumovanie tvarmi, kresbou a pod.).

Keď kreslíme v RNA s čiastočne priesvitnou farbou, znamená to, že do určitej miery môžeme vidieť farbu pod ňou. Informácie o priesvitných bodoch a úrovni priesvitnosti farieb sa však nezachovávajú vo všetkých podporovaných grafických formátoch. Napr. ak uložíme takýto obrázok ako BMP, všetky jeho priesvitné body sa nahradia bodmi momentálnej farby pozadia a všetky čiastočne priesvitné farby sa nahradia podobnými odtieňmi farieb (bez priesvitnosti). Na pohľad bude obrázok vyzerať rovnako. Keď ho však otvoríme v RNA, všetky informácie o priesvitnosti sa stratia.

Formáty, ktoré zachovávajú presné informácie o priesvitnosti sú RNA, LGF, DIB a TGA. V určitom rozsahu sú tieto informácie zachované aj pri formátoch ANI, CUR, ICO, GIF a PNG.


Okná a panely s nástrojmi

Okná a panely s nástrojmi zabezpečujú rýchly prístup k väčšine funkcií a nástrojov RNA. Každú z týchto funkcií môžeme zvoliť aspoň dvoma rôznymi spôsobmi, väčšinou cez príkazy ponuky alebo cez klávesové skratky. Nižšie nájdeme všetky okná a panely s nástrojmi, ktoré sa používajú v pokročilom nastavení RNA. Aby sme ich tu názorne popísali, každý panel a okno sme zobrazili nezakotvené, takže môžeme vidieť aj jeho titulný riadok. Okná a panely s nástrojmi sú zobrazené nielen v bežnom stave, ale aj v stave, kedy nastavujeme prostredie – všetky tlačidlá a ich ostatné prvky sú zvýraznené, takže si môžeme ľahko zapamätať ich tvar.

  • Hlavný panel
  • Panel Tvary
  • Panel Maľovanie a efekty
  • Panel Štetce
  • Panel Paleta
  • Okno Pečiatky
  • Panel Animácia
  • Obsah
  • Pomôcka pre voľbu farby
  • Okno Nastavenie Lupy
  • Panel Hroty
  • Okno Nastavenie farieb
  • Okno Nastavenie nástrojov
  • Stavový riadok


Panel Animácia

Tento panel obsahuje tlačidlá :

Predchádzajúca fáza

Každé kliknutie na toto tlačidlo zobrazí na stránke predchádzajúcu fázu animovaného obrázka (okamžite, teda bez dodržania zodpovedajúcej dĺžky trvania). Ak je práve zobrazená prvá fáza, ďalšie kliknutie zobrazí poslednú fázu – a to aj v prípade, keď je vypnuté opakovanie animácie.

Ak je ukážka v režime Prehrať normálne alebo Prehrať odzadu a klikneme na toto tlačidlo, opakovanie ukážky sa preruší.

Nasledujúca fáza

Každé kliknutie na toto tlačidlo zobrazí na stránke nasledujúcu fázu animovaného obrázka (okamžite, teda bez dodržania zodpovedajúcej dĺžky trvania). Ak je práve zobrazená posledná fáza, ďalšie kliknutie zobrazí prvú fázu – a to aj v prípade, keď je vypnuté opakovanie animácie.

Ak je ukážka v režime Prehrať normálne alebo Prehrať odzadu a klikneme na toto tlačidlo, opakovanie ukážky sa preruší.

Prehrať odzadu

Toto tlačidlo prepne zobrazenie do režimu Ukážka (ak už nie je zapnutý) a začne prehrávať tú istú sériu fáz, ako keď stlačíte Prehrať normálne, ale v obrátenom poradí (a dodržiava dĺžky trvania jednotlivých fáz).

Ak má obrázok zapnutú voľbu opakovanie animácie a stlačíme tlačidlo Prehrať odzadu, séria fáz sa opakovane prehráva odzadu v animačnej slučke.

Ak znovu stlačíme tlačidlo Prehrať odzadu, režim ukážky sa zatvorí a RNA sa vráti do režimu Maľovanie.

Zastaviť prehrávanie

Funguje iba v režime Ukážka. Zastaví prehrávanie série fáz. Ak na toto tlačidlo znova klikneme, prehrávanie sa opäť rozbehne. Ak ale klikneme na tlačidlo Prehrať odzadu a Prehrať normálne, RNA sa vráti späť do režimu Maľovanie.

Prehrať normálne

Toto tlačidlo prepne zobrazenie do režimu Ukážka (ak už nie je zapnutý) a začne prehrávať celú sériu fáz zo záberu, ktorý sme si zvolili v okne Obsah. Zodpovedajúce dĺžky trvania jednotlivých fáz určujú, ako dlho bude fáza zobrazená (kým ju nenahradí ďalšia fáza).

Ak má obrázok zapnutú voľbu opakovanie animácie a stlačíme tlačidlo Prehrať normálne, séria fáz sa opakovane prehráva v animačnej slučke. Ak sme v okne Obsah vybrali viacero záberov, všetky fázy sa zobrazia za sebou jedna po druhej.

Ak znovu stlačíme tlačidlo Prehrať normálne, režim ukážka sa zatvorí a RNA sa vráti do režimu Maľovanie.

Vložiť pred fázu

Vloží novú prázdnu fázu pred označenú fázu. Nová fáza bude mať tie isté nastavenia (veľkosť, farba pozadia a obrázok pozadia) ako označená fáza.

Vložiť za fázu

 Vloží novú prázdnu fázu za označenú fázu. Nová fáza bude mať tie isté nastavenia (veľkosť, farba pozadia a obrázok pozadia) ako označená fáza.

Odstrániť fázu

Vymaže označenú fázu.

Minimalizovať obrázok

Pozrime podrobne pri príkaze Animácia/Minimalizovať.

Zobraziť základný bod

To isté dosiahneme, ak zvolíme príkaz Zobrazenie/Zobraziť základný bod.

Viac podrobností nájdeme v časti o základných bodoch a pri opise dialógového okna Základný bod.

Priesvitky

Zapne alebo vypne nástroj Priesvitky, pozri detaily o príkaze Zobrazenie/Priesvitky.

O paneli Animácie sa dozvieme ešte viac v časti Ukážka animácie.


Panel Štetce

Obsah tohto panelu závisí od zvoleného štetca. Viac detailov nájdeme v časti Voľba farby a priesvitnosti. Keď si zvolíme typ štetca, v paneli Štetce sa zobrazí sada rovnakých nástrojov v najtypickejších prirodzených farbách.

Aby sme zvolili štetec:

  • kliknime na šedé šípky (pravú alebo ľavú) na vrchu panela a listujme medzi všetkými typmi štetcov, alebo
  • kliknime na šedý štetec medzi šípkami. Otvorí sa ponuka, ktorá obsahuje zoznam všetkých dostupných štetcov.

Kedykoľvek si vyberieme iný typ štetca, na paneli Paleta sa zobrazí taká skupina farieb, ktorá zodpovedá najbežnejším odtieňom pre daný štetec.


Pomôcka pre voľbu farby

Umožňuje zobraziť alebo nastaviť označenú farbu na kreslenie, maľovanie, vypĺňanie, nahrádzanie farby, pridávanie textu atď. Toto okno obsahuje:

  • Jeden z troch možných farebných modelov. Podrobnosti nájdeme v časti Voľba farby a priesvitnosti.
  • Nastavenie priesvitnosti – môžeme tu skúmať alebo zmeniť úroveň priesvitnosti nastavenej farby tým, že myšou alebo perom ťaháme malý trojuholník na spodnom okraji okna doľava alebo doprava. Hodnoty sa pohybujú medzi 0% a 100%, alebo medzi 0 a 255 – v závislosti od nastavenia v položke Nastavenie prostredia/Iné.

Ak chceme zmeniť farebný model, vyberme príkaz Zobrazenie/Farebný model.


Panel Nastavenie farieb

Okno Nastavenie farieb

Okno Nastavenie farieb zobrazí kód momentálne zvolenej farby. Farba je znázornená v tvare RGB (Červená – Zelená – Modrá) aj HSV (Odtieň – Sýtosť – Jas). Tu môžeme skúmať a meniť nastavenie farby.

Keď upravíme ktorékoľvek z nastavení, obnovia sa aj nastavenia v Palete, v pomôcke pre voľbu farby a ukážke farby v Stavovom riadku. A naopak, výber farby rôznymi inými spôsobmi obnoví nastavenia v tomto okne.

Ak zvolíme v Zobrazenie/Farebný model príkaz Použiť paletu a vyberieme si farbu, ktorá sa nezhoduje so žiadnou farbou z modelu paleta, v pomôcke pre voľbu farby sa nezobrazí žiadny výber. Okno Nastavenie farieb tiež ukazuje nastavenú úroveň priesvitnosti farby. Táto úroveň je priamo spojená s nastavením priesvitnosti pomôcku pre voľbu farby. Hodnoty sa pohybujú medzi 0% a 100%.


Hlavný panel

Obsahuje tlačidlá na:

  • Otváranie, Ukladanie a Tlač obrázka. Zhodujú sa s príkazmi Súbor/Otvoriť..., Súbor/Uložiť a Súbor/Tlačiť... .
  • Zmazanie obrázka. Toto tlačidlo sa zhoduje s príkazom Maľovanie/Zmazať obrázok.
  • Nastavenie obrázka. Toto tlačidlo sa zhoduje s príkazom Zobrazenie/Nastaviť obrázok.
  • Vystrihovanie, kopírovanie a prilepenie objektu, s ktorým práve pracujeme. Môže to byť záber, fáza alebo oblasť. Tieto tlačidlá sa zhodujú s príkazmi Úpravy/Vystrihnúť, Úpravy/Kopírovať a Úpravy/Prilepiť.
  • Naberanie farby a úrovne priesvitnosti z obrázka. Viac podrobností nájdeme v časti Voľba farby a priesvitností.
  • Späť a znovu. Tieto tlačidlá zodpovedajú príkazom Úpravy/Späť a Úpravy/Znovu.
  • Vyhladzovanie hrán – vypnutie a zapnutie.
  • Nastavenie povrch. Viac podrobností nájdeme v časti Práca s povrchmi papiera.
  • Nastavenie motívu. Viac podrobností nájdeme v časti Práca s motívmi.
  • Nastavenie súmernosti, konkrétne súmernosti vľavo, vpravo, hore aj dolu, súmernosti vľavo a vpravo, súmernosti hore a dolu a nastavenie súmernosti. Viac podrobností nájdeme v časti Práca so súmernosťou.
  • Zobraziť/skryť Pečiatky. Toto tlačidlo sa zhoduje s príkazom Zobrazenie/Pečiatky.
  • Oblasť. Zhoduje sa s príkazom Maľovanie/Oblasť/Označiť oblasť.
  • Prepínanie medzi momentálnym zväčšením alebo zmenšením a normálnym zobrazením (100% veľkosť). Viac podrobností nájdeme v popise okna Nastavenie lupy.
  • Priesvitky – vypnutie a zapnutie. Viac podrobností nájdeme v popise príkazu Zobrazenie/Priesvitky.


Panel Hroty

Každý štetec a efekt má vopred určenú veľkosť hrotu. Ak chceme vybrať inú veľkosť hrotu ako je nastavená, použijeme panel Hroty. Tento panel obsahuje dve skupiny nastavení:

  • Veľkosť hrotu. Hodnoty sa môžu pohybovať medzi 1 a 100. Toto nastavenie funguje pre všetky štetce, efekty aj tvary.
  • Tvary hrotu. Môžeme si vybrať jeden z týchto tvarov: okrúhly hrot, štvorcový hrot, štetinový hrot, náhodný hrot, vlastný hrot a špeciálny hrot. Ak chcete nastaviť vlastný hrot, musíte najprv určiť nejakú oblasť obrázka. Potom ju zvolíme ako hrot pomocou možnosti Maľovanie/Oblasť/Kresliť s oblasťou. Tvar hrotu môžeme nastaviť iba pri efektoch. Na obrázku dole sú zobrazené výsledky gumovania s rozličnými tvarmi hrotov. Úplne naľavo bol použitý okrúhly hrot s úrovňou priesvitnosti nastavenou na 80%.

Ak chceme použiť rôzne tvary hrotov pre kreslenie, zvolíme možnosť základné kreslenie a vyberieme tvar a veľkosť hrotu a kreslíme čiary alebo akékoľvek iné tvary (môžeme kresliť aj od ruky).


Obsah

Panel Obsah je najdôležitejším panelom na prácu s viacerými obrázkami alebo so sériami obrázkov (najmä s obrázkami RNA a LGF, ale aj s animovanými GIF súbormi, animovanými ikonami atď.). Pomôže nám usporiadať si všetky obrázky, ktoré máme otvorené na pracovnej ploche. V rámci jedného obrázka nám pomáha organizovať všetky jeho zábery. V zvolenom zábere nám pomáha usporiadať si všetky jeho fázy.

Viac podrobností nájdeme v časti Obsah.


Panel Maľovanie a efekty

Skladá sa z dvoch častí. Horná časť obsahuje všetky typy dostupných štetcov (fixka, kaligrafická fixka, ceruzka, vodová farba, temperová farba, gélová farba, akrylová farba, vosková pastelka, olejová pastelka, krieda, uhlík a sprej). Spodná časť obsahuje všetky dostupné efekty (základné kreslenie, gumovanie, farbenie, rozmazanie, stmavenie, vyhladenie, zaostrenie, vytváranie obrysov).

Úplné informácie o štetcoch a efektoch nájdeme v častiach:

  • Voľba štetca
  • Používanie efektov


Panel Paleta

Tento panel sa zvyčajne zobrazuje v ľavej dolnej časti hlavného okna. Jeho obsah závisí od zvoleného typu štetca (nižšie môžeme vidieť rôzne voľné palety pre ceruzku, vodovú farbu, voskovú pastelku a uhlík).

Farby z panelu Paleta môžeme použiť dvojakým spôsobom:

  • Ak sme si už predtým vybrali farbu, môžeme ju teraz upraviť tak, že nakrátko namočíme štetec do ďalšej farby a namiešame nový odtieň. Čím dlhšie budeme miešať, tým viac farby z palety sa na štetec pridá. Túto vlastnosť môžeme použiť vtedy, ak chceme napr. vytvoriť jemné prechody medzi farbami.

  • Momentálnu farbu na štetci môžeme úplne nahradiť inou farbou z palety, ak do nej ponoríme štetec na dlhší čas a vytrvalo miešame, alebo ak na ňu klikneme pravým tlačidlom myši (resp. grafického pera tabletu so stlačeným tlačidlom).

Viac detailov nájdeme v časti Voľba farby a priesvitnosti a v časti Používanie efektov.


Panel Tvary

Pozostáva z tlačidiel na vkladanie tvarov (kreslenie od ruky – čiara a bodky, jednoduchá úsečka, lúče, obvod elipsy/kružnice, obvod obdĺžnika/štvorca, vyplnená elipsa/kružnica, vyplnený obdĺžnik/štvorec, obvod pravidelného mnohouholníka, vyplnený pravidelný mnohouholník, obvod hviezdy, vyplnená hviezda, otvorená krivka, uzavretá krivka, vyplnená krivka, otvorený mnohouholník, uzavretý mnohouholník, vyplnený mnohouholník), na výplň a nahradenie farieb, vkladanie textu a nastavenie tvaru hrotu.

Podrobnejšie informácie nájdeme v častiach:

  • Vkladanie tvarov
  • Výplň a nahradenie farby
  • Vkladanie textu
  • Nastavenie hrotu


Okno Pečiatky

V hornej časti okna Pečiatky je názov zvolenej kategórie. Ak chceme vidieť všetky kategórie, kliknime na šípku vpravo od mena kategórie – vtedy sa otvorí ponuka všetkých kategórií. Pod názvom každej kategórie sa skrýva celá skupina súvisiacich pečiatok. Kliknime na tú z nich, ktorú chceme použiť. Potom kliknime na náš obrázok – na tomto mieste sa otlačí zvolená pečiatka. V spodnej časti okna Pečiatky sú štyri voľby, ktoré môžeme meniť:

  • Veľkosť pečiatok (podrobnosti pozri v časti Jednoduché používanie pečiatok).
  • Medzery medzi dvoma za sebou idúcimi fázami pečiatky (ak sme zvolili pečiatku, ktorá obsahuje sériu obrázkov, a teraz myšou alebo grafickým perom ťaháme po papieri).
  • Náhodné rozmiestenie, podrobnosti pozri v časti Príkazy ponuky Pečiatky.
  • Pomiešané, podrobnosti pozri v časti Príkazy ponuky Pečiatky.

Ak sa chceme podrobne oboznámiť s používaním pečiatok, pozrime sa na časť Vkladanie pečiatok.

  • Jednoduché používanie pečiatok
  • Kreslenie pečiatkou
  • Pečiatka ako oblasť
  • Vkladanie pečiatky pravým tlačidlom myši
  • Pečiatka so sériou obrázkov
  • Príkazy ponuky Pečiatky
  • Pečiatkovanie pomocou tabletu
  • Pridávanie vlastných pečiatok


Stavový riadok

Nachádza sa v spodnej časti hlavného okna RNA. Poskytuje informácie o momentálne zvolenej farbe a možnostiach nástrojov alebo ponúk spolu s inými užitočnými detailmi.

V ňom nájdeme:

  • Ukážku farby, t.j. momentálne zvolenú farbu pre kreslenie, maľovanie, vypĺňanie, nahrádzanie farby, pridávanie textu atď.
  • Ďalšie informácie o práve zvolenom nástroji alebo príkaze. Keď otvoríme ponuku (kliknutím ľavého alebo pravého tlačidla myši), v prvom poli stavového riadku sa zobrazí krátky text – opis tohto nástroja alebo príkazu.
  • Ďalšie informácie o tlačidlách z každého okna a panelu nástrojov (ak na ne ukážeme myšou alebo grafickým perom).
  • Aktuálnu pozíciu kurzoru (ak ním hýbeme vnútri papiera).
  • Keď určujeme oblasť, tretie a štvrté pole stavového riadka uvádzajú pozíciu ľavého horného rohu vymedzeného obdĺžnika. Posledné dve polia ukazujú momentálnu výšku a šírku tohto obdĺžnika.


Okno Nastavenie nástrojov

Toto okno obsahuje tri nastavenia:

  • Veľkosť hrotu: Hodnotou je číslo od 1 do 100 a vzťahuje sa na všetky umelecké štetce, všetky efekty a vkladanie pečiatok.
  • Tolerancia farieb: Hodnota je od 0% do 100% a prejavuje sa pri vypĺňaní a nahrádzaní farby: ak zvolíme farbu, zapneme nástroj Výplň a klikneme na bod na obrázku, zvolená farba vyplní súvislú oblasť v okolí tohto bodu, čiže oblasť, v ktorej majú všetky body rovnakú farbu ako označený bod. To však platí iba vtedy, ak nastavenie Tolerancia farieb má hodnotu 0%. Ak by malo vyššiu hodnotu, zvolená farba vyplní v oblasti aj body podobnej farby. Túto podobnosť určuje práve Tolerancia farieb – čím je vyššia, tým viac príbuzných odtieňov považuje za “rovnaké”, pozri obrázok dolu. Podobne reaguje aj nástroj Nahradenie farby.
  • Hustota bodiek: Hodnota je od 0% do 100%. Určuje hustotu bodiek pre Náhodný hrot.


Okno Nastavenie lupy

Toto okno obsahuje:

  • Úroveň zväčšenia/zmenšenia zobrazeného obrázka. Hodnoty sa pohybujú od 5% do 99% (zmenšenie), alebo od 100% až do 25600% (zväčšenie). Ak stlačíme Ctrl W alebo Ctrl +, obrázok sa zväčší o jeden krok v poradí 5%, 10%, 20%, 25%, 33%, 50%, 100%, 200%, 300%, … atď. Ak stlačíme Ctrl Q alebo Ctrl –, obrázok sa zmenší o jeden krok v takom istom poradí.
    Ďalšie možnosti, ako zväčšiť či zmenšiť zobrazenie obrázka, sú tlačidlo Lupa na Hlavnom paneli alebo príkaz Zobrazenie/Lupa.
  • Náhľad celého obrázka so zvýraznenou oblasťou, ktorá je práve zväčšená na papieri. Tento zvýraznený obdĺžnik môžeme pomocou myši (alebo grafického pera) posúvať po náhľade na obrázok. Po zväčšenom obrázku sa tiež môžeme pohybovať pomocou vodorovných a zvislých posúvačov na okrajoch stránky.

  • Prepínacie okienko Priesvitné body. Ak je zaškrtnuté, všetky priesvitné body obrázka budú označené čiernou bodkou v strede zväčšeného bodu (aspoň na 400%). Nepomýľme si však priesvitné body obrázka (t.j. určité časti obrázka, ktoré sú úplne priesvitné, keď sa používajú ako napr. RNA či LGF tvary, ICO, ANI, CUR, GIF, DIB) s čiastočne priesvitnými farbami.
  • Prepínacie okienko Mriežka. Ak je zaškrtnuté, zobrazí sa pomocná mriežka čiar (ak je obrázok zväčšený aspoň na 400%). Tieto čiary nám pomôžu pri maľovaní, kreslení a orientácii v zväčšenom obrázku.
    Štyri obrázky dolu znázorňujú všetky kombinácie prepínacích okienok Priesvitné body a Mriežka.

Viac podrobností nájdeme v časti Lupa.


Slovníček základných pojmov a výrazov

  • uzavretý mnohouholník
  • uzavretá krivka
  • záber
  • fáza
  • obrázok
  • Imagine
  • RNA súbor
  • LGF súbor
  • LGW súbor
  • LogoMotion
  • motív
  • mnohouholník
  • krivky a mnohouholníky
  • podporované grafické formáty
  • panel nástrojov
  • okno s nástrojmi


Fáza

Záber každého obrázka môže byť buď jednoduchý obraz, alebo séria obrázkov nazývaných fázy. Ak záber s viacerými fázami použijeme napr. ako tvar korytnačky v prostredí Imagine, fázy sa budú automaticky opakovať, takže vznikne ilúzia animovaného filmu.

RNA nám ponúka silné prostredie pre vytváranie takýchto animácii zo sérií fáz. Tieto série si môžeme vytvárať a prezerať v Ukážke animácie. Nezabudnime, že pri animovaní série fáz je dôležitá aj dĺžka trvania.


Imagine

Imagine je nová generácia prostredia a programovacieho jazyka Logo, ktorú vyvinulo vydavateľstvo edukačného softvéru Logotron, pozri www.logo.com. Imagine vznikol ako moderný nástroj pre žiakov, študentov, učiteľov a profesionálnych autorov edukačného softvéru. Žiaci a študenti v ňom môžu rozvíjať svoje tvorivé schopnosti, môžu v ňom kresliť a vytvárať animácie, vytvárať webové stránky, riešiť tradičné logovské problémy, vyvíjať multimediálne aplikácie, využívať hlasový vstup a výstup, modelovať, konštruovať prostredia a mikrosvety pre objavovanie, komunikovanie a konštruovanie poznania, vyvíjať prezentácie a projekty pre rozvoj matematického a informatického myslenia, pre prácu s údajmi a pod.

Imagine má objektovo-orientovanú štruktúru a podporuje v úplnej miere objektové programovanie, ktoré je zaujímavým a nenásilným spôsobom zakomponované do tradičného logovského myslenia. Podporuje hierarchiu objektov a správaní, paralelné nezávislé procesy, poskytuje základné nástroje na maľovanie voľnou rukou. Základným cieľom prostredia a jazyka Imagine je poskytnúť žiakom, študentom a učiteľom inšpirujúci nástroj na podporu učenia sa objavovaním a konštruovaním.

Medzi zaujímavé vlastnosti prostredia Imagine patria:

  • Korytnačky a korytnačia geometria.
  • Jednoduché a viacnásobné korytnačky.
  • Pomôcky a ďalšie grafické súčiastky.
  • Udalosti a paralelné procesy.
  • Úplná objektová štruktúra so základnými a používateľmi definovanými triedami.
  • Nástroje pre nekorytnačie kreslenie.
  • Multimédia a hlasový vstup/výstup.
  • Priame manipulácie a bohaté prostredie pre vývoj mikrosvetov.


Krivky a mnohouholníky

Mnohouholníky sú útvary pospájané z rôzne dlhých úsečiek. Krivky sú oblé čiary spájajúce niekoľko bodov.

Aj mnohouholníky aj krivky môžu byť buď otvorené, uzavreté alebo vyplnené.


LGF súbor

Vlastný grafický formát pre uchovávanie obrázkov v prostredí Imagine a LogoMotion. LGF súbory môžu obsahovať jeden alebo niekoľko (komprimovaných) obrázkov.


LGW súbor

Vlastný grafický formát pre uchovávanie obrázkov v prostredí Comenius Logo. RNA, Imagine a LogoMotion naďalej akceptuje tento formát. Vylepšením formátu LGW vznikol formát LGF súborov.


LogoMotion

Je to predchodca editora RNA, určený na editovanie obrázkov a animácií. V spolupráci s prostredím Imagine dokáže vytvárať a modifikovať animované obrázky, ktoré používame napr. ako tvary korytnačiek. V grafickom editore LogoMotion môžeme vytvárať a upravovať obrázky, ktoré použijeme v prostredí Imagine alebo aj mimo neho.

LogoMotion poskytuje bohatú škálu nástrojov na kreslenie a maľovanie, vkladanie textu do grafickej plochy s využitím rôznych druhov písma, štýlov, farieb a veľkostí. Tak isto dovoľuje kresliť základné geometrické tvary (čiary, kruhy, obdĺžniky, elipsy, vyplnené elipsy, zaoblené krivky a pod.).

LogoMotion môžeme používať aj pri vytváraní a úprave ikon a kurzorov prostredia Windows a tiež dobre spolupracuje so schránkou. Grafický editor LogoMotion umožňuje meniť veľkosť animovaných obrázkov, otáčať ich a farbiť. Poskytuje silné nástroje na vytváranie animácií a animovaných filmov, čiže postupností fáz. Podporuje mnoho ďalších moderných grafických nástrojov.


Mnohouholník

Pozri krivky a mnohouholníky.


Motív

Motív je malý grafický objekt (obrázok, tvar) použitý opakovane namiesto farby napr. pri vypĺňaní mnohouholníkov, obdĺžnikov alebo iných plôch. Motívy sú uložené ako samostatné bitmapy vo formáte *.DIB v priečinku Motívy prostredia RNA.


Obrázok

Obrázky sú zložité grafické údajové objekty prostredia Imagine a editorov RNA a LogoMotion, ktoré sa využívajú napr. ako tvary korytnačiek. RNA nám poskytuje silné prostredie pre ich vytváranie a upravovanie.

Každý obrázok je buď prázdna alebo neprázdna séria záberov. Každý záber je buď jednoduchý obrázok alebo séria obrázkov nazývaných fázy. Je to akýsi „animovaný film“, ktorý znázorňuje napr. pohyb postavičky daným smerom. Viacero záberov teda môže znázorňovať pohyb postavičky rôznymi smermi (napr. chôdzu doprava, chôdzu smerom k nám, chôdzu doľava a chôdzu smerom od nás).

Obrázky sa uchovávajú ako RNA súbory (alebo v staršom formáte ako LGF súbory či obrázky LGW z prostredia Comenius Logo) a používajú sa napr. v projektoch pre Imagine. Okrem vlastného grafického obsahu má každý obrázok pripojené aj ďalšie informácie, a to o:

  • dĺžke trvania pre každú fázu,
  • základnom bode každej fázy,
  • štýle animácie – podľa smeru alebo podľa čísla záberu,
  • základnom uhle,
  • opakovaní animácie (zapnuté alebo vypnuté).


Okno s nástrojmi

Je podobné ako panel nástrojov, môžeme však meniť jeho veľkosť a rozloženie komponentov podľa vlastnej potreby, napr. do dvoch riadkov a pod.

Okno s nástrojmi pre prácu s textom.


Panel nástrojov

Panel nástrojov je úzky zvislý alebo vodorovný pruh – jeden riadok alebo jeden stĺpec tlačidiel alebo iných riadiacich prvkov. Môže byť buď:

  • Ukotvený pri niektorom okraji hlavného okna RNA, alebo
  • Ukotvený pri inom, už ukotvenom paneli, alebo
  • Voľne umiestený kdekoľvek na ploche.


Podporované grafické formáty

Pre príkaz Súbor/Otvoriť…RNA podporuje tieto grafické formáty:

  • formát Revelation Natural Art *.RNA
  • LogoMotion – obrázkový súbor *.LGF
  • Imagine – súbor s projektom *.IMP
  • Comenius Logo – obrázkový súbor *.LGW
  • Windows Bitmap *.BMP
  • Device Independent Bitmap *.DIB
  • JPEG obrázok *.JPG
  • GIF – animovaný obrázok *.GIF
  • Animovaný kurzor *.ANI
  • Kurzor *.CUR
  • Ikona *.ICO
  • Windows Metafile *.WMF a *.EMF
  • Targa *.TGA
  • Portable Network Graphics *.PNG

Pre príkaz Súbor/ Uložiť ako RNA podporuje tieto grafické formáty:

  • formát Revelation Natural Art *.RNA
  • LogoMotion – obrázkový súbor *.LGF
  • Windows Bitmap *.BMP
  • Device Independent Bitmap 32bpp *.DIB
  • JPEG obrázok *.JPG
  • Animovaný kurzor *.ANI
  • Kurzor *.CUR
  • Ikona *.ICO
  • GIF – animovaný obrázok *.GIF
  • Targa *.TGA
  • Portable Network Graphics *.PNG


RNA súbor

Vlastný grafický formát pre uchovávanie obrázkov v prostredí RNA. RNA súbory môžu obsahovať jeden alebo niekoľko (komprimovaných) obrázkov.


Uzavretá krivka

Pozri krivky a mnohouholníky.


Uzavretý mnohouholník

Pozri krivky a mnohouholníky.


Záber

Základný prvok zloženého obrázka v RNA. Zábery obvykle znázorňujú postavu či iný prvok v rôznych smeroch a pohyboch (napr. chôdza doprava, chôdza smerom k nám, chôdza doľava a chôdza smerom od nás).

V tomto príklade bol kompas pre všetky zábery rozdelený na štyri úseky (každému úseku zodpovedá jeden záber, preto má tento obrázok štyri zábery). Celkový počet záberov v obrázku nie je obmedzený.

Záber môže byť buď jednoduchý obrázok, alebo séria obrázkov nazývaných fázy. Veľkosť záberu nie je ničím obmedzená (okrem obmedzenia grafickou pamäťou prostredia Windows).


Farebný model

Otvorí ponuku s tromi odlišnými farebnými modelmi. Umožní nám vybrať si, ktorý z nich budeme používať v pomôcke pre voľbu farby, v dialógovom okne Nastavenie papiera pri voľbe farby pozadia a pri Ukážke animácie.


Fázy

Otvára ponuku poskytujúcu opačný príkaz ku Zmeniť na fázy. Tento príkaz zmení všetky fázy zobrazené v Obsahu na jednotlivé zábery.


Hrot

Otvára ponuku, ktorá umožňuje zvoliť veľkosť hrotu a pri používaní efektov aj tvar hrotu. Ďalšie detaily nájdeme v časti opisujúcej panel Hroty.


Iné

Otvorí ponuku obsahujúcu zoznam ďalších panelov a okien s nástrojmi, ktoré sú k dispozícii v danej konfigurácii. Označme panel či okno s nástrojmi, ktoré chceme zobraziť. Zrušme označenie panelu alebo okna, ktoré chceme skryť.

Nastavenie prostredia…

Príkaz otvorí dialógové okno Nastavenie prostredia. Zvoľme túto možnosť, ak chceme nastaviť inú konfiguráciu alebo upraviť prostredie.


Kopírovať, Ctrl+C

Vytvorí kópiu celého obrázka (alebo viacerých obrázkov), záberu (alebo viacerých záberov), alebo fázy (či viacerých fáz) a vloží ju/ich do schránky.


Nastavenia lupy, F8

Otvorí alebo skryje okno Lupa.


Minimalizovať, Ctrl+M

Zmenší označenú fázu (či viacero fáz), alebo záber (či viacero záberov), alebo celý obrázok zrušením všetkých vonkajších stĺpcov a riadkov obsahujúcich len priesvitné body. Táto operácia však neporuší umiestnenie základného bodu obrázka.

Tento príkaz môžeme vykonať aj kliknutím na tlačidlo Minimalizovať obrázok na Hlavnom paneli.


Motív

Otvorí dialógové okno Motív.


Lupa

Otvorí vnorenú ponuku s dvoma skupinami príkazov. Pomocou možností v prvej skupine môžeme obrázok zväčšiť, Zobraziť normálne (t.j. v 100% veľkosti), alebo zmenšiť.

Kliknutím na príkaz Zväčšiť sa zväčšenie zvýši o jeden stupeň. Kliknutím na príkaz Zmenšiť sa zväčšenie o jeden stupeň zmenší. Môžeme použiť aj klávesové skratky: Ctrl W alebo Ctrl num + obrázok o jeden stupeň zväčší, Ctrl Q alebo Ctrl num – obrázok o jeden stupeň zmenší a Ctrl Num * vráti obrázok na 100% veľkosť.

Mriežka

Ak zvolíme túto možnosť, zobrazí sa pomocná mriežka pozostávajúca z čiar (pri zväčšení 400% a viac). Tieto čiary nám pomôžu kresliť, maľovať a orientovať sa vo zväčšenom obrázku.

Priesvitné body

Ak zvolíme túto možnosť, všetky priesvitné body sa pri zväčšení od 400% zvýraznia malou čiernou bodkou v strede zodpovedajúcich štvorčekov mriežky. Nezmýľme si však priesvitné body s čiastočne priesvitnými farbami.


Nastaviť papier...

Otvorí dialógové okno Nastavenie papiera.


Nastaviť trvanie…, Ctrl+D

Umožní nastaviť dĺžku trvania pre označené fázy alebo zábery alebo celé animované obrázky. Otvorí sa nasledujúce dialógové okno:

Zapamätajme si, že toto dialógové okno nám umožňuje buď zadať presné číslo pre všetky označené fázy, alebo zadať percentá, napr. 80% zmenšovania alebo zväčšovania predchádzajúcej dĺžky trvania pri zachovaní proporcií.


Nastaviť základný bod…, Ctrl+H

Otvára dialógové okno Základný bod, ktoré nám umožňuje určiť polohu základného bodu pre všetky označené fázy.


Nový, Ctrl+N

Vytvorí nový prázdny hárok papiera (t.j. obrázok s jedným záberom pozostávajúcim z jednej fázy). Jeho šírka, dĺžka a farba pozadia sú rovnaké ako naposledy nastavené hodnoty týchto údajov v dialógovom okne Nastavenie papiera.


Oblasť

Otvára ponuku Oblasť.


Obsah, F4

Otvorí alebo skryje okno Obsah.


Odstrániť, Del

Vymaže práve označený prvok – záber (alebo niekoľko záberov), fázu (alebo niekoľko fáz), prípadne označenú oblasť nášho obrázka.


Otvoriť..., Ctrl+O

Zobrazí dialógové okno Otvoriť s okienkom Ukážka. Priečinok, ktorý sa zobrazí v dialógovom okne, je buď priečinok Moje obrazky, alebo priečinok, ktorý sme naposledy použili v ponuke Otvoriť.

V dialógovom okne Otvoriť môžeme označiť a otvoriť akýkoľvek obrázok (alebo niekoľko obrázkov, ak sme zvolili viacero súborov) v ľubovoľnom podporovanom grafickom formáte.


Označiť všetko, Ctrl+A

Označí všetky obrázky, ak práve pracujeme s obrázkami. Označí všetky zábery, ak práve pracujeme so zábermi. Označí všetky fázy, ak práve pracujeme s fázami.

Označí celý obrázok, ak sme práve kreslili, maľovali alebo pracovali s obrázkom.


Paleta, F7

Otvorí alebo skryje panel Paleta.


Príkazy ponuky Pečiatky

Ak zvolíme Maľovanie/Pečiatky, otvorí sa nasledujúca ponuka:

Náhodné rozmiestenie

Vypne alebo zapne náhodné rozmiestenie medzi dvojicami susedných odtlačených pečiatok. Všimnime si rozdiel medzi nasledujúcimi radmi robotov – pri druhom rade sme použili náhodné rozmiestnenie.

Ak je Náhodné rozmiestnenie zapnuté, veľkosť medzery sa nastaví ako priemerná hodnota a medzery sa vyberajú náhodne medzi 0 a dvojnásobkom tejto hodnoty (pozri aj časť Kreslenie s pečiatkami).

Pomiešané

Ak kreslíme s pečiatkou ako so sériou obrázkov, všetky jej fázy sa odtlačia v ich skutočnom poradí. Keď ale zvolíme možnosť Maľovanie/Pečiatky/Pomiešané, fázy sa budú odtláčať v náhodnom poradí (až kým túto voľbu opäť nevypneme).

Použiť ako oblasť

Odtlačí zvolenú pečiatku do stredu papiera a ponúkne jej použitie ako s označenou oblasťou, takže pred jej odtlačením na papier môžeme zmeniť jej veľkosť, otáčať ju alebo pracovať s ňou ako s akoukoľvek inou oblasťou.

Použiť ako pozadie

Otvorí ponuku s štyrmi štýlmi (Do stredu, Prispôsobiť, Natiahnuť a Vykachličkovať). Tieto určujú, ako sa pečiatka použije na pozadí papiera. Táto možnosť je zhodná s možnosťou Obrázok pozadia v dialógovom okne Nastavenie papiera.


Pečiatky

Pečiatky, F11

Otvára okno s Pečiatkami.


Povrch

Otvorí dialógové okno Povrch.


Prevrátiť poradie, Ctrl+R

Prevráti poradie všetkých označených fáz, alebo všetkých fáz práve označených záberov, alebo animovaných obrázkov.


Priesvitky

Otvorí ponuku, v ktorej zvolíme, čo chceme vidieť „cez“ práve zobrazenú fázu: môžeme si zvoliť buď jednu alebo dve predchádzajúce fázy, alebo jednu fázu nasledujúcu. To isté môžeme dosiahnuť aj tak, že kliknime na tlačidlo Priesvitky na paneli Animácia.

Uvedomme, že tieto obrázky “duchov” nie sú časťou zobrazeného obrázka. Slúžia iba ako orientačná pomôcka pri kreslení, maľovaní a vytváraní animácie.

Ak je zapnutá voľba Priesvitky a necháme tiež zobraziť základný bod, obrázok “duchov” na pozadí je pripútaný ku krížiku základného bodu a ak hýbeme týmto krížikom, hýbe sa spolu s ním. Túto možnosť oceníme pri vytváraní niektorých animácií.

Tento obrázok má dve fázy. Na prvej sme použili pravidelné tvary k vytvoreniu kostry nášho obrázka. Na druhej – so zobrazením predchádzajúcej fázy – ju využívame ako akúsi šablónu.


Prilepiť, Prilepiť pred, Prilepiť za, Ctrl+V

Ak sme vystrihli alebo skopírovali vybranú časť obrázka, príkaz Prilepiť vloží do nášho obrázka kópiu obsahu, ktorý je momentálne uložený v schránke.

Ak sme vystrihli alebo skopírovali jeden alebo viacero záberov alebo jednu či viacero fáz do schránky, možnosť Prilepiť z ponuky Úpravy bude nahradená dvoma možnosťami, a to Prilepiť pred a Prilepiť za. Tieto vložia kópiu obsahu zo schránky buď:

  • pred/za označený záber, ak sme vystrihli či kopírovali záber alebo zábery, alebo
  • pred/za označenú fázu, ak sme vystrihli či kopírovali fázu alebo fázy.

Ak chceme vystrihnúť alebo kopírovať záber a vložiť ho niekam ako fázu, vystrihneme či skopírujeme ho a vložíme na novú pozíciu cez zodpovedajúci príkaz obsahu (t.j. cez možnosti Obsahu fáz). Podobne použijeme možnosti obsahu, ak chceme prilepiť fázu ako obrázok alebo ako záber atď.


Skončiť, Alt+X

Zatvorí všetky obrázky. Ak obsahujú neuložené zmeny, RNA nás vyzve k ich uloženiu.


Späť, Ctrl+Z

Urobí jeden krok späť z postupu na vrátenie krokov.


Súmernosť

Otvára ponuku so štyrmi možnosťami súmernosti. Vyberme buď Nepoužívať, alebo jednu z troch možností pre súmerné kreslenie, maľovanie, pečiatkovanie a písanie textu.

Všimnime si tiež zodpovedajúce ikony na Hlavnom paneli spolu s tlačidlom Nastaviť súmernosť.


Štetce, F5

Otvorí alebo skryje panel Štetce.


Štetec

Otvára ponuku so všetkými dostupnými Štetcami. Posledná možnosť efekt poskytuje ďalšiu ponuku s dostupnými efektmi.


Tlačiť..., Ctrl+P

Zobrazí dialógové okno Tlačiť obsahujúce Rozsah tlače, Rozloženie a Ukážku, a tiež štandardné tlačidlá Nastaviť tlačiareň, Vytlačiť a Zrušiť.

V časti Rozsah tlače sa môžeme rozhodnúť, či chceme tlačiť iba označenú fázu (fázy) alebo všetky fázy obrázka.

Položky časti Rozloženie nám umožnia rozhodnúť sa, či chceme vytlačiť jednotlivé fázy spolu s ich číslom, umiestniť jednotlivé fázy do jedného riadku, alebo či chceme proporcionálne zmeniť veľkosť obrázka tak, aby pokrýval celú stranu, ak je to možné.

V oblasti Ukážka vidíme, ako bude vytlačená strana vyzerať. Môžeme experimentovať s rôznymi kombináciami nastavení v Rozsah tlače a Rozloženie spolu s Nastavením tlačiarne…, napríklad:

Všimnime si, že sa vytlačí aj farba pozadia papiera a obrázok na pozadí.


Transformovať…, Alt+T

Otvára dialógové okno Transformovať obrázok.


Tvar

Otvára vnorenú ponuku príkazov pre:

  • Vkladanie tvarov.
  • Výplň a nahradenie farieb.
  • Vkladanie textu.

Všimnime si, že väčšina ponúkaných príkazov otvára ďalšiu ponuku s príbuznými príkazmi. Napríklad Obdĺžnik ponúka možnosti Obvod a Výplň.


Ukážka animácia, F9

Spúšťa a vypína Ukážku animácie.


Uložiť, Ctrl+S

Uloží označený obrázok (so všetkými jeho zábermi a fázami) do súboru v určenom podporovanom grafickom formáte. Ak ukladáme svoj obrázok prvýkrát, otvorí sa dialógové okno Uložiť, takže ho môžeme aj pomenovať.

Ak chceme zmeniť meno súboru, formát alebo miesto uloženia, musíme zvoliť príkaz Uložiť ako... .


Uložiť ako..., Alt+F2

Uloží označený obrázok pod novým menom, v inom grafickom formáte alebo s novým umiestením. Ak chceme uložiť súbor pod jeho existujúcim menom, formátom a umiestnením, použijeme možnosť Uložiť.


Vložiť pred

Vloží nový záber pred označený záber, ak práve pracujeme so zábermi. Vloží novú fázu pred označenú fázu, ak práve pracujeme s fázami.

Nový záber či fáza má rovnakú veľkosť a nastavenia pozadia, aké má susedný záber či fáza.


Vložiť za, Ins

Vloží nový záber za označený záber, ak práve pracujeme so zábermi. Vloží novú fázu za označenú fázu, ak práve pracujeme s fázami.

Nový záber či fáza má rovnakú veľkosť a nastavenia pozadia, aké má susedný záber či fáza.


Vyhladzovanie hrán, Alt A

Táto funkcia (a jej zodpovedajúce tlačidlo na Hlavnom paneli) zapína a vypína mechanizmus na vyhladzovanie hrán. Vyhladzovanie hrán zjemňuje a vyrovnáva okraje čiar, tvarov a písmen pridaním ďalších bodov s rôznymi stupňami priesvitnosti zvolenej farby.


Vystrihnúť, Ctrl+X

Odstráni práve označený objekt - t.j. odstráni buď (v závislosti od konkrétnej situácie):

  • Označenú časť obrázka, alebo
  • Jeden záber či niekoľko záberov, alebo
  • Jednu fázu či viac fáz

a vloží ju/ich do schránky. Príkaz Vystrihnúť sa nedá použiť, ak je v Obsahu označených viac obrázkov:

Ak práve pracujeme s animovaným obrázkom, t.j. v Obsahu je jeden obrázok vybraný a zvolíme Vystrihnúť, jedna z jeho fáz bude vystrihnutá namiesto celého animovaného obrázka (v závislosti od toho, s ktorou fázou sme naposledy pracovali).


Vytvoriť animáciu…, Alt+G

Otvára dialógové okno Vytvorenie animácie.


Vytvoriť prelínanie, Ctrl+B

Vloží vizuálny prechod (vizuálny priemer, prelínanie) medzi každý pár práve označených fáz záberu alebo viacerých záberov.


Zábery

Otvára vnorenú ponuku, ktorá nám umožní:

  • Vypínať a zapínať Opakovanie animácie.
  • Vypínať a zapínať Animovanie podľa smeru.
  • Určiť Nastavenie základného bodu obrázka.
  • Zmeniť všetky fázy všetkých záberov na jeden záber spájajúci spolu všetky fázy.

Tieto nastavenia (a tiež ďalšie) môžeme meniť aj kliknutím pravého tlačidla myši na okno Obsah.


Základný bod

Ukáže momentálnu pozíciu Základného bodu a zmení kurzor na biely krížik. Ten vyjadruje, že sa chystáme skúmať alebo zmeniť pozíciu základného bodu. Viac detailov nájdeme pri opise dialógového okna Základný bod.


Zatvoriť, Ctrl+F4

Zatvorí obrázok bez toho, aby ukončil aplikáciu. Ak obrázok obsahuje doposiaľ neuložené zmeny, RNA nás vyzve k uloženiu obrázka pred jeho zatvorením.


Zmazať obrázok

Zmaže celý obrázok tak, že ho prekryje priesvitnými bodmi zvolenej farby pozadia a obnoví obrázok na pozadí (ak je nejaký obrázok zvolený). Ak sa obrázok skladá z viacerých záberov s fázami, zmaže sa len práve zobrazené fáza.


Znovu, Shift+Ctrl+Z

Znovu vykoná jeden krok z postupu na vrátenie krokov.


<Mená súborov>

Skupina mien medzi možnosťami Tlačiť a Skončiť sú názvy súborov, s ktorými sme nedávno pracovali v RNA.


Pracujeme s jednotlivým obrázkom

Aby sme využili z RNA čo najviac, mali by sme sa naučiť všetko o jeho nástrojoch, technikách, funkciách a režimoch. Nasledujúci prehľad nám poskytne detailné informácie o dôležitých nástrojoch a funkciách, ktoré budeme potrebovať pri práci s obrázkom.

  • Voľba štetca
  • Voľba farby a priesvitnosti
  • Nastavenie hrotu
  • Vkladanie tvarov
  • Vkladanie textu
  • Postup na vrátenie krokov
  • Výplň a nahradenie farby
  • Práca s motívmi
  • Práca s rôznymi povrchmi papiera
  • Vkladanie pečiatok
  • Používanie efektov
  • Vyhladzovanie hrán
  • Práca so súmernosťou
  • Práca s oblasťou
  • Lupa


Voľba štetca

RNA ponúka širokú škálu kresliacich nástrojov – paletu umeleckých štetcov. Ich použitím vytvoríme prirodzene vyzerajúce maľby. Pre viac technické kresby môžeme namiesto umeleckých štetcov použiť základné kreslenie. Všimnime si, že pri používaní štetcov sú dôležité aj nasledujúce nastavenia:

  • Ktorý typ štetca sme zvolili?
  • Akú farbu a stupeň priesvitnosti sme zvolili?
  • Aká je veľkosť hrotu štetca?
  • Je vyhladzovanie hrán zapnuté alebo vypnuté?
  • Je zvolený špeciálny povrch papiera?
  • Je zvolený motív?
  • Je nastavená niektorá súmernosť?

Pri voľbe štetca kliknime buď na zodpovedajúcu ikonu na paneli Maľovanie a efekty, alebo zvoľme Zobrazenie/Štetce, kde môžeme na vrchu okna listovať medzi štetcami, alebo zvoľme Maľovanie/Štetec a vyberme si zo zobrazenej ponuky.

  • Fixka
  • Kaligrafická fixka
  • Ceruzka
  • Vodová farba
  • Temperová farba
  • Gélová farba
  • Akrylová farba
  • Vosková pastelka
  • Olejová pastelka
  • Krieda
  • Uhlík
  • Sprej


Ceruzka

Ceruzku používame na črtanie a kreslenie hladkých jednoduchých čiar a úhľadných a jemných oblúkov na kreslenie a vyfarbovanie prirodzených obrázkov. Všimnime si, že:

  • Sýtosť farby sa nezvyšuje ani pri opakovaných ťahoch.
  • Ak použijeme ceruzku na kreslenie obrysov, budú jasné, pevné a jednoznačné, zároveň však hladké a plynulé.
  • Ak použijeme tablet s podložkou citlivou na tlak a zväčšíme tlak, stopa bude trochu hrubšia a sýtejšia.
  • Môžeme čiastočne prekryť svetlý odtieň tmavším. Nie je ľahké prekryť tmavý odtieň svetlejším.
  • Musíme byť veľmi opatrní a trpezliví, ak chceme vyfarbiť celú plochu ceruzkou. Ani tak nebude celá plocha úplne jednoliata.
  • Kombinovanie ceruzky a rôznych stupňov priesvitností je mimoriadne vhodné na tieňovanie.


Fixka

Fixku používame na kreslenie jasných a sýtych čiar a malieb. Všimnime si, že:

  • Sýtosť farby sa pri opakovaných ťahoch jemne zvyšuje.
  • Ak použijeme tablet s podložkou citlivou na tlak a grafické pero silnejšie pritlačíme, hrúbka stopy sa zväčší iba jemne. Sýtosť farby ostane rovnaká.
  • Môžeme ľahko prekryť svetlý odtieň tmavším odtieňom, avšak prekryť tmavý odtieň svetlejším je skoro nemožné.
  • Keď prekryjeme jednu farbu druhou, výsledok bude tmavší ako každý z jednotlivých odtieňov.


Kaligrafická fixka

Kaligrafickú fixku používame na kreslenie jasných, sýtych a ostrých čiar a kresieb. Všimnime si, že:

  • Sýtosť farby sa pri opakovaných ťahoch jemne zvyšuje.
  • Ak použijeme tablet s podložkou citlivou na tlak, stopa veľmi citlivo reaguje na tlak pera a smer ťahu.
  • Môžeme ľahko prekryť svetlý odtieň tmavším odtieňom, avšak prekryť tmavý odtieň svetlejším je skoro nemožné.


Akrylová farba

Akrylovú farbu používame pre sýte a jasné maľby. Maľované čiary však nie sú úplne jednoliate; uvidíme stopy jednotlivých štetín štetca. Všimnime si, že:

  • Akrylové farby perfektne prekrývajú spodnú farbu ľubovoľného odtieňa, aj svetlými odtieňmi ľahko prekryjeme tmavšiu farbu. Avšak ani opakovaným nanášaním farby sa nezvyšuje jej sýtosť. Pri opakovaných ťahoch iba zanecháme viac farby na jednom mieste.
  • Ak urobíme jeden dlhý ťah akrylovou farbou, farba sa postupne míňa. Ak chceme mať pri maľovaní stále sýty odtieň a tak dokonale prekrývať spodnú vrstvu farby, používajme len krátke ťahy.
  • Pri používaní tabletu s podložkou citlivou na tlak dostaneme pri meniacom sa tlaku pera ťahy rôznych hrúbok. Čím väčší tlak však použijeme, tým rýchlejšie sa nám vyminie farba.


Gélová farba

Keď používame gélovú farbu, získame jasné a sýte farby, ktoré v istej miere prenikajú aj cez vyššie vrstvy. Maľovanie gélovými farbami sa podobá na maľovanie na sklo. Všimnime si, že:

  • k urobíme jeden dlhý ťah gélovou farbou, farba sa postupne míňa. Ak chceme mať stále namočený štetec, robme len krátke ťahy.
  • Pri používaní krátkych ťahov môžeme pokryť plochu peknou, jednoliatou farbou bez škvŕn a tieňov.

  • Pokiaľ máme štetec stále mokrý, môžeme jednoducho prekryť spodnú kresbu, a to aj tmavšie odtiene svetlými farbami. Spodná vrstva farby sa nerozpíja a jemne presvitá cez vrchnú vrstvu.
  • Ak použijeme tablet s podložkou citlivou na tlak a budeme meniť tlak pera, dostaneme ťahy s veľkou variabilitou sýtosti a hrúbky. Avšak čím väčší tlak použijeme, tým rýchlejšie sa nám vyminie farba.


Temperová farba

Temperové farby používame na maľovanie sýtych silnejších aj slabších odtieňov, ktoré sa miešajú so spodnými namaľovanými vrstvami. Všimnime si, že:

  • Ak urobíme jeden dlhý ťah so štetcom namočeným do temperky, farba sa postupne míňa a bledne. Keď zastavíme a začneme nový ťah, je to, akoby sme si znova namočili štetec do farby – stopa bude opäť sýta.
  • Ak používame tablet s podložkou citlivou na tlak a vyvinieme len slabý tlak, dostaneme slabú farebnú stopu, ktorá sotva prekryje spodnú vrstvu. Keď tlak zväčšíme, stopa bude hrubšia a sýtejšia. Avšak, čím väčší tlak použijeme, tým rýchlejšie sa nám vyminie farba.
  • Aj keď je farba sýta, jemne sa mieša a rozmazáva aj spodné vrstvy farby.


Vodová farba

Vodové farby používame na maľovanie realistických, mäkkých ale aj sýtych malieb používaním vrstiev farieb (podobných alebo odlišných odtieňov). Všimnime si, že:

  • Ak urobíme jeden dlhý ťah so štetcom s vodovou farbou, farba sa postupne míňa a bledne. Keď zastavíme a začneme nový ťah, je to, ako by sme si znova namočili štetec do farby – stopa bude opäť sýta.
  • Ak používame tablet s podložkou citlivou na tlak, získame čiary meniacich sa hrúbok a sýtostí menením tlaku pera. Avšak čím väčší tlak použijeme, tým rýchlejšie sa nám vyminie farba. Všimnime si tiež, že čím menšiu veľkosť štetca použijeme, tým menej farby môžeme nabrať, a teda farba sa rýchlejšie vyminie.

  • Keď prekrývame jednu farbu druhou, odtiene sa budú navzájom jemne miešať.
  • Je ťažké prekryť tmavý odtieň svetlým. Dá sa to len do istej miery nanášaním viacerých ťahov.
  • Ani pri vymaľovávaní celej oblasti vodovou farbou nedosiahneme jednoliatu plochu.

  • Vyskúšajme aj kombinovanie vodových farieb s farebnými ceruzkami.


Krieda

Kriedu používame na kreslenie hrubých, nepresných čiar skôr nevýrazných odtieňov. Kriedy sú veľmi populárne u umelcov kresliacich krajinomaľbu, portréty, figúry a scenérie len niekoľkými odtieňmi.

Všimnime si, že:

  • Sýtosť farby sa veľmi nezväčšuje ani pri opakovaných ťahoch. Ďalšie ťahy len zanechajú viac farby na jednom mieste.
  • Čiary sú skôr rozmazané, takže nie sú veľmi vhodné na detaily a malé objekty.
  • Ak použijeme tablet s podložkou citlivou na tlak, pri zmene tlaku pera dostaneme čiary rôznych hrúbok.
  • Ľahko prekryjeme jednu farbu inou, aj tmavý odtieň svetlejším.


Uhlík

Je podobný kriede, ale používa sa iba v tmavých tónoch. Je vhodný na rýchle črtanie; tento jemný nástroj nás bude inšpirovať k vlastnej tvorbe a experimentovaniu. Môžeme ho použiť na mäkké oblúky, ale aj na výrazné, silné ťahy.

Všimnime si, že:

  • Sýtosť farby sa veľmi nezväčšuje ani pri opakovaných ťahoch. Ďalšie ťahy len zanechajú viac farby na jednom mieste.
  • Ak použijeme tablet s podložkou citlivou na tlak, pri väčšom tlaku dostaneme čiary väčšej hrúbky. Čím sú však čiary hrubšie, tým sú aj nejasnejšie.
  • Uhlík je vynikajúci na tieňovanie.
  • Uhlík je taký populárny aj preto, že nanesená stopa sa dá výborne rozmazávať prstami. V RNA to môžeme vyskúšať použitím gumovania alebo iných efektov.


Olejová pastelka

Olejové pastelky používame na maľovanie jasných, živých, ale nepravidelných ťahov a mäkkých čiar.

Všimnime si, že:

  • Sýtosť farby sa veľmi nezväčšuje ani pri opakovaných ťahoch. Ďalšie ťahy len zanechajú viac farby na jednom mieste. Ak chceme dosiahnuť sýty tmavý okraj, musíme opakovať rovnaké ťahy viackrát.
  • Olejové pastelky môžeme použiť na hrubé čiary a čiastočne tiež na jemné či detailné kresby.
  • Použitím tabletu s podložkou citlivou na tlak dostaneme čiary rôznych hrúbok pri meniacom sa tlaku pera. Zväčšením tlaku zanecháme na papieri viac farby.
  • Prekrývaním farieb sa spodné vrstvy čiastočne rozmazávajú.
  • Môžeme čiastočne prekrývať jednu farbu druhou, aj tmavší odtieň svetlejším.
  • Olejové pastelky sú vhodné na tieňovanie.


Vosková pastelka

Voskovky používame na kreslenie mäkkých, nepravidelných čiar jemných, matných farieb. Kreslí sa s nimi veľmi ľahko, a preto sú vhodné na rýchle črtanie.

Všimnime si, že:

  • Sýtosť farby sa veľmi nezväčšuje ani pri opakovaných ťahoch. Ďalšie ťahy však zanechajú viac farby na jednom mieste.
  • Čiary sú skôr rozmazané, takže nie sú veľmi vhodné na detaily a malé objekty.
  • Ak použijeme tablet s podložkou citlivou na tlak a zväčšíme tlak pera, stopa bude hrubšia a zanecháme na papieri viac farby. Použitím väčšieho tlaku a zmenšovaním priesvitnosti môžeme zaujímavo stupňovať odtiene a tieňovať.
  • Je takmer nemožné prekryť jednu farbu inou, ani tmavším odtieňom svetlejší.
  • Ak chceme dosiahnuť sýty tmavý okraj, musíme opakovať rovnaké ťahy viackrát.


Sprej

Je podobný kriede, ale je menej sýty. Zväčša sa používa v jasných syntetických farbách. Je populárny a vhodný na rýchle, približné črtanie. Môžeme ho použiť na jemné oblúky, ale aj na výrazné, silné ťahy. Všimnime si, že:

  • Sýtosť farby sa veľmi nezväčšuje ani pri opakovaných ťahoch. Ďalšie ťahy len zanechajú viac farby na jednom mieste.
  • Ak použijeme tablet s podložkou citlivou na tlak, pri väčšom tlaku dostaneme čiary väčšej hrúbky.
  • Sprej je vynikajúci na tieňovanie.
  • Je ťažké prekryť jednu farbu druhou, aj svetlý odtieň tmavším.


Voľba farby a priesvitnosti

Farba je, samozrejme, jedným z kľúčových prostriedkov RNA. Farba sa v RNA používa v dvoch pomerne nezávislých oblastiach:

  • Ako farba pozadia papiera a v Ukážke animácie. Ak chceme zistiť momentálne nastavenia alebo ich meniť, zvoľme príkaz Zobrazenie/Nastaviť obrázok, alebo zvoľme Farba pozadia… v ponuke Ukážka animácie.
  • Ako farba zvolená na maľovanie, kreslenie, vkladanie textu, ďalších tvarov, výplň alebo nahrádzanie farby atď. Ak chceme vedieť, akú farbu máme práve zvolenú, môžeme ju preskúmať v malom Ukážkovom okne v ľavom rohu Stavového riadka, alebo ju uvidíme priamo na kurzore, ak je RNA v režime Kreslenie, alebo si môžeme pozrieť Farbu, či viac technické okno Nastavenie farieb.

Máme niekoľko možností, ako môžeme nastaviť farbu na maľovanie, kreslenie a vkladanie tvarov:

  • Vyberieme si štetec na paneli Štetce a dostaneme ponuku najčastejšie používaných farieb (nasledujúci obrázok ukazuje niektoré z ponúkaných sád farieb).
  • Ak potrebujeme farbu, ktorá nie je medzi predvolenými na paneli Štetcov, môžeme si ju zvoliť na Palete alebo len pozmeniť jej odtieň namočením štetca do farby.
  • Ak chceme farbu zvoliť z kompletnej (alebo veľmi širokej) ponuky farieb, môžeme si otvoriť Farbu. Ak tak však chceme urobiť, mali by sme už rozumieť rôznym farebným modelom. Tu si tiež môžeme nastaviť (alebo zistiť) stupeň priesvitnosti zvolenej farby.
  • Ak chceme zadať farbu presne, podľa jej špecifického kódu, otvoríme okno Nastavenie farieb.
  • Pre veľmi pokročilých používateľov je niekedy potrebné otvoriť aj okno Nastavenie nástrojov a zvoliť toleranciu farieb.
  • Niekedy potrebujeme nastaviť farbu (a jej stupeň priesvitnosti) podľa inej časti nášho obrázka. Vtedy môžeme využiť nástroj Nabrať farbu.

Ak sa chceme dozvedieť viac o nastavovaní farieb a priesvitností, pozrime si aj tieto časti:

  • Panel Štetce
  • Panel Paleta
  • Pomôcka pre voľbu farby
  • Okno Nastavenie farieb
  • Nástroj na naberanie farby
  • Stupeň priesvitnosti: nastavenie priesvitnosti
  • Farebné modely


Nástroj na naberanie farby

Často sa stáva, že potrebujeme vedieť, aká farba je použitá v niektorej časti obrázka a akú má priesvitnosť. Aby sme to zistili, kliknime na tlačidlo Nabrať farbu na Hlavnom paneli a následne kliknime na bod nášho obrázka – nabratú farbu a jej priesvitnosť uvidíme v pomôcke pre voľbu farby. To nám dovolí použiť v ďalšej práci rovnaké nastavenie farby, alebo ju jemne zmeniť a použiť ju namiesto pôvodnej. Po nabratí farby uvidíme presné parametre odtieňa a priesvitnosti v okne Nastavenie farieb.


Stupeň priesvitnosti: nastavenie priesvitnosti

Pre každú farbu, ktorú sme si zvolili na kreslenie, maľovanie alebo vkladanie tvarov, textu atď. si môžeme nastaviť stupeň priesvitnosti, t.j. stupeň, v akom bude predchádzajúcu kresbu cez pridaný text, čiaru, atď. vidieť. Jej hodnota sa pohybuje medzi 0% a 100% a môžeme ju vidieť a meniť pomocou nastavenia priesvitnosti v pomôcke pre voľbu farby. Všimnime si, že 100% priesvitnosť nezanecháva na papieri žiadnu stopu, teda spodný obrázok úplne presvitá. Takto nastavené body sú rovnaké ako základné priesvitné body na papieri. Aby sme zistili presnú farbu a priesvitnosť nejakého bodu na papieri, kliknime na tlačidlo Nabrať farbu na Hlavnom paneli a následne na bod nášho obrázka. Vtedy uvidíme nabratú farbu a jej priesvitnosť v pomôcke pre voľbu farby (a v okne Nastavenie farieb).

Na obrázku vidíme pomôcku pre voľbu farby (tri možné alternatívy farebných modelov) s priesvitnosťou nastavenou na 20%. Pozícia úplne vľavo zodpovedá 0%, úplne vpravo je 100% priesvitnosť.

Kreslenie s čiastočnou priesvitnosťou znamená, že farba (čiara, obdĺžnik, text atď.) neprekrýva úplne predchádzajúci obrázok, či farbu na pozadí (ako ukazuje nasledujúci obrázok). Červený obdĺžnik sme prekryli tvarmi a písmenami so zvyšujúcou sa priesvitnosťou. Prvé písmeno a trojuholník nie sú vôbec priesvitné. Ďalšie písmená a tvary majú 20%, 40%, 60% a 80% priesvitnosť. Preto je červený obdĺžnik na pozadí stále viac a viac viditeľný cez písmená a tvary.


Farebné modely

V RNA sa používajú tri odlišné technické modely označovania farieb na kreslenie, maľovanie, písanie, vypĺňanie a pod. Keď zvolíme Zobrazenie/Farebný model, otvoria sa nám nasledujúce tri možnosti:

Tieto zodpovedajú trom vizuálnym možnostiam, ktoré máme k dispozícii na interaktívne nastavovanie farby.

  • HSV model (Odtieň – Sýtosť – Jas) je kruh s trojuholníkom v strede. Ak chceme zvoliť farbu, ťahajme malý krúžok po farebnom kruhu (tým nastavíme odtieň) a/alebo biely krížik v trojuholníku (tým nastavíme sýtosť a jas).
  • RGB model (komponenty Červená – Zelená – Modrá) je kocka, v ktorej môžeme buď ťahať biele bodky po jej hranách, a tým nastavovať jednotlivo každý z komponentov, alebo ťahať malé krúžky po jej stenách, alebo hýbať krížikom a tak nastavovať všetky komponenty súčasne.
  • Model paleta ponúka 256 predvolených farieb. Farbu zvolíme kliknutím na vybraný odtieň.


Nastavenie hrotu

Panel Hroty použijeme, ak chceme zistiť alebo nastaviť:

  • Aktuálnu veľkosť hrotu.
  • Aktuálny tvar hrotu.

Veľkosť hrotu sa dá nastaviť pre všetky umelecké štetce. Tvar hrotu sa však dá nastaviť iba pre efekty, ako napr. základné kreslenie, gumovanie alebo rozmazanie. Ak chceme napríklad nakresliť obdĺžniky s oblými alebo ostrými rohmi, vyberme možnosť základné kreslenie, vyberme farbu, veľkosť hrotu a rôzne tvary hrotu (v tomto prípade okrúhly, štvorcový, štetinový a náhodný hrot) a dosiahneme podobný výsledok, ako vidíme dole na obrázku:


Vkladanie pečiatok

Pečiatky sú malé obrázky, ktoré sa zobrazujú v okne Pečiatky a sú zatriedené do kategórií podľa príbuzných námetov. Môžeme si prezerať jednotlivé kategórie, vybrať vhodné pečiatky a pridať ich do nášho obrázka.

  • Ak je okno Pečiatok skryté, môžeme ho zobraziť tak, že klikneme na tlačidlo Pečiatky na Hlavnom paneli, alebo vyberieme príkaz Zobrazenie/Pečiatky.
  • Ak je okno minimalizované (pozri pravú časť nasledujúceho obrázka), kliknime na malú šípku na jeho titulnom riadku.
  • Ak je okno zobrazené, môžeme ho skryť kliknutím na krížik v jeho titulnom riadku alebo minimalizovať kliknutím na šípku na titulnom riadku.
  • Ak je okno ukotvené, môžeme ho presunúť do akejkoľvek inej pozície. Stačí kliknúť na titulný riadok a potiahnuť ho na požadované miesto v hlavnom okne.

Najvrchnejší prvok okna Pečiatok je názov kategórie. Aby sme videli všetky kategórie, kliknime na šípku a objaví sa úplná ponuka kategórií. Pod názvom jednej kategórie sa skrývajú všetky súvisiace pečiatky. Ak si chceme vybrať pečiatku, kliknime na ňu. Ak teraz klikneme na náš obrázok, pečiatka sa na tomto mieste odtlačí. V spodnej časti okna Pečiatok sú štyri hodnoty, ktoré môžete upravovať:

  • Veľkosť pečiatok (pozri časť jednoduché použitie pečiatok).
  • Medzery medzi dvoma za sebou idúcimi odtlačkami (keď zvolíme pečiatku a ťaháme kurzor alebo pero po papieri).
  • Náhodné rozmiestenie, viac v časti o príkazoch ponuky pečiatky.
  • Pomiešané, pozri časť Príkazy ponuky Pečiatky.

Pečiatky môžeme použiť pri mnohých zábavných a tvorivých aktivitách (pozri nasledujúci obrázok):

Výsledný vzhľad pečiatky alebo pečiatok otlačených na obrázok je ovplyvnený týmito voľbami:

  • Ktorá pečiatka je zvolená? Je to jednoduchý obrázok alebo séria obrázkov?
  • Aké je aktuálne nastavenie v ponuke Pečiatky?
  • Je vyhladzovanie hrán vypnuté alebo zapnuté?
  • Je nastavená nejaká symetria?
  • Je nastavený nejaký povrch papiera?

Vyskúšajme si rôzne nastavenia a štýly práce s pečiatkami a pečiatkovanie na rôzne druhy povrchu papiera. Ak sa chceme naučiť viac o práci s pečiatkami, pomôžu nám pri tom nasledujúce časti:

  • Jednoduché používanie pečiatok
  • Kreslenie pečiatkou
  • Pečiatka ako oblasť
  • Vkladanie pečiatky pravým tlačidlom myši
  • Pečiatka so sériou obrázkov
  • Príkazy ponuky Pečiatky
  • Pečiatkovanie pomocou tabletu
  • Pridávanie vlastných pečiatok


Jednoduché používanie pečiatok

  • Najprv sa presvedčme, či je zobrazené okno Pečiatok.
  • V ponuke kategórií nájdime takú, ktorá nás zaujíma (napr. Architektúra).
    Pod názvom kategórie sa objaví niekoľko súvisiacich pečiatok.
  • Vyberme si tú, ktorú chceme použiť v obrázku, kliknime na ňu a uvoľnime tlačidlo myši alebo grafického pera.
  • Potom posuňme kurzor na stránku a kliknime na miesto, kam chceme pečiatku odtlačiť. Tú istú pečiatku môžeme opakovane odtlačiť na rozličné miesta na papieri. Keď odtlačíme pečiatku na papier, nemôžeme už s ňou hýbať (môžeme však použiť možnosť Späť).

Ak chceme zmeniť veľkosť pečiatky skôr, ako ju odtlačíme na papier, musíme zmeniť nastavenie položky Veľkosť, ktorá sa vyjadruje rôznymi spôsobmi:

  • Ako percento pôvodnej veľkosti (napr. 33%, 50%, 150% atď.), alebo
  • V celých číslach ako 40 alebo 210, ktoré určujú presnú veľkosť zmenenej pečiatky v bodoch (pomer medzi výškou a šírkou sa pritom zachová, dané číslo určuje väčší z dvoch rozmerov).

Ak vyberieme pečiatku a klikneme do obrázka pravým tlačidlom myši, pečiatka vygumuje farbu z obrázka:


Kreslenie pečiatkou

Ak chceme pomocou pečiatky kresliť:

  • Vyberme si pečiatku a presuňme kurzor na stránku.
  • Keď stlačíme tlačidlo myši a začneme kresliť, pečiatka sa opakovane odtláča podľa ťahu kurzora.

Najprv si vyskúšajme iba vodorovné ťahy, neskôr môžeme vyskúšať napr. aj kruhové ťahy. Všimnime si, že pečiatka sa najprv otočí a až potom sa odtlačí na stránku. Môžeme získať rozličné výsledky podľa toho, či začneme ťah vo vodorovnom smere a potom ho meníme smerom dole alebo hore, alebo ťah začneme v zvislom smere.

Ak kreslíme s pečiatkou so stlačeným pravým tlačidlom myši, pečiatka sa opakovane vymazáva z pozadia.

Môžeme tiež meniť veľkosť medzery medzi jednotlivými po sebe nasledujúcimi pečiatkami. Vopred nastavená je hodnota 100%, t.j. pečiatky sa odtláčajú tesne jedna vedľa druhej (pozrime prvý rad domov na obrázku nižšie). Túto hodnotu môžeme zmeniť tým, že klikneme na Medzery v okne Pečiatok a zvolíme inú hodnotu. Táto hodnota môže byť vyjadrená:

  • Ako percento veľkosti pečiatky (napr. 50%, 100%, 150% atď.), kde napríklad 200% znamená, že dve susedné pečiatky budú mať medzi sebou medzeru takej veľkosti, aká je veľkosť pečiatky.
  • V celých číslach ako napr. 10, 50 alebo -20, ktoré určujú veľkosť medzery v bodoch. T.j. 0 znamená to isté ako 100%, 20 znamená, že veľkosť medzery bude 20 bodov, -10 znamená, že dve susedné pečiatky sa prekryjú o 10 bodov atď.

Môžeme si tiež vyskúšať možnosť Maľovanie/Pečiatky/Náhodné rozmiestnenie. Ak je táto možnosť zapnutá, RNA vloží medzi jednotlivé pečiatky náhodne veľké medzery. V tomto prípade bude aktuálna hodnota medzery nastavená ako priemerná hodnota a náhodné medzery budú mať hodnotu medzi 0 a dvojnásobkom tejto hodnoty (pozri na obrázok nižšie).


Pečiatka ako oblasť

Pečiatku môžeme použiť aj ako oblasť – a využiť potom tie možnosti, ktoré práca s oblasťou ponúka:

  • Zvoľme pečiatku v okne Pečiatok tak, že na nej stlačíme ľavé tlačidlo myši. Potom pritiahnime jej kópiu na papier.
  • Keď tlačidlo uvoľníme, pečiatka sa položí na obrázok ako označená oblasť, takže predtým, ako ju odtlačíme na papier, môžeme meniť jej veľkosť, otáčať ju, alebo s ňou zaobchádzať ako s ktoroukoľvek inou oblasťou. Táto metóda je užitočná, keď chceme presne umiestniť pečiatku alebo ju pred odtlačením upraviť (pozri obrázok dolu).

Ak chceme našu pečiatky dostať ako oblasť do stredu papiera, vyberme možnosť Maľovanie/Pečiatky/Použiť ako oblasť (pozri aj časť Príkazy ponuky Pečiatky)


Vkladanie pečiatky pravým tlačidlom myši

Keď vybranú pečiatku potiahneme na papier so stlačeným pravým tlačidlom myši a tlačidlo potom uvoľníme, objaví sa ponuka s nasledujúcimi príkazmi:

Odtlačiť | Odtlačí pečiatku na obrázok.
Použiť ako oblasť | Ponúkne použitie pečiatky ako oblasti, takže pred jej odtlačením na papier môžeme zmeniť jej veľkosť, otáčať ju alebo pracovať s ňou ako s akoukoľvek inou oblasťou.
Použiť ako pozadie | Otvorí ponuku s štyrmi štýlmi (Do stredu, Prispôsobiť, Natiahnuť a Vykachličkovať). Tieto určujú, ako sa pečiatka objaví na pozadí papiera. Táto možnosť je zhodná s možnosťou Obrázok pozadia v dialógovom okne Nastavenie papiera.


Pečiatka so sériou obrázkov

Niektoré pečiatky, ktoré si vyberieme v okne Pečiatok, môžu byť v skutočnosti série obrázkov. Toto sa môže stať vtedy, keď používame ako pečiatky obrázky formátov RNA a LGF alebo LGW obrázky z prostredia Comenius Logo, animované obrázky GIF, animované kurzory, animované ikony atď. (Každý z týchto formátov obrázkov so sériami môžeme v RNA vytvoriť, preskúmať alebo upraviť.) Skutočnosť, že v RNA môžeme použiť série obrázkov ako pečiatky, robí z mechanizmu Pečiatky ešte zaujímavejší nástroj.

Predtým, ako sa pokúsime porozumieť fungovaniu zložených pečiatok, pripomeňme si, čo sú animované obrázky a čo sú ich zábery a fázy. Všetky pečiatky, ktoré obsahujú sériu obrázkov, sa správajú, ako keby boli ich jednotlivé obrázky fázy obrázka s jedným záberom.


Obrázky so zábermi podľa čísla

Ak používame ako pečiatku obrázok s animáciou podľa čísla záberu, RNA nedostane žiadne informácie (od obrázka ako takého) o tom, ako sa majú zobrazovať rôzne smery:

Preto RNA otáča fázy obrázka, aby tak vyjadril rôzne smery pohybu kurzora. Môžu nastať nasledujúce situácie:

  • Ak kreslíme a náš ťah je viac-menej vodorovný (zľava doprava), všetky fázy všetkých záberov budú odtlačené jedna po druhej v približnom rade s minimálnym natočením. Ak je náš ťah viac-menej vertikálny (zhora nadol), všetky fázy všetkých záberov sa odtlačia jedna po druhej v približnom stĺpci s takmer žiadnym natočením. (Na ilustráciu sme použili toho istého robota, pozrime nižšie, a animovanie podľa smeru sme v tomto obrázku zmenili na animovanie podľa čísla záberu).

  • Ak začneme náš ťah približne horizontálne, ale potom ho stočíme smerom nahor alebo nadol (a pokračujeme v tomto smere), všetky fázy všetkých záberov sa odtlačia jedna po druhej, a to kolmo na náš pohyb. RNA otočí fázy podľa momentálneho pohybu kurzoru (pozri si ľavú časť nasledujúceho obrázka).
  • Ak začneme náš ťah približne vertikálne smerom nahor, ale potom ho stočíme a pokračujeme v tomto smere, všetky fázy všetkých záberov sa odtlačia jedna po druhej v smere pohybu. Fázy sa teda otočia tak, aby vyjadrili smer pohybu.
  • Ak začneme náš ťah približne vertikálne smerom nadol, ale potom ho stočíme a pokračujeme v tomto smere, všetky fázy všetkých záberov sa odtlačia jedna po druhej v opačnom smere k smeru pohybu.

  • Veľkosť medzery medzi susednými fázami môžeme meniť v nastavení Medzery v okne Pečiatok (pozri časť Kreslenie s pečiatkami). Môžeme zvoliť aj možnosť Náhodné rozmiestnenie.
  • Ak označíme voľbu Maľovanie/Pečiatky/Pomiešané, poradie fáz odtlačených do nášho obrázka bude náhodné (pozri časť Príkazy ponuky pečiatky).


Obrázky so zábermi podľa smeru

Ak používame ako pečiatku obrázok animovaný podľa smeru, RNA dostane od samotného obrázka úplné informácie o tom, ako sa majú zobraziť na papieri rozličné smery ťahu myši či grafického pera.

Preto platí:

  • Ak si vyberieme pečiatku a opakovane klikáme na papier, odtláča sa stále len jeden záber – buď prvý, alebo ten, pri ktorom sme naposledy skončili kreslenie s touto pečiatkou.
  • Ak si vyberieme pečiatku a kreslíme ňou, vyberie sa záber, ktorý zodpovedá smeru pohybu kurzora, a jeho jednotlivé fázy sa odtlačia na papier jedna za druhou (aj opakovane).
    Napríklad, vybrali sme si obrázok robot so 4 zábermi a základným uhlom 20. Jeho prvý záber sa použije vtedy, ak budeme kurzorom pohybovať v smere od -70 do 110 stupňov. Jeho druhý záber sa použije pre smery medzi 110 a 200 atď.

  • Veľkosť medzery medzi susednými fázami bude zodpovedať aktuálnym nastaveniam Medzery v okne Pečiatok (pozri časť Kreslenie s pečiatkami).

Všimnime si:

  • Postup, ktorý sme popísali vyššie, zodpovedá spôsobu, akým sa používajú a zobrazujú animované tvary v programe Imagine.
  • Ak používame ako pečiatku obrázok animovaný podľa smeru, RNA už nebude jednotlivé fázy otáčať – predpokladá totiž, že zábery ako také už vyjadrujú príslušné otáčania.
  • Predpokladajme, že obrázok, ktorý používame, má iba jeden záber. V tomto prípade sa pre všetky smery kreslenia použije ten istý záber a jeho fázy sa odtlačia vždy v pôvodnom smere (t.j. bez otáčania).

  • Predpokladajme, že každý záber, ktorý používame ako pečiatku, má iba jedinú fázu. Kedykoľvek klikneme na obrázok, odtlačí sa prvý záber. Vždy, keď kreslíme s touto pečiatkou, opakovane sa odtlačí ten záber, ktorý zodpovedá momentálnemu smeru pohybu kurzora.


Pečiatkovanie pomocou tabletu

Ak v RNA pacujeme s tabletom a kreslíme s pečiatkami, ktoré sú animovanými obrázkami s niekoľkými zábermi a fázami , RNA reaguje na prítlak pera – tlakom pera môžeme vtedy ovplyvniť úroveň priesvitnosti každej nakreslenej fázy.

Pomocou tejto funkčnosti môžeme vytvoriť veľa zaujímavých efektov, ako napr. krajinu, ktorá sa postupne vynára z hmly.


Pridávanie vlastných pečiatok

Ak chceme ako pečiatku použiť niektorý vlastný obrázok (akejkoľvek veľkosti a podporovaného grafického formátu), skopírujme ho do priečinku RNA s názvom Pečiatky. Je vhodné, aby sme tento súbor vložili priamo do priečinku, ktorý sa zhoduje s námetom našej novej pečiatky. Ak potom otvoríme príslušnú kategóriu v okne Pečiatok, medzi možnosťami sa objaví aj nová pečiatka a bude pripravená na bežné použitie.

Niekedy sa môže stať, že chceme rýchlo (a opakovane) vytvoriť na papieri skupinu niekoľkých náhodne usporiadaných pečiatok vecí alebo postáv (ako napr. na obrázku dolu), ktoré sme našli v okne Pečiatok. Najprv môžeme použiť RNA na to, aby sme tieto pečiatky skombinovali do jediného obrázka s viacerými fázami, a potom výsledok uložiť do priečinku Pečiatky. Pri kreslení pomocou novej zloženej pečiatky potom môžeme využiť voľby Náhodné rozmiestnenie alebo Pomiešané.


Vkladanie tvarov

Tieto nástroje používame vtedy, keď chceme do obrázka vkladať geometrické tvary alebo časti kreslené voľnou rukou. Na výsledný vzhľad budú mať vplyv nasledujúce nastavenia:

  • Aký tvar je zvolený?
  • Ktorý štetec alebo efekt je zvolený?
  • Aká farba a úroveň priesvitnosti je nastavená?
  • Aká veľkosť hrotu je zvolená?
  • Aký tvar hrotu je zvolený? (nezabudnime, že tvar hrotu môžeme zmeniť iba pri efektoch, a nie pri umeleckých štetcoch.)
  • Je nastavený nejaký efekt?
  • Je vyhladzovanie hrán vypnuté alebo zapnuté?
  • Je nastavený nejaký povrch papiera?
  • Je zvolený motív?
  • Je nastavená niektorá symetria?

Do obrázka môžeme vkladať nasledujúce tvary a prvky:

  • Kreslenie od ruky: čiara a bodky
  • Úsečka a lúče
  • Kruh alebo elipsa: obvod a výplň
  • Obdĺžnik alebo štvorec: obvod a výplň
  • Pravidelný mnohouholník: obvod a výplň
  • Hviezda: obvod a výplň
  • Mnohouholník: otvorený, uzavretý a vyplnený
  • Krivka: otvorená, uzavretá a vyplnená

Pozrime si tiež:

  • Vkladanie textu
  • Výplň a nahradenie farieb
  • Vkladanie pečiatok

Všimnime si, že keď tvary vkladáme pravým tlačidlom myši alebo pomocou gumy grafického pera, v obrázku sa zvolený tvar vymaže.

  • Gumovanie


Kreslenie od ruky: čiara a bodky

Keď chceme od ruky nakresliť čiaru:

  • Kliknime na tlačidlo Čiara na paneli Tvary alebo vyberme možnosť Maľovanie/Tvar/Kreslenie od ruky/Čiara.
  • Posuňme kurzor na náš obrázok a stlačme ľavé tlačidlo myši.
  • Ťahajme myš, a tým nakreslíme neprerušený ťah nakreslený voľnou rukou.
  • Ťah ukončíme, keď uvoľníme tlačidlo myši alebo zdvihneme grafické pero.

Ak chceme nakresliť bodkovaný ťah:

  • Kliknime na tlačidlo Bodky na paneli Tvary alebo vyberme možnosť Maľovanie/Tvar/Kreslenie od ruky/Bodky.
  • Pokračujme ako pri normálnej čiare.

To, ako bude vyzerať výsledok, ovplyvní vybraný typ štetca a jeho veľkosť. Ak kreslíme pomocou tabletu s grafickým perom a vyberieme si kreslenie od ruky, rôznym tlakom pera na podložku môžeme meniť hrúbku čiary. Ak tlačíme silno, čiary budú hrubé, ak tlačíme zľahka, čiary budú jemné.


Úsečka a lúče

Ak chceme nakresliť rovnú čiaru:

  • Kliknime na tlačidlo Úsečka na paneli Tvary alebo vyberme možnosť Maľovanie/Tvar/Úsečka/Úsečka.
  • Posuňme kurzor na obrázok.
  • Prvým kliknutím určíme bod, kde sa úsečka začne.
  • Potom potiahneme myš a čiara sa natiahne do momentálnej pozície kurzora.
  • Druhé kliknutie určí bod, kde sa úsečka skončí.

Ak stlačíme kláves Shift a zároveň kreslíme úsečku, jej smer bude horizontálny, diagonálny alebo vertikálny.

To, ako bude vyzerať výsledný vzhľad úsečky, ovplyvní aj zvolený typ štetca a jeho veľkosť. Napríklad čiara nakreslená vodovou farbou postupne od začiatku ku koncu stráca sýtosť (pozri nižšie). Rôzne typy štetcov tiež inak nanášajú farbu na papier, keď križujú jeden druhý. Všimnime si tiež, že rôznym tlakom pera na podložku nie je možné meniť hrúbku úsečky.

Použitím druhej možnosti tvaru úsečka – nástroja Lúče – môžeme dosiahnuť veľmi pôsobivé výsledky.

  • Kliknime na tlačidlo Lúče na paneli Tvary alebo vyberme možnosť Maľovanie/Tvar/Úsečka/Lúče.
  • Posuňme kurzor na obrázok.
  • Kliknutím určíme začiatok lúča.
  • Potom potiahnime kurzor v jednom smere.
  • Pokračujme kruhovým alebo elipsovitým pohybom.

Vyskúšajme si rôzne štetce, farby, úrovne priesvitnosti a povrchy.

Lúče nakreslené olejovou pastelkou v odtieňoch zelenej.


Kruh alebo elipsa: obvod a výplň

Ak chceme nakresliť obvod elipsy alebo kružnice:

  • Kliknime na tlačidlo Obvod elipsy alebo kružnice na paneli Tvary alebo vyberme možnosť Maľovanie/Tvar/Elipsa/Obvod.
  • Posuňme kurzor na obrázok.
  • Kliknutím určíme roh (mysleného) rámiku kružnice alebo elipsy.
  • Potom potiahnime kurzor smerom k opačnému rohu rámiku.

Všimnime si, že:

  • Ak držíme kláves Shift stlačený a zároveň ťaháme myš, elipsa sa stane presnou kružnicou.
  • Ak držíme stlačený kláves Ctrl, začiatočný bod (určený prvým kliknutím) určí stred elipsy alebo kružnice, a nie roh mysleného rámika.
  • Ak držíme klávesy Shift a Ctrl stlačené súčasne a zároveň ťaháme myš, z elipsy sa stane presná kružnica a naše prvé kliknutie určí jej stred.

Ak chceme nakresliť vyplnenú elipsu alebo kruh:

  • Kliknime na tlačidlo Vyplnená elipsa alebo kruh na paneli Tvary alebo vyberme možnosť Maľovanie/Tvar/Elipsa/Výplň.
  • Postupujme rovnako ako je popísané vyššie. O tlačidlách Shift a Ctrl platí to isté, ako pri obvode elipsy a kružnice.

Všimnime si, ako vybraný štetec a jeho veľkosť ovplyvnia vzhľad elíps a kruhov. Ani pri tomto tvare nie je možné tlakom pera na podložku meniť hrúbku obvodu.


Obdĺžnik alebo štvorec: obvod a výplň

Ak chceme nakresliť obvod obdĺžnika alebo štvorca:

  • Kliknime na tlačidlo Obvod obdĺžnika alebo štvorca na paneli Tvary alebo vyberme možnosť Maľovanie/Tvar/Obdĺžnik/Obvod.
  • Posuňme kurzor na obrázok.
  • Kliknutím určíme roh obvodu.
  • Potom potiahnime kurzor smerom k opačnému rohu.

Všimnime si, že:

  • Ak držíme kláves Shift stlačený a zároveň premiestňujeme kurzor, obdĺžnik sa stane presným štvorcom.
  • Ak držíme stlačený kláves Ctrl, začiatočný bod (určený prvým kliknutím) určí stred obdĺžnika alebo štvorca, a nie jeho roh.
  • Ak držíme klávesy Shift a Ctrl stlačené súčasne a premiestňujeme kurzor, z obdĺžnika sa stane štvorec a naše prvé kliknutie určí jeho stred.

Ak chceme nakresliť vyplnený obdĺžnik alebo štvorec:

  • Kliknime na tlačidlo Vyplnený obdĺžnik alebo štvorec na paneli Tvary alebo vyberme možnosť Maľovanie/Tvar/Obdĺžnik/Výplň.
  • Postupujme rovnako ako je popísané vyššie.

O tlačidlách Shift a Ctrl platí to isté, ako pri obvode obdĺžnika a štvorca.

Všimnime si, ako vybraný štetec a jeho veľkosť ovplyvnia vzhľad obdĺžnikov a štvorcov. Ani pri tomto tvare nie je možné tlakom pera na podložku meniť hrúbku obvodu.


Hviezda: obvod a výplň

Ak chceme nakresliť obvod hviezdy:

  • Kliknime na tlačidlo Obvod hviezdy na paneli Tvary alebo vyberme možnosť Maľovanie/Tvar/Hviezda/Obvod.
  • Posuňme kurzor na obrázok.
  • Kliknutím určíme stred hviezdy.
  • Potom potiahnime kurzor akýmkoľvek smerom k jednému z vrcholov.
  • Konkrétny počet vrcholov môžeme vopred stanoviť pomocou nástroja Počet vrcholov na paneli Tvary. Toto číslo môžeme meniť pomocou šípok hore a dole. Najmenší možný počet vrcholov je 3 a najväčší 25.

Ak chceme nakresliť vyplnenú hviezdu:

  • Kliknime na tlačidlo Vyplnená hviezda na paneli Tvary, alebo vyberme možnosť Maľovanie/Tvar/ Hviezda/Výplň.
  • Postupujme rovnako ako je popísané vyššie.

Všimnime si, ako vybraný štetec a jeho veľkosť ovplyvnia vzhľad obvodu a výplne hviezdy. Ani pri tomto tvare nie je možné tlakom pera na podložku meniť hrúbku obvodu.


Pravidelný mnohouholník: obvod a výplň

Ak chceme nakresliť obvod pravidelného mnohouholníka:

  • Kliknime na tlačidlo Obvod pravidelného mnohouholníka na paneli Tvary alebo vyberme možnosť Maľovanie/Tvar/Pravidelný mnohouholník/Obvod.
  • Posuňme kurzor na obrázok.
  • Kliknutím určíme stred útvaru.
  • Potom potiahnime kurzor akýmkoľvek smerom k jednému z vrcholov. Konkrétny počet vrcholov (ktorých je rovnaký ako počet strán) môžeme vopred stanoviť pomocou nástroja Počet vrcholov na paneli Tvary.
  • Počet vrcholov meníme pomocou šípok hore a dole. Najmenší možný počet je 3 a najväčší 25.

Ak chceme nakresliť vyplnený pravidelný mnohouholník:

  • Kliknime na tlačidlo Vyplnený pravidelný mnohouholník na paneli Tvary alebo vyberme možnosť Maľovanie/Tvar/Pravidelný mnohouholník/Výplň.
  • Postupujme rovnako ako je popísané vyššie.

Všimnime si, ako vybraný štetec a jeho veľkosť ovplyvnia vzhľad obvodu a výplne pravidelných mnohouholníkov. Ani pri tomto tvare nemôžeme tlakom pera na podložku meniť hrúbku obvodu.


Krivka: otvorená, uzavretá a vyplnená

Ak chceme nakresliť otvorenú krivku (t.j. krivku, ktorá nie je uzavretá ani vyplnená):

  • Kliknime na tlačidlo Otvorená krivka na paneli Tvary alebo vyberme možnosť Maľovanie/Tvar/Zaoblená čiara/Otvorená.
  • Posuňme kurzor na obrázok.
  • Kliknutím určíme začiatočný bod krivky označený malou pulzujúcou značkou.
  • Posuňme kurzor a druhým kliknutím určíme pozíciu druhého bodu. Vytvorí sa prvý úsek krivky – prvý a druhý bod sa navzájom spoja pružnou čiarou.
  • Posuňme kurzor ďalej.
    Pokiaľ nestlačíme tlačidlo myši, neobjaví sa pružná čiara.
  • Keď klikneme myšou, na mieste kurzora sa objaví ďalšia značka, ktorá bude spojená s predchádzajúcou značkou pružným úsekom krivky.
  • Značku môžeme presunúť do pozície, ktorá nám vyhovuje a kliknutím ju zakotviť. Posúvanie tretej (a ďalších) značiek mení tvar predchádzajúceho úseku krivky.
  • Môžeme opakovať tento postup toľkokrát, koľko potrebujeme.
  • Ktorúkoľvek pulzujúcu značku môžeme myšou chytiť a ťahať po papieri – a tým upravovať výsledný tvar krivky.
  • Ak klikneme na niektorý už jestvujúci úsek, teda medzi dve pulzujúce značky, rozdelíme tento úsek novou značkou na dva úseky. Aj takto môžeme postupne upravovať výsledný tvar krivky.
  • Ak chceme ukončiť vytváranie krivky, klikneme pravým tlačidlom myši alebo tlačidlom grafického pera.

Dočasné pulzujúce značky potom zmiznú a ich rozmiestenie bude prepojené hladkou krivkou, ktorá bude mať vzhľad podľa zvoleného typu a veľkosti štetca, farby a ostatných nastavení. (Vytváranie krivky môžeme ukončiť aj tak, že klikneme na tlačidlo pre iný tvar.)

Uvedomme si, že keď uvoľníme tlačidlo myši, pohneme kurzorom o kúsok ďalej a stlačíme ho znova, môže sa stať jedna z nasledujúcich vecí:

  • Ak klikneme veľmi blízko k predchádzajúcej značke, nevznikne ďalšia značka, ale táto preskočí (spolu s pružnou čiarou) ku kurzoru a bude ďalej sledovať pohyb kurzora.
  • Ak klikneme veľmi blízko ku začiatočnej značke krivky, medzi začiatočnou značkou a pozíciou kurzora sa vytvorí nová časť krivky. Toto nám umožní pridávať nové časti na začiatok krivky.
  • Ak klikneme veľmi blízko k jednej z už predtým vytvorených značiek alebo kliknime na existujúcu značku, preskočí ku kurzoru a môžeme ju potiahnutím premiestniť. Toto nám umožní meniť tvar krivky.
  • Ak klikneme veľmi blízko k niektorému úseku krivky (k čiare samotnej), vytvorí sa tam nová značka a rozdelí daný úsek na dve časti. Toto nám umožní pridávať viac vnútorných značiek a veľmi presne vytvarovať krivku.

Všimnime si, ako vybraný štetec a jeho veľkosť ovplyvnia vzhľad krivky. Ani pri tomto tvare nie je možné tlakom pera na podložku meniť hrúbku čiary.

Ak chceme nakresliť uzavretú krivku (t.j. krivku, ktorá má spojený začiatočný a koncový bod):

  • Kliknime na tlačidlo Uzavretá krivka na paneli Tvary alebo vyberme možnosť Maľovanie/Tvar/Zaoblená čiara/Uzavretá.
  • Posuňme kurzor na obrázok.
  • Kliknutím určíme jej začiatočný bod.
  • Potom postupujme rovnako, ako pri otvorených krivkách.

Jediný rozdiel je v tom, že začiatočný a koncový bod spája pružná čiara. Keď pridáme nový bod (značku) do uzavretej krivky, vždy to znamená, že sa daný úsek rozdelí na dve časti, t.j. nová značka sa umiestni medzi dve predtým spojené značky.

Keď chceme dosiahnuť uzavretú krivku požadovaného tvaru, vyžaduje si to určité skúsenosti. Na obrázku vyššie vidíme slabo ružovo načrtnutý požadovaný tvar. Najprv vytvoríme body 1, 2 a 3. Potom klikneme na čiaru medzi bodmi 2 a 3, čím vytvoríme bod 4. Tento potom potiahneme do výslednej pozície. Nakoniec klikneme na čiaru medzi bodmi 1 a 3, vytvoríme tak bod 5 a ten potiahneme do výslednej pozície.

Ak chceme nakresliť vyplnenú krivku (t.j. krivku, ktorá je spojená a vyplnená):

  • Kliknime na tlačidlo Vyplnená krivka na paneli Tvary alebo vyberme možnosť Maľovanie/Tvar/Zaoblená čiara/Vyplnená.
  • Posuňme kurzor na obrázok.
  • Kliknutím určíme jej začiatočný bod.
  • Potom postupujme rovnako, ako pri uzavretých krivkách.

Vyplnené krivky môžu obsahovať priesvitné časti. Toto sa stane vtedy, keď je táto časť pokrytá párnym počtom vrstiev vyplnenej krivky.

Keď vytvárame uzavretú alebo vyplnenú krivku, môžeme získať krásne a prekvapujúce tvary. Predtým, než ukončíme krivku kliknutím pravým tlačidlom myši alebo tlačidlom grafického pera, môžeme potiahnuť akúkoľvek značku krivky. Takto môžeme dosiahnuť rôzne obmeny predchádzajúcich tvarov (pozri nižšie):


Mnohouholník: otvorený, uzavretý a vyplnený

Ak chceme nakresliť otvorený mnohouholník (t.j. mnohouholník, ktorý nie je ani uzavretý ani vyplnený):

  • Kliknime na tlačidlo Otvorený mnohouholník na paneli Tvary alebo vyberme možnosť Maľovanie/Tvar/Mnohouholník/Otvorený.
  • Posuňme kurzor na obrázok.
  • Kliknutím určíme jeho začiatočný bod.
  • Potom pokračujme rovnako ako pri otvorených krivkách. Jediný rozdiel spočíva v tom, že jednotlivé body mnohouholníka sú spojené rovnými úsečkami, a nie úsekmi hladkej krivky.

Ak chceme nakresliť uzavretý mnohouholník (t.j. mnohouholník, ktorý má spojený začiatočný a konečný bod):

  • Kliknime na tlačidlo Uzavretý mnohouholník na paneli Tvary alebo vyberme možnosť Maľovanie/Tvar/Mnohouholník/Uzavretý.
  • Posuňme kurzor na obrázok.
  • Kliknutím určíme začiatočný bod.
  • Potom budeme postupovať rovnako, ako pri otvorených mnohouholníkoch. Jediný rozdiel je v tom, že začiatočný a konečný bod spája pružná úsečka.

Ak klikneme na úsečku, ktorá spája dva vrcholy (dve pulzujúce značky) vytváraného mnohouholníka, táto úsečka sa rozdelí novým vrcholom na dve časti, t.j. medzi dvoma predtým spojenými značkami vznikne nová značka.

Ak chceme nakresliť vyplnený mnohouholník (t.j. mnohouholník, ktorý je spojený a vyplnený):

  • Kliknime na tlačidlo Vyplnený mnohouholník na paneli Tvary alebo vyberme možnosť Maľovanie/Tvar/Mnohouholník/Vyplnený.
  • Posuňme kurzor na obrázok.
  • Kliknutím určíme jeho začiatočný bod.
  • Potom budeme postupovať rovnako, ako pri uzavretých mnohouholníkoch.

Vyplnené mnohouholníky môžu obsahovať priesvitné časti. Toto sa stane vtedy, keď je táto časť pokrytá párnym počtom vrstiev vyplneného mnohouholníku. Mnohouholníky a vyplnené mnohouholníky môžeme použiť na vytváranie pomerne zložitých objektov (pozri napr. na obrázok dolu).


Vkladanie textu

Pomocou tohto nástroja môžeme vkladať do nášho obrázka text. Robíme to takto:

  • Kliknime na tlačidlo Text na paneli Tvary alebo zvoľme Maľovanie/Tvar/Text. Otvorí sa nám textový rámik (horná časť nasledujúceho obrázka) a textové okienko (dolná časť nasledujúceho obrázka).

  • Do textového okienka môžeme napísať písmeno, slovo, vetu, celý odsek, alebo aj niekoľko odsekov textu. Môžeme si sem tiež prilepiť text zo schránky.
  • Text môžeme potom upravovať pomocou:
    • Určenia typu písma, hrúbky (normálne, tučné, kurzíva, podčiarknuté) a veľkosti písma.
    • Určením zarovnanie odseku (zarovnať doľava, centrovať, zarovnať doprava alebo zarovnať do bloku).

Nastavená úprava sa vždy použije na celý text. Ak chceme pridávať do obrázka text rôznych farieb, veľkostí, typov písma, zarovnaní atď., musíme upravovať časti textu jednotlivo.

Počas písania a upravovania textu sa zobrazuje daný text a jeho aktuálne písmo, farba, štýl, veľkosť a zarovnanie v textovom rámiku.

  • Kliknime do rámika a posuňme ho na ľubovoľné miesto na papieri. Jeho obsah môžeme naďalej meniť a upravovať v Textovom okienku.
  • Textový rámik môžeme po papieri premiestňovať aj pomocou šípok na klávesnici.
    • Keď stačíme kláves Ctrl a textový rámik potiahneme na nové miesto, na pôvodnej pozícii zostane jeho odtlačok. Napriek tomu môžeme stále text v rámiku upravovať v Textovom okienku.
    • Ťahajme za niektorú zo šiestich značiek na obvode textového rámika – tak interaktívne zmeníme veľkosť jeho písma. Všimnime si, že protiľahlá značka zostáva na svojom mieste. Tiež si všimnime, že týmto sa mení veľkosť textu v rámiku, a zároveň aj veľkosť písma určená v Textovo okienku.
  • Kliknime kamkoľvek mimo textového rámika. Obsah rámika ostane vytlačený na našom obrázku na danom mieste a rámik zmizne.
    Ak znovu klikneme na papier (kým máme stále otvorené Textové okienko), rámik sa znovuobjaví na tomto mieste (kam sme klikli myšou) a bude obsahovať rovnaký text.
  • Vyberme inú farbu, a tým zmeníme pôvodnú farbu textu.
  • Vyberme iný štetec, a tým zmeníme vzhľad textu.

Uvedomme si, že keď raz odtlačíme text do nášho obrázka, stáva sa jeho súčasťou a nedá sa viac meniť ani upravovať.

Ak klikneme na tlačidlo Text znovu, obsah textového rámika sa vytlačí do nášho obrázka a Textové okienko aj textový rámik zmiznú. To isté môžeme urobiť aj zavretím Textového okienka. Všimnime si, že keď ho znovu otvoríme, bude v ňom predošlý text. Textový rámik sa znovuobjaví na jeho poslednej pozícii s predošlým textom, avšak v momentálnej farbe a nastavení štetca.

Uvedomme si, že konečný vzhľad vloženého textu závisí od:

  • Aký text sme zadali?
  • Ako je nastavené písmo, štýl a veľkosť?
  • Aké má odsek zarovnanie?
  • Aká farba a stupeň priesvitnosti je zvolený?
  • Aký štetec alebo efekt je nastavený?
  • Je vyhladzovanie hrán zapnuté alebo vypnuté?
  • Je nastavený špeciálny povrch papiera?
  • Je zvolený motív?
  • Je zvolená niektorá súmernosť?

Všimnime si, že pokiaľ je zapnutá súmernosť vľavo a vpravo a/alebo hore a dolu, vytlačia sa nám na papier dve alebo štyri kópie rovnakého textu – budú však zrkadlovo súmerné.


Výplň a nahradenie farby

Výplň a nahradenie farby znamená vždy zámenu terajšej farby (možno viacerých, veľmi podobných farieb) za práve zvolenú farbu alebo za práve zvolený motív. Ak chceme nahradiť niektorú farbu inou alebo vyplniť niektorú súvislú oblasť zvolenou farbou, vyberme si najprv novú farbu (ktorú chceme použiť), potom kliknime na tlačidlo Výplň alebo Nahradenie farby na Hlavnom paneli a kliknime kurzorom na dané miesto.

  • Výplň znamená prekrytie súvislej oblasti (pozostávajúcej z bodov obkolesujúcich nami zvolený bod), ktorá je ohraničená ľubovoľnou farbou odlišnou od farby vnútri tejto oblasti. Oblasť je teda súvislá plocha okolo bodu, v ktorej majú všetky body rovnakú farbu ako zvolený bod. Dajme pozor na to, že oblasť nesmie mať žiadne „otvory“ do okolia, lebo inak farba pri vypĺňaní „vytečie“ von a zaplní väčšiu plochu, alebo aj celý papier.
  • Nahradenie farby značí nahradenie všetkých bodov (ktoré majú farbu totožnú s bodom, na ktorý sme klikli) celého obrázka práve nastavenou farbou.

Keď máme pri vypĺňaní a nahrádzaní farby nastavenú toleranciu farieb na 0% znamená to, že len body rovnakej farby (akú má bod, na ktorý sme klikli) sa nahradia novou farbou. Toleranciu farieb však môžeme aj zvýšiť – vtedy sa nahradia aj body podobnej farby. Pri nastavení tolerancie (odchýlky) na 100% sa celý obrázok prekryje vybratou farbou. Hodnota tolerancie prednastavená v RNA je 5% (ako môžeme vidieť v okne Nastavenie nástrojov).

Všimnime si, že vyplniť alebo nahradiť farbu môžeme buď inou farbou, alebo aj práve zvoleným motívom; pozri obrázok dolu.


Používanie efektov

Ak si chceme vybrať jeden z efektov, môžeme buď kliknúť na príslušné tlačidlo na paneli Maľovanie a efekty, alebo zvoliť príkaz Maľovanie/Štetec/Efekt a vybrať si jeden zo zoznamu efektov:

  • Základné kreslenie
  • Gumovanie
  • Farbenie
  • Rozmazanie
  • Zosvetlenie
  • Stmavenie
  • Vyhladenie
  • Zaostrenie
  • Farbenie obrysov


Čo sú efekty

Môžeme si ich predstaviť ako zvláštne štetce pre špeciálne efekty. Efekty určujú spôsob, akým by sa mali meniť body na obrázku, keď cez ne prechádzame nástrojom (či už pri kreslení od ruky alebo pri kreslení úsečiek, obdĺžnikov alebo pridávaní textu a pod.). Ak napr. zvolíme efekt gumovanie a nakreslíme obdĺžnik, tento tvar sa z nášho obrázka zmaže.

Ak použijeme akýkoľvek efekt okrem gumovania, pri stlačení pravého tlačidla (myši alebo pera) sa daný tvar z obrázka zmaže. Prekvapujúce a zaujímavé výsledky tiež môžeme dosiahnuť, keď budeme kombinovať rôzne efekty s rôznymi povrchmi a motívmi.

Ak používame efekty, nasledujúce nastavenia ovplyvnia výsledok:

  • Ktorý efekt je zvolený?
  • Aká veľkosť hrotu je zvolená?
  • Aký tvar hrotu je nastavený?
  • Aká úroveň priesvitnosti je nastavená?
  • Je vyhladzovanie hrán vypnuté alebo zapnuté?
  • Ktorý tvar sa chystáme pomocou vybraného efektu vložiť do obrázka?
  • Aký text sa chystáme vložiť do obrázka; aké sú nastavenia textu?
  • Chceme vyplniť alebo nahradiť farbu?
  • Je nastavený nejaký povrch papiera?
  • Je zvolený motív?
  • Je nastavená niektorá súmernosť?

Pozri tiež:

  • Používanie efektov


Základné kreslenie

Základné kreslenie používame vtedy, keď chceme kresliť jednoduché bodky, úsečky, krivky alebo tvary bez umeleckých štetcov.

Všimnime si, že:

  • Pri Základnom kreslení sa používa momentálne nastavenú farbu a jej priesvitnosť.
  • Ak pri Základnom kreslení používame tablet s podložkou citlivou na tlak, zmenou tlaku pera nezmeníme hrúbku čiary, ale dosiahneme odlišnú sýtosť farby.
  • Keď ťahy pri Základnom kreslení opakujeme, sýtosť farby sa nezvýši.

Základné kreslenie môžeme použiť napr. aj vtedy, ak chceme vložiť do fotografie jasné a ľahko viditeľné technické informácie. V pravej polovici obrázka sú tie isté čiary nakreslené pomocou bielej a čiernej umeleckej ceruzky. Obidve farby ale RNA skombinovalo s bodmi za nimi, takže stratili svoju sýtosť.


Gumovanie

Gumovanie používame vtedy, keď chceme (čiastočne alebo úplne) odstrániť určité časti obrázka.

Všimnime si, že:

  • Gumovanie neberie do úvahy momentálne nastavenú farbu.
  • Účinnosť gumovania môžeme ovplyvniť tak, že nastavíme rozličné úrovne priesvitnosti. Čím nižšia je nastavená úroveň priesvitnosti, tým viac bude vymazaných bodov, cez ktoré guma prejde. Ak je úroveň priesvitnosti nastavená na 0%, každý vymazaný bod stratí svoju farbu a stane sa priesvitný.
  • Ak pri gumovaní používame tablet s podložkou citlivou na tlak, rôznym tlakom na pero dosiahneme rozličné úrovne priesvitnosti.
  • Ak gumujeme s použitím oblasti, stupeň vymazania jednotlivých bodov závisí od úrovne priesvitnosti príslušného bodu v oblasti. Čím nižšia je úroveň priesvitnosti, tým väčší stupeň bude stupeň vymazania. To isté platí, ak gumujeme pridávaním vyplneného tvaru (napr. vyplnenej elipsy alebo kruhu) a zvolili sme motív alebo povrch papiera.
  • k sme predtým na papieri určili niektorý obrázok ako pozadie alebo farbu pozadia, pri gumovaní obrázka sa odkryjú zodpovedajúce časti obrázka alebo farby pozadia.

Gumovanie nám tiež umožní vytvoriť niektoré pôsobivé vizuálne efekty.


Zosvetlenie

Zosvetlenie používame vtedy, keď chceme zosvetliť určité časti obrázka.

Všimnime si, že:

  • Zosvetlenie neberie do úvahy momentálne zvolenú farbu.
  • Stupeň zosvetlenia môžeme ovplyvniť tým, akú úroveň priesvitnosti nastavíme. Čím nižšia je nastavená úroveň priesvitnosti, tým bude väčší stupeň zosvetlenia.
  • Ak pri zosvetlovaní používame tablet s podložkou citlivou na tlak, rôznym tlakom na pero dosiahneme rozličný stupeň zosvetlenia.
  • Zosvetlenie predstavuje opačnú úpravu obrázka ako stmavenie.

Zosvetlenie je užitočným nástrojom pri upravovaní tmavých fotografií. Treba len nastaviť vysokú úroveň priesvitnosti a opakovane pokrývať obrázok (alebo jeho časť) pomocou vyplneného obdĺžnika, elipsy, mnohouholníka a pod.


Stmavenie

Tento efekt používame vtedy, keď chceme stmaviť určité časti obrázka.

Všimnime si, že:

  • Stmavenie neberie do úvahy momentálne zvolenú farbu.
  • Stupeň stmavenia môžeme ovplyvniť tým, akú úroveň priesvitnosti nastavíme. Čím nižšia je nastavená úroveň priesvitnosti, tým bude väčší stupeň stmavenia.
  • Ak pri stmavovaní používame tablet s podložkou citlivou na tlak, rôznym tlakom na pero dosiahneme rozličný stupeň stmavenia.
  • Stmavenie predstavuje opačnú úpravu obrázka ako zosvetlenie.


Vyhladenie

Vyhladenie používame vtedy, keď chceme vyhladiť prechody farieb alebo ostré hranice v rámci obrázka.

Všimnime si, že:

  • Vyhladenie neberie do úvahy momentálne zvolenú farbu.
  • Mieru vyhladenia môžeme ovplyvniť tým, akú úroveň priesvitnosti nastavíme. Čím nižšia je nastavená úroveň priesvitnosti, tým bude väčšia miera vyhladenia.
  • Ak pri vyhladzovaní používame tablet s podložkou citlivou na tlak, rôznym tlakom na pero dosiahneme rozličnú mieru vyhladenia.
  • Vyhladenie predstavuje opačnú úpravu obrázka ako zaostrenie.


Zaostrenie

Zaostrenie používame vtedy, keď chceme zvýrazniť hranice medzi odtieňmi.

Všimnime si, že:

  • Zaostrenie neberie do úvahy momentálne zvolenú farbu.
  • Mieru zaostrenia môžeme ovplyvniť tým, akú úroveň priesvitnosti nastavíme. Čím nižšia je nastavená úroveň priesvitnosti, tým bude väčšia miera zaostrenia.
  • Ak pri zaostrovaní používame tablet s podložkou citlivou na tlak, rôznym tlakom na pero dosiahneme rozličnú mieru zaostrenia.
  • Zaostrenie predstavuje opačnú úpravu obrázka ako vyhladenie.

Prvý obrázok ukazuje pôvodnú fotografiu. Efekt zaostrenia sme použili na vežu v žltom obdĺžniku s úrovňou priesvitnosti nastavenou na 50%. Na treťom obrázku vidíme výsledok. Štvrtý obrázok opäť vychádza z pôvodnej fotografie a použili sme pri ňom úroveň priesvitnosti 15%. Na piatom obrázku vidíme výsledok.


Farbenie

Farbenie používame vtedy, keď chceme upraviť farebné odtiene určitých častí obrázka.

Všimnime si, že:

  • Farbenie používa momentálne zvolenú farbu a premaľuje každý bod obrázka, cez ktorý prejde.
  • Intenzitu farbenia môžeme ovplyvniť tým, akú úroveň priesvitnosti nastavíme. Čím nižšia je nastavená úroveň priesvitnosti, tým väčšia bude intenzita farbenia.
  • Ak pri farbení používame tablet s podložkou citlivou na tlak, rôznym tlakom na pero dosiahneme rozličnú úroveň farbenia.

Prvý obrázok ukazuje pôvodnú fotografiu. Okno sme potom zafarbili žltým vyplneným mnohouholníkom s 0% priesvitnosťou. Tretí obrázok ukazuje výsledok. Štvrtý obrázok opäť vychádza z pôvodného obrázka a je zafarbený rovnakým žltým mnohouholníkom, ale s 65% priesvitnosťou. Piaty obrázok ukazuje výsledok.


Rozmazanie

Rozmazanie používame vtedy, keď chceme rozmazať určité časti obrázka.

Všimnime si, že:

  • Rozmazanie neberie do úvahy momentálne nastavenú farbu.
  • Rozsah rozmazania môžeme ovplyvniť tým, akú úroveň priesvitnosti nastavíme. Čím nižšia je nastavená úroveň priesvitnosti, tým bude väčší rozsah rozmazania.
  • Ak pri rozmazaní používame tablet s podložkou citlivou na tlak, rôznym tlakom na pero dosiahneme rozličnú hrúbku a rozsah rozmazania.
  • Ak pri rozmazávaní používame vyplnené tvary (ako napr. vyplnený kruh atď.), výsledný účinok bude podobný ako pri vyhladzovaní.

Rozmazávať sa oplatí s veľkými hrotmi nástroja (10 a viac), ktoré môžeme kombinovať s rôznymi úrovňami priesvitnosti.

Na prvom obrázku je pôvodná fotografia. Na druhom obrázku bol na odraze vody použitý efekt rozmazanie nanesený hrotom veľkosti 12, kreslením od ruky.


Farbenie obrysov

Farbenie obrysov používame vtedy, keď chceme zdôrazniť obrysy obrázka.

Všimnime si, že:

  • Farbenie obrysov používa momentálne zvolenú farbu. Všetky body, ktoré nie sú priesvitné, ale s priesvitnými bodmi susedia, sa zafarbia na momentálne zvolenú farbu.
  • Stupeň zafarbenia obrysov môžeme ovplyvniť tým, akú úroveň priesvitnosti nastavíme. Čím nižšia je nastavená úroveň priesvitnosti, tým bude väčší bude stupeň zafarbenia obrysov.
  • Ak pri farbení obrysov používame tablet s podložkou citlivou na tlak, rôznym tlakom na pero dosiahneme rozličný stupeň zafarbenia obrysov.

Tento efekt je veľmi užitočný napr. vtedy, keď potrebujeme stmaviť a zvýrazniť obrysy kreslenej postavy.


Práca s motívmi

Ako zaujímavú alternatívu k práve zvolenej farbe si môžeme vybrať motív, ktorý použijeme na vypĺňanie oblastí, alebo ako výplň vyplnených mnohouholníkov a vyplnenej krivky. Po zapnutí RNA nie je zvolený žiadny motív. Ak chceme niektorý použiť, kliknime na tlačidlo Motívy na Hlavnom paneli. Otvorí sa nám dialógové okno.

Ak klikneme na malú šípku pri slove Názov v pravej hornej časti dialógového okna Motív, otvorí sa ponuka všetkých motívov, ktoré sú momentálne k dispozícii. Vyberme si niektorý z nich, napríklad Rohy – v oblasti Ukážka vidíme, ako by použitie tohto motívu vyzeralo na papieri.

Všimnime si, že v dialógovom okne Motív môžeme upraviť spôsob, ako sa zvolený motív využije pri vypĺňaní plochy, útvaru, textu a pod. Na to používame voľby Rozloženie, Medzery a Posun.

  • Pri generovaní opakujúcich sa riadkov a stĺpcov vzorky sa využívajú štyri kópie motívu – vidíme ich v okienku Rozloženie. Každý z tejto štvorice motívov sa dá otočiť alebo vertikálne či horizontálne preklopiť. Všetky transformácie môžeme vytvoriť a skúmať práve v okienku Rozloženie. Postupne kliknime na každý zo štvorice motívov a v okne transformácií si preň vyberme jednu z možností. V okne Ukážka môžeme pozorovať zodpovedajúci efekt pri vytváraní celej vzorky riadkov a stĺpcov.

  • Ak chceme medzi stĺpce a riadky opakujúceho sa motívu vložiť Medzery, použime hornú skupinu volieb Na šírku a Na výšku.
  • Ak chceme určiť Posun medzi riadkami alebo stĺpcami opakujúceho sa motívu, použime dolnú skupinu volieb Na šírku a Na výšku.

  • Ak zapneme možnosť Zafarbovať, farby motívu sa transformujú na odtiene práve zvolenej farby.

  • Ak v dialógovom okne Motív klikneme na tlačidlo Znovu, zrušia sa všetky doposiaľ určené transformácie, teda Rozloženie, Medzery, Posun a Zafarbovať.
  • Všimnime si tiež, že výsledný vyplnený tvaru so zvoleným motívom je ovplyvnený aj momentálne zvoleným povrchom.

Všetky motívy sú uložené v priečinku RNA Motívy ako samostatné bitmapy vo formáte *.DIB. Môžeme si vytvoriť aj vlastný motív, pridať ho do tohto priečinku a používať ho rovnako ako ostatné motívy. Všimnime si, že akýkoľvek povrch z priečinku RNA Povrchy môžeme skopírovať aj do priečinku Motívy a používať ho ako motív.

Tiež si všimnime, že ku každému motívu máme ďalšie možnosti nastavenia v okne Motívy, ktorými môžeme pozmeňovať spôsob, akým budú znaky pokrývať tvar, oblasť, či text (pravá časť obrázka).

Vybrané motívy ovplyvňujú kreslenie vtedy, keď:

  • Do obrázka vkladáme vyplnené tvary, t.j. vyplnené elipsy, obdĺžniky, mnohouholníky, hviezdy, krivky a pravidelné mnohouholníky.
  • Vyplníme oblasť farbou alebo nahradíme farbu.
  • Do obrázka vkladáme text.
  • Použijeme niektorý efekty pomocou vyplneného tvaru (napr. stmavenie časti plochy pomocou vyplneného kruhu).

Ak chceme vypnúť mechanizmus kreslenia s motívom, vypnime tlačidlo Motív na Hlavnom paneli.


Práca s rôznymi povrchmi papiera

Povrch je zvyčajne malý kúsok grafiky, opakujúca sa vzorka, ktorá pod povrchom papiera vytvára neviditeľnú štruktúru. Keď na papier kreslíme, maľujeme alebo vkladáme naň tvary a texty, ukrytý povrch ovplyvní výsledný vzhľad obrázka. Keď začíname prácu s RNA, nemá zvolený žiaden povrch papiera. Ak chceme niektorý použiť, kliknime na tlačidlo Povrch na Hlavnom paneli. Otvorí sa nám dialógové okno so zvoleným povrchom bez štruktúry:

Kliknime na malú šípku vpravo hore vedľa slov bez štruktúry a otvorí sa nám zoznam všetkých povrchov, ktoré sú momentálne k dispozícii. Kliknutím si vyberme niektorý z nich, napríklad Tehly:

Všimnime si, že pre každý povrch máme k dispozícii tri stupne intenzity, ako ho má RNA použiť: Normálny, Jemný a Hrboľatý. Nasledujúci obrázok ukazuje v pravej časti výsledok pri každom z týchto troch stupňov pri kreslením olejovou pastelkou od ruky:

Zvolený povrch papiera sa vo výslednom obrázku prejaví vtedy, keď:

  • Kreslíme voľnou rukou alebo vkladáme tvary ako čiary, obdĺžniky, mnohouholníky atď.
  • Vypĺňame alebo nahrádzame farby.
  • Vkladáme text.
  • Vkladáme pečiatky.
  • Použijeme efekt, napríklad stmavenie atď.

Nasledujúci obrázok sme vytvorili pomocou Kamenného povrchu a Hrboľatého stupňa intenzity, použitím lúčov s olejovými pastelkami.

Povrchy papiera sú v skutočnosti súbory vo formáte *.DIB uložené v priečinku RNA Povrchy. Keď si zvolíme z priečinku nejaký Povrch, RNA vykachličkuje plochu neviditeľnou skrytou štruktúrou zo zvoleného povrchu. Keď potom kreslíme alebo maľujeme, táto neviditeľná štruktúra ovplyvňuje spôsob, akým sa farba nanáša na papier. V povrchoch papiera sa väčšinou používajú rôzne odtiene šedej spolu s rôznymi stupňami priesvitnosti a ovplyvňujú kreslenie takýmto spôsobom:

  • Tmavšie tóny povrchu stmavujú farbu, ktorú prikladáme do obrázka niektorým nástrojom. Výsledné body potom vyzerajú, akoby boli v tieni.
  • Svetlejšie tóny povrchu zosvetľujú farbu, ktorú prikladáme do obrázka niektorým nástrojom. Výsledné body potom vyzerajú, akoby boli osvetlené.
  • Čím menej priesvitné sú body povrchu, tým viac farby pridáme kreslením na ne.
  • Čím priesvitnejšie sú body povrchu, tým menej farby pridáme kreslením na ne.

Ak budeme rešpektovať tieto zásady, môžeme si vytvoriť vlastné povrchy a uložiť ich vo formáte DIB do priečinku Povrchy. Nasledujúci obrázok ilustruje tieto pravidlá. Povrch pozostáva zo šiestich malých štvorcov. Tri vrchné štvorce sú rovnakej šedej farby (v RGB modeli má táto farba kód [45 45 45]), avšak majú zväčšujúcu sa priesvitnosť od 0% cez 40% až na 80%. Tri nižšie štvorce sú bledo-šedej farby [190 190 190] s rovnakými stupňami priesvitnosti ako vo vrchnom riadku – 0%, 40% a 80%. Všimnime si, ako vyzerá obrázok, keď potom kreslíme na takýto povrch ceruzkou.

Ak chceme vypnúť mechanizmus kreslenia na špeciálne povrchy, vypnime tlačidlo Povrch na Hlavnom paneli.


Práca so súmernosťou

Veľa postáv a objektov je určitým spôsobom symetrických. Keď v RNA použijeme niektorý z druhov kreslenia so súmernosťou, rozšírime a obohatíme naše kreatívne možnosti. RNA ponúka horizontálnu a vertikálnu súmernosť a ich kombináciu. Vyskúšajme si nasledujúce tlačidlá (alebo im zodpovedajúce príkazy):

Súmernosť vľavo, vpravo, hore aj dolu
Vypnúť/zapnúť

Kliknime na toto tlačidlo na Hlavnom paneli alebo vyberme možnosť Maľovanie/Súmernosť/Vľavo, vpravo, hore aj dolu. Tým zapneme alebo vypneme kombináciu horizontálnej a vertikálnej súmernosti (pozri nižšie).

Súmernosť hore a dolu
Vypnúť/zapnúť

Kliknime na toto tlačidlo na Hlavnom paneli alebo vyberme možnosť Maľovanie/Súmernosť/Hore a dolu. Tým zapneme alebo vypneme horizontálnu súmernosť. Ak je zapnutá, objaví sa vodorovná vodiaca čiara v strede obrázka (alebo na inom mieste, ktoré sme predtým nastavili, pozri Nastaviť súmernosť nižšie). Vodiaca čiara označuje pozíciu mysleného horizontálneho zrkadla, ktoré odráža naše kroky, keď kreslíme, maľujeme, pridávame tvary, texty alebo pečiatky atď.

Súmernosť vľavo a vpravo
Vypnúť/zapnúť

Kliknime na toto tlačidlo na Hlavnom paneli alebo vyberme možnosť Maľovanie/Súmernosť/Vľavo a vpravo. Tým zapneme alebo vypneme vertikálnu súmernosť. Ak je zapnutá, objaví sa zvislá vodiaca čiara v strede obrázka (alebo na inom mieste, ktoré sme predtým nastavili, pozri Nastaviť súmernosť nižšie). Vodiaca čiara označuje pozíciu mysleného vertikálneho zrkadla, ktoré odráža naše kroky, keď kreslíme, maľujeme, pridávame tvary, texty alebo pečiatky atď.

Nastavenie súmernosti

Kliknime na toto tlačidlo na Hlavnom paneli. Umožní nám to meniť pozíciu vodiacich čiar súmernosti. Ak je zapnutá jedna z troch súmerností a klikneme na tlačidlo Nastaviť súmernosť, kurzor sa zmení na nitkový kurzor, pomocou ktorého môžeme presunúť vodiacu čiaru na akékoľvek miesto na obrázku. Ak je zapnutá iba horizontálna alebo vertikálna súmernosť, môžeme presúvať iba jednu vodiacu čiaru. Ak je zapnutá kombinácia horizontálnej a vertikálnej súmernosti, posúvame vždy bod, v ktorom sa vodiace čiary pretínajú. Akonáhle prestaneme posúvať jednu alebo obidve vodiace čiary a pustíme tlačidlo myši, Nastavenie súmernosti sa automaticky vypne.

Zapnuté môže byť vždy iba jedno z troch tlačidiel pre súmernosť. Ak chceme súmerné kreslenie vypnúť, musíme znova kliknúť na príslušné tlačidlo.

Ak je zapnuté niektoré súmerné kreslenie, prejaví sa pri týchto činnostiach:

  • Vkladanie tvarov a kreslenie od ruky, vkladanie textu, výplň a nahradenie farieb. Každý ťah alebo iný krok sa objaví na našom obrázku aj zrkadlovo otočený, vrátane vkladania textu.
  • Vkladanie pečiatok.
  • Používanie efektov, ako napr. základné kreslenie, gumovanie alebo rozmazanie.

Veľa zaujímavých obrázkov môžeme vytvoriť aj tak, že striedavo vypíname a zapíname súmernosti, používame rozličné umiestenia vodiacich čiar, vkladáme pečiatky najprv so súmernosťou, a potom bez nej, prepíname z jedného typu súmernosti na druhý atď. Nasledujúce obrázky sme vytvorili pomocou spomínaných techník.

Na obrázku hore sme použili horizontálnu aj vertikálnu súmernosť v štyroch rôznych pozíciách (pri vytváraní rámika pre poštové známky). Potom sme rámiky vyplnili rôznymi farbami (bez použitia súmernosti) a pridali do nich text a pečiatky z okna Pečiatok.

Na obrázku nižšie sme zasa pripravili pozadie, použili horizontálnu súmernosť a jediným ťahom vložili sériu pečiatok (pozri časť Pečiatky obsahujúce sériu obrázkov). Potom sme odraz postáv vo vode označili ako oblasť a zošikmili mierne doprava. Nakoniec sme odraz vo vode rozmazali pomocou svetlomodrej vodovej farby.


Postup na vrátenie krokov

Každý krok, ktorý urobíme pri vytváraní nášho obrázka (či už jednoduchého alebo zloženého), môžeme vrátiť späť, „cúvnuť“ v kreslení, maľbe, vytváraní animácie a pod. Táto možnosť zahŕňa ťahy štetca, vloženie tvarov, vloženie textu či pečiatky, vypĺňanie, zmeny veľkosti, zmeny poradia obrázkov v Obsahu, alebo zmeny poradia fáz v zábere, použitie akejkoľvek zmeny časti alebo viacerých častí v našom obrázku atď.

Pri vytváraní obrázka sa môžeme vrátiť o koľkokoľvek krokov, RNA si totiž pamätá celú sekvenciu nášho postupu – krok po kroku.

Ak si RNA zatiaľ nepamätá žiaden krok našej práce, tlačidlo Späť na Hlavnom paneli je nefunkčné. Ak si RNA pamätá jeden alebo viacero krokov, tlačidlo sa stane aktívnym a môžeme naň raz alebo opakovane klikať. Keď použijeme možnosť cúvať vo vývoji späť, stane sa aktívnym aj tlačidlo Znovu. Ak sa rozhodneme zopakovať svoje kroky, môžeme klikať na toto tlačidlo a obnoviť to, čo sme práve vrátili späť.

  • Ak chceme cúvnuť o krok späť, môžeme buď kliknúť na tlačidlo Späť, alebo zvoliť príkaz Úpravy/Späť <čo>.
  • Ak chceme zopakovať práve zrušený krok, môžeme buď kliknúť na tlačidlo Znovu, alebo zvoliť príkaz Úpravy/Znovu <čo>.


Vyhladzovanie hrán

Vyhladzovanie hrán je účinný spôsob ako zjemniť ťahy pri kreslení od ruky, úsečky, pravidelné tvary, ostré prechody a hrany písmen atď. Spočíva v tom, že RNA do obrázka pridá body navyše, ktoré majú rôzne úrovne priesvitností momentálne vybranej farby.

Môžeme ho vypnúť alebo zapnúť tak, že zapneme alebo vypneme tlačidlo Vyhladzovanie hrán na Hlavnom paneli. Podľa predvolených nastavení je tento nástroj zapnutý. Je užitočné používať ho vždy – s výnimkou prípadov, keď potrebujeme mať iba ostré hrany v našom obrázku.

Vyhladzovanie hrán má vplyv na tieto činnosti:

  • Vkladanie tvarov (ako napr. kreslenie od ruky, kreslenie úsečiek, kruhov, obdĺžnikov a pod.). Prvý riadok na obrázku vyššie ukazuje dvojicu kružníc. Ľavú z nich sme nakreslili so zapnutým vyhladzovaním hrán, pravú s vypnutým vyhladzovaním hrán.
  • Vypĺňanie plochy. Druhú a tretiu kružnicu vľavo sme vyplnili so vypnutým vyhladzovaním, druhú a tretiu kružnicu vpravo sme vyplnili so zapnutým vyhladzovaním.
  • Vkladanie textu.
  • Menenie veľkosti. Otáčanie a zošikmovanie oblasti.

Obrázok dolu ukazuje niekoľko párov objektov (oblastí, písmen, elíps a úsečiek). V každom páre sme prvý objekt vytvorili pri zapnutom vyhladzovaní a druhý pri vypnutom. Dvojica kvetináčov ukazuje, ako vyzerá výsledok zmenšovania oblasti (podobne pri otáčaní alebo zošikmení) s alebo bez vyhladzovania. Dvojica písmen znázorňuje rozdiel pod lupou, kedy sú detaily ľahko viditeľné. Posledná skupina ukazuje, ako závisí vyhladzovanie hrán od toho, aký používame štetec. Čierne elipsy s úsečkami sme nakreslili fixkou a nie sú medzi nimi žiadne viditeľné rozdiely. Modré elipsy a úsečky sme nakreslili vodovou farbou a účinok vyhladzovania hrán je už zjavný.


Práca s oblasťou

Tento režim používame, ak chceme na zvolenú obdĺžnikovú oblasť obrázka použiť jednu alebo viaceré funkcie RNA. O oblastiach sa dozvieme podrobnejšie v častiach:

  • Určenie oblasti
  • Príkazy ponuky oblasť


Príkazy ponuky Oblasť

Ak vyberieme možnosť Maľovanie/Oblasť alebo ak klikneme pravým tlačidlom myši na obdĺžnik oblasti, otvorí sa nasledujúca ponuka:

Označiť oblasť

Zapne alebo vypne režim definovania oblasti (to isté sa stane, ak klikneme na tlačidlo Oblasť na Hlavnom paneli). V tomto režime sa kurzor zmení a jeho potiahnutím môžeme označiť oblasť.

Otvoriť oblasť zo súboru…

Otvorí dialógové okno Otvoriť oblasť zo súboru. Potom môžeme otvoriť a na papier priložiť akýkoľvek obrázok v niektorom podporovanom grafickom formáte. Tento vložený obrázok bude rámikom označený ako nová oblasť.

Uložiť oblasť ako…

 Otvorí dialógové okno Uložiť oblasť. V tomto okne môžeme určiť meno súboru a formát, v akom chceme uložiť obsah oblasti.

Zachovať priesvitnosť

Ak je táto možnosť zapnutá, každý priesvitný bod oblasti zostane priesvitný, keď budeme hýbať celou oblasťou. V opačnom prípade priesvitné nezostanú.

Vrátiť k pôvodnej

Tento príkaz sa dá zvoliť, ak sme použili aspoň jednu z transformácií, ktoré sú pre oblasť dostupné. Príkaz zruší všetky transformácie, ktoré sme vykonali s obdĺžnikovou oblasťou. Príkaz však môžeme použiť iba vtedy, keď je oblasť ešte stále označená. (Neskôr môžeme použiť možnosť Späť a zrušiť sled zmien krok za krokom.)

Meniť veľkosť
Otáčať
Zošikmovať

Tieto príkazy nám umožňujú meniť veľkosť, otáčať a zošikmovať oblasť.

Transformácie

Otvorí ponuku s nasledujúcimi príkazmi:

  • Preklopiť vodorovne alebo Preklopiť zvislo.
  • Zmenšiť na 50% alebo Zväčšiť na 200%.
  • Otočiť o 90%, Otočiť o 180%, Otočiť o 270%.

Kresliť s oblasťou

Nastaví obsah oblasti ako vlastný hrot pre kreslenie.

Použiť ako pozadie

Otvorí ponuku so štyrmi štýlmi (Do stredu, Prispôsobiť, Natiahnuť, Vykachličkovať), ktoré určujú, akým spôsobom sa oblasť použije ako pozadie.

Pridať ako fázu

Skopíruje obsah oblasti a pridá ju ako novú fázu do označeného záberu.


Určenie oblasti

Oblasť určíme tak, že klikneme na tlačidlo Oblasť na Hlavnom paneli, alebo vyberieme príkaz Maľovanie/Oblasť/Označiť oblasť. V režime oblasť sa kurzor zmení na označovací krížik. Stlačením ľavého tlačidla a ťahaním po papieri označíme obdĺžnikovú oblasť nášho obrázka (pozri ilustráciu vľavo dolu).
Keď už je oblasť definovaná (pozri strednú časť ilustrácie dolu), môžeme s ňou robiť takéto akcie:

  • Predtým, než pohneme vybranou oblasťou z jej pôvodnej pozície, môžeme zmeniť hranice a polohu obdĺžnika oblasti (t.j. hranice ako také, nie obsah obdĺžnika). Keď podržíme stlačený kláves Shift, hranica oblasti sa mierne zmení (pozri ilustráciu vpravo dolu). Teraz môžeme potiahnuť jednu z ôsmych štvorcových značiek, a tým zmeníme veľkosť obdĺžnika. Keď potiahneme okraj alebo vnútornú časť obdĺžnika, budeme s rámikom oblasti hýbať po obrázku.

  • Ak kláves Shift nie je stlačený – potiahneme obsah označenej oblasti do inej pozície (pozri ilustráciu vľavo dolu). Obdĺžnikom môžeme hýbať buď pomocou myši, alebo grafickým perom, alebo pomocou šípok na klávesnici.
  • Ak je stlačený kláves Ctrl – potiahneme kópiu obsahu označenej oblasti do inej pozície na papier a tam ju pustením ľavého tlačidla myši položíme do obrázka.
  • Potiahneme jednu z ôsmych štvorcových značiek rámika, a tak zmeníme veľkosť obsahu oblasti (pozri strednú časť ilustrácie dolu).
  • Dvojklikneme na oblasť. Osem štvorcových značiek sa zmení na štyri krúžky (pozri pravú časť obrázka dolu). Keď za tieto krúžky potiahneme, môžeme otáčať celý obsah oblasti.

  • Ďalším dvojkliknutím do oblasti sa značky zmenia na osem trojuholníkov. Keď potiahneme za jeden zo štyroch trojuholníkov na stranách rámika, celá oblasť sa zošikmí (pozri ilustráciu vľavo dolu). Keď potiahneme za jeden zo štyroch trojuholníkov v rohoch rámika, oblasť sa skreslí (t.j. roztiahne a deformuje; pozri strednú a pravú časť ilustrácie dolu). Takto sa rámik oblasti zmení na rôznobežník.

  • Opakovaným dvojklikaním do vnútornej časti oblasti sa budeme cyklicky pohybovať medzi možnosťami meniť veľkosť –> otáčať –> zošikmovať alebo skresľovať –> ... Keď použijeme na jednu oblasť viacero takýchto zmien, môžeme dosiahnuť zaujímavé obmeny toho istého objektu (pozrime obrázok nižšie).
  • Ak sa chceme vrátiť k pôvodnému obrázku a zrušiť všetky transformácie, ktoré sme na ňom vykonali, kliknime pravým tlačidlom myši dovnútra oblasti a z ponuky vyberme príkaz Vrátiť k pôvodnej.

  • Pomocou tlačidla Esc môžeme zrušiť označenie oblasti.


Lupa

Je veľmi užitočné, keď môžeme zväčšiť alebo zmenšiť časti obrázka, s ktorými práve pracujeme. Pomáha nám to vyladiť detaily, presnejšie vybrať oblasť alebo sa pohybovať s presnosťou na jednotlivé body atď. Ak lupa nie je zapnutá, obrázok je zobrazený v Normálnej veľkosti, t.j. 100%. (Nezabudnime, že v režime Ukážka sa nám obrázok vždy zobrazí v normálnej veľkosti – ani zväčšený, ani zmenšený.)

Keď chceme zmeniť úroveň zväčšenia/zmenšenia, môžeme:

  • Otočiť koliesko myši.
  • Použiť klávesové skratky Ctrl+Q a Ctrl+W (alebo Ctrl+Num –, Ctrl+Num + a Ctrl+Num *).
  • Kliknúť na tlačidlo Zväčšiť na Hlavnom paneli.
  • Vybrať niektorú z možností ponuky Zobrazenie/Lupa.

Ak chceme zistiť aktuálnu úroveň zväčšenia, môžeme sa buď pozrieť na titulný riadok hlavného okna RNA, alebo otvoriť okno Lupa a skontrolovať v ňom úroveň zväčšenia.

V okne Lupa nájdeme náhľad na celý obrázok so zvýraznenou časťou, ktorá je práve zväčšená na papieri. Tento zvýraznený obdĺžnik môžeme pomocou myši (alebo grafického pera) posúvať v rámci náhľadu. Viac detailov nájdeme v časti o okne Lupa.


Pracujeme so sériou obrázkov. Animácie

RNA je efektívny a atraktívny nástroj na vytváranie samostatných obrázkov, ktoré môžeme tlačiť, ukladať a používať na rôzne účely (aj v iných aplikáciách). Okrem toho nám RNA umožňuje vytvárať a upravovať aj animované obrázky, napríklad:

  • Animované GIF-y pre webové stránky alebo rôzne prezentácie.
  • Animované kurzory pre Windows.
  • Obrázky pre Imagine, ktoré môžeme použiť pre korytnačky ako ich tvary.
  • Zložené pečiatky pre vlastné RNA.

Ak sa chceme naučiť podrobnosti o obrázkoch a spôsoboch ich používania, pozrime si aj časti:

  • Animovaný obrázok a jeho vlastnosti
  • Obsah
  • Ukážka animácie


Animovaný obrázok a jeho vlastnosti

RNA obrázky (a tiež LGF obrázky v prostredí Imagine, animované GIF-y, animované kurzory alebo obrázky LGW z prostredia Comenius Logo) sú zložité grafické dátové objekty, ktoré sa používajú najmä ako animované obrázky, zložené pečiatky pre RNA, alebo ako tvary pre korytnačky v prostredí Imagine atď. Každý animovaný obrázok je buď prázdna, alebo neprázdna séria záberov.

Každý záber sa skladá buď z jedného obrázka, alebo zo série obrázkov nazývaných fázy. Séria obrázkov tvorí druh animovaného filmu znázorňujúceho napríklad pohyb určitej postavy niektorým smerom. Teda rôzne zábery môžu znázorňovať pohyb tej istej postavy rôznymi smermi (ako napr. chôdzu doprava, chôdzu smerom k nám, chôdzu doľava a chôdzu smerom od nás).

Nasledujúci obrázok predstavuje súbor RNA robot (jeho názov môžeme vidieť pod názvom okna Obsah). V ľavej časti Obsahu (na kompase) vidíme, že obrázok robot obsahuje štyri zábery: každý z nich vyjadruje pohyb robota v určitom zväzku smerov. Napr. prvý záber ukazuje, ako by robot vyzeral, keby bol smer jeho pohybu medzi 335 a 65 stupňami (alebo inak vyjadrené, medzi -25° a 65°). Na obrázku dolu je práve označená prvá zo šiestich fáz tohto záberu. Vidíme tiež, že dĺžka jej trvania je 200 milisekúnd.

Všimnime si, že obrázky môžu mať:

  • Niekoľko záberov zobrazujúcich rôzne smery pohybu, pričom každý záber pozostáva z jedinej fázy. Ak použijeme takýto obrázok napr. ako tvar korytnačky, korytnačka nebude animovaná. Každý záber však bude vyjadrovať určitý jej smer (resp. zväzok smerov). Štandardná zelená korytnačka z prostredia Imagine je príkladom takéhoto obrázka.

  • Jediný záber pozostávajúci z niekoľkých fáz. Ak použijeme takýto obrázok napr. ako tvar korytnačky v prostredí Imagine, korytnačka nebude vyjadrovať svoj smer tvarom. Napriek tomu využije sériu fáz na automatickú animáciu. Viac sa dozvieme v časti Obsah.
  • Niekoľko záberov, z ktorých každý obsahuje niekoľko fáz. Takýto obrázok je typický pre animované korytnačky, ktoré automaticky (alebo manuálne – čiže určovaním čísla záberu) menia svoj tvar podľa súčasného smeru.

Animované obrázky sa využívajú napr. v projektoch Imagine alebo pri tvorbe webových stránok, prezentácií a pod. Okrem vlastnej grafickej podoby obsahuje každý obrázok aj tieto doplňujúce informácie:

  • Základný bod pre každú fázu.
  • Dĺžku trvania pre každú fázu.
  • Či sa má animovať podľa smeru alebo podľa čísla záberu.
  • Základný uhol.
  • Opakovanie animácie (zapnuté alebo vypnuté).


Dĺžka trvania

Každá fáza obrázka má svoju dĺžku trvania. Ak použijeme obrázok ako tvar korytnačky, Imagine bude automaticky zobrazovať všetky fázy zodpovedajúceho záberu jednu po druhej. Určené dĺžky trvania použije ako „rýchlosť“, s akou sa majú jednotlivé fázy vymieňať. Dĺžka trvania 1000 znamená 1000 milisekúnd, čiže 1 sekundu. Takto sa v prostredí Imagine zabezpečuje automatická animácia.

Ak chceme zmeniť dĺžku trvania jednej fázy, kliknime na súčasnú nastavenú dĺžku a prepíšme ju, alebo kliknime pravým tlačidlom na fázu a zvoľme Animácia/Nastaviť trvanie…. Vtedy sa otvorí dialógové okno Dĺžka trvania (podrobnosti možno nájsť v časti Obsah).

Ak chceme zmeniť dĺžku trvania všetkých fáz jedného záberu na rovnakú hodnotu, označme tento záber v Obsahu záberov a zvoľme možnosť Animácia/Nastaviť trvanie…. Otvorí sa dialógové okno Dĺžka trvania.

Ak chceme zmeniť dĺžku trvania všetkých fáz všetkých záberov na rovnakú hodnotu, označme obrázok v Obsahu obrázkov a zvoľme Animácia/Nastaviť trvanie… alebo kliknime pravým tlačidlom na obrázok v Obsahu obrázkov a zvoľme Animácia/Nastaviť trvanie…. Otvorí sa dialógové okno Dĺžka trvania.


Základný bod

V každej fáze je niektorý bod určený ako základný. Pracujú s ním viaceré príkazy jazyka Imagine – považujú ho za pozíciu tejto fázy. Ak sa napr. obrázok použije ako tvar korytnačky v prostredí Imagine, základný bod práve zobrazenej fázy obrázka sa umiestni do momentálnej pozície korytnačky. Všimnime si tiež, že:

  • Každá fáza obrázka má svoj vlastný základný bod.
  • Pri určovaní základného bodu v obrázku používame takýto súradnicový systém: Ľavý horný roh danej fázy má súradnice [0 0], X-ová súradnica rastie smerom doprava, Y-ová súradnica rastie smerom dolu.
  • Základný bod sa nemusí nachádzať vnútri fázy. Ak je napr. veľkosť fázy [53 30], základný bod môže mať súradnice [110 20] alebo [-25 -10] atď.

Umiestnenie základného bodu sa zobrazuje v režime Základný bod, ktorý môžeme zapnúť kliknutím na tlačidlo Základný bod na paneli Animácia, stlačením klávesu F11 alebo zvolením Zobrazenie/Základný bod).Keď zapneme tento režim, základný bod fázy sa zvýrazní bielym krížom. Okrem toho sa kurzor myši zmení na štyri biele šípky, ktoré umožňujú ľahké a presné určenie inej pozície (aj mimo obrázka a papiera) základného bodu.

Ďalšou možnosťou je určiť tento bod v dialógovom okne Základný bod, ktoré zobrazíme, ak zvolíme príkaz Animácia/Nastaviť základný bod.


Dialógové okno Základný bod

Ak chceme zobraziť toto dialógové okno, môžeme buď:

  • zvoliť Animácia/Nastaviť základný bod… v hlavnej ponuke, alebo
  • stlačiť Ctrl+H, alebo
  • zvoliť Animácia/Nastaviť základný bod… v ponuke Obsahu obrázkov, ak chceme zvoliť rovnaký základný bod pre všetky fázy všetkých záberov daného obrázka, alebo
  • voliť Animácia/Nastaviť základný bod… v ponuke Obsahu záberov, ak chceme zvoliť rovnaký základný bod pre všetky fázy daného záberu , alebo
  • zvoliť Animácia/Nastaviť základný bod… v ponuke Obsahu fáz, ak chceme zvoliť základný bod pre konkrétnu fázu.

Toto dialógové okno nám umožní určiť nový základný bod pre jednu alebo viacero fáz (podľa toho, čo sme označili, keď sme otvárali toto dialógové okno).

Poskytuje nám tri možnosti, ako určiť základný bod:

  • Použijeme okienka Súradnica X a Súradnica Y a zadáme polohu v percentách šírky a výšky danej fázy. Napríklad:

Základné body v obrázkoch sme zvolili nasledovne:
 | 50% a 50% | základný bod je v strede fázy
 | 50% a 100% | základný bod je v strede dolného okraja
 | 20% a 110% | Y-ová súradnica je mimo obrázka
 | -30% a 50% | X-ová súradnica je mimo obrázka

  • Použijeme okienka Súradnica X a Súradnica Y a zadať polohu v bodoch, napr. 20 a 10, alebo 0 a 0, alebo –10 a 50.

  • Použijeme možnosť Rýchly výber. Klikneme na niektorú z deviatich čiernych značiek, a tým určíme polohu základného bodu.

Všimnime si, že určenia základného bodu pomocou percent je veľmi užitočné v prípadoch, kedy naraz určujeme základný bod pre fázy rôznych veľkostí. Niekedy, najmä keď sami vytvárame alebo skenujeme animované obrázky, je dôležité určovať základný bod „ručne“ fázu za fázou, aby sme dosiahli realistickú a presvedčivú ilúziu pohybu.


Opakovanie animácie

Ak má obrázok zapnuté opakovanie animácie a použijeme ho napr. ako tvar korytnačky v prostredí Imagine, fázy záberu sa budú opakovane zobrazovať. V opačnom prípade sa animácia prehrá iba raz a zastane (ako animovaný film).

Aby sme zapli alebo vypli opakovanie animácie:

  • Zvoľme Animácia/Zábery.
  • Zapnime alebo vypnime voľbu Opakovať animáciu (alebo to isté urobíme v ponuke Obsahu záberov).


Animovanie podľa smeru alebo podľa čísla záberu

Obrázok môže pozostávať z niekoľkých záberov a obsahovať informáciu o tom, akým spôsobom sa majú tieto zábery použiť napr. pre animovanie v prostredí Imagine. Existujú dve možnosti:

  • V režime podľa smeru sa zábery v prostredí Imagine použijú automaticky tak, aby vždy vyjadrovali momentálny smer korytnačky.
  • V režime podľa čísla záberu nie sú zábery automaticky previazané so smerom korytnačky. Sami sa musíme rozhodnúť, ktorý záber korytnačka použije v danej chvíli ako jej tvar.

Keď použijeme obrázok z RNA ako tvar korytnačky v Imagine, jej nastavenie určovanie Záberu sa automaticky zapne alebo vypne podľa toho, v ktorom režime sme v RNA obrázok vytvorili.

Ak chceme prepnúť medzi animovaním podľa smeru a animovaním podľa čísla záberu a naopak:

  • Zvoľme možnosť Animácia/Zábery.
  • Označme alebo zrušme voľbu Animovať podľa smeru (alebo zvolíme to isté v ponuke Obsah záberov.)


Základný uhol

Každý obrázok, ktorý sa animuje podľa smeru, má určený uhol, ktorý sa nazýva základný uhol obrázka. Jeho hodnota vyjadruje stredný smer pre prvý záber obrázka. Zvyčajne to býva 0 stupňov, t.j. sever. Niekedy je však šikovné túto hodnotu zmeniť. Nasledujúci obrázok napr. predstavuje robota, ktorý má štyri zábery. Prvý záber ukazuje robota kráčajúceho smerom od nás. Základný uhol tohto záberu je (kvôli názornému vyjadreniu priestoru a perspektívy) 20°.

V tomto prípade je rozumné rozdeliť všetky možné smery pohybu robota na štyri skupiny: od -25° do 65°, od 65° do 155°, od 155° do 245° a od 245° do 335°, t.j. -25°.

Ak chceme zmeniť základný uhol obrázka, zvoľme Animácia/Zábery/Nastaviť základný uhol… alebo kliknime na uhol v strede kompasu v Obsahu záberov.


Dialógové okno Vytvoriť animáciu

Podobá sa oknu Transformovať obrázok: aj pomocou tohto nástroja môžeme urobiť zmenu veľkosti fázy alebo fáz, ich otočenie a preklopenie spolu s vyhladzovaním hrán. Rozdiel medzi oknami Vytvoriť animáciu a Transformovať obrázok však spočíva v tom, že kým okno Transformovať obrázok mení a prepisuje pôvodnú fázu či fázy, okno Vytvoriť animáciu ich zachová a pridá (vygeneruje) jednu alebo niekoľko ďalších (ich počet určujeme v okienku Počet).

Pri tomto postupe sa môže stať (v závislosti od nastavení v dialógovom okne), že pre každú zvolenú fázu vytvoríme sériu nových fáz, ktoré budú znova obsahovať aj pôvodnú fázu – napr. nové fázy budú obsahovať pôvodnú fázu ako poslednú v sérii. V niektorých prípadoch si ju v sérii necháme, inokedy ju odstránime.

Nasledujúce tri príklady ilustrujú oba prípady. V každom z nich sme najprv zvolili jednu fázu včely, a potom otvorili dialógové okno Vytvoriť animáciu.

Príklad 1

Nastavenia sú Počet = 8, Uhol = 360 a je zapnuté Vyhladzovanie hrán. Znamená to, že z označenej fázy včely vznikne 8 nových fáz, ktoré budú postupne rovnomerne ponatáčané doprava tak, aby posledná z nich bola otočená o 360 stupňov. Čiže prvá nová fáza bude otočená o 45°, druhá o 90°, tretia o 135°… atď.

Keďže jediný použitá transformácia je tu otočenie (bez zmeny veľkosti alebo preklopenia), posledná fáza bude rovnaká ako prvá, takže ju môžeme odstrániť.

Príklad 2

V tomto príklade sme použili tie isté nastavenia, pridali sme však Zmenu veľkosti na 10%. Znamená to, že fázy sa budú postupne zmenšovať tak, aby posledná mala 10% z veľkosti prvej. Samozrejme, teraz nie je posledná fáza identická s prvou, takže ju nevyhodíme.

Príklad 3

Nastavenia sú Počet = 8, žiadna Zmena veľkosti, t.j. Šírka a Výška = 100%, žiadne Otočenie, avšak zvolíme zvislé preklopenie. Výsledkom bude séria 8 nových fáz, ktoré sa postupne preklápajú zvislo tam a späť vo svojej pôvodnej veľkosti 100%.

Dialógové okno Vytvoriť animáciu je však ešte mocnejším nástrojom. Zatiaľ sme vždy mali v Obsahu fáz jedinú fázu a z nej generovali sériu nových transformácií. Teraz však vychádzajme z obrázka, ktorý má jediný záber s viacerými fázami (na nasledujúcom obrázku sú to dve fázy včely letiacej na sever). Označme teraz celý záber a otvorme dialóg Vytvoriť animáciu. Nastavme Počet = 12, Otočenie = 360° a zapnime Vyhladzovanie hrán. Výsledkom generovania bude 12 animovaných záberov, z ktorých každý obsahuje toľko fáz ako pôvodný záber (v našom prípade dve), a sú rovnomerne pootáčané tak, aby pokryli celkové otočenie 360°. Nasledujúci obrázok ilustruje tretí z týchto záberov.


Dialógové okno Transformovať obrázok

Toto dialógové okno nám pomáha upraviť jednu alebo niekoľko fáz tým, že zmeníme ich veľkosť, otočíme ich alebo preklopíme. Ľubovoľnú kombináciu týchto úprav môžeme vykonať so všetkými vybranými fázami v jednom kroku, a to so zapnutým alebo vypnutým Vyhladzovaním hrán.

Ak chceme otvoriť dialógové okno Transformovať obrázok, označíme jednu alebo niekoľko fáz, alebo niekoľko záberov, prípadne aj celý obrázok kliknutím na jeho záložku v okne Obsah. Potom buď:

  • zvolíme príkaz Animácia/Transformovať…, alebo
  • stlačíme Alt+T, alebo
  • klikneme pravým tlačidlom na označenú fázu/fázy, alebo záber, alebo obrázok a zvolíme zo zobrazenej ponuky príkaz Animácia/Transformovať….

Zmena veľkosti

Hodnoty pre Zmenu veľkosti zadávame buď:

  • ako percento pôvodnej veľkosti (napr. 33%, 50%, 150% atď.), alebo
  • ako celé číslo, napr. 40 alebo 230, ktoré určuje presnú šírku alebo výšku zmeneného obrázka v bodoch.

Každú z týchto hodnôt môžeme buď vybrať z pripojenej ponuky, alebo zadať ako kladné celé číslo, alebo percento. Všimnime si tiež, že pod Výškou je okienko Proporčne. Táto voľba zachováva pomer medzi výškou a šírkou obrázka. Ak ju nezvolíme, môžeme určovať každú hodnotu zvlášť.

Otočenie

Hodnotou pre Otočenie je uhol (zadaný v stupňoch), ktorým určujeme, o koľko chceme otočiť obrázok v smere hodinových ručičiek. Môžeme tu však zadať aj zápornú hodnotu uhla – vtedy sa bude obrázok otáčať proti smeru hodinových ručičiek.

Preklopenie

Funkcia Preklopenie nám umožňuje preklopiť obrázok buď vodorovne a/alebo zvislo zároveň so zmenou jeho veľkosti a/alebo otočením.

V tomto dialógovom okne môžeme zvoliť ľubovoľnú kombináciu popísaných funkcií. Keď napokon klikneme na tlačidlo OK, zložená transformácia sa aplikuje na všetky označené fázy a pôvodný obrázok sa nahradí výsledným. Tieto kroky však môžeme vrátiť späť tlačidlom Späť.

Nasledujúci príklad ukazuje transformáciu veľkosti na 200%, a zároveň otočenie o 90 stupňov. Zväčšili a otočili sme obe fázy zároveň.


Obsah

Prehľad okna Obsah

Okno Obsah je hlavným prvkom RNA na organizovanie našej práce, keď pracujeme s viacerými obrázkami, alebo so sériou animovaných obrázkov (konkrétne s obrázkami formátu RNA a LGF, ale tiež s animovanými súbormi GIF, animovanými ikonami atď.). Pomáha nám udržiavať si prehľad o všetkých obrázkoch, ktoré máme otvorené na obrazovke. Pri animovaných obrázkoch nám pomáha organizovať, generovať, upravovať a usporadúvať všetky jeho zábery a fázy.

Okno Obsah môže byť skryté, otvorené, alebo minimalizované. Pokiaľ nie je skryté, môže byť ukotvené (väčšinou v spodnej časti hlavného okna) alebo voľné, takže ho môžeme presúvať na ľubovoľnú vyhovujúcu pozíciu na obrazovke:

  • Ak je Obsah úplne skrytý, otvoríme ho stlačením klávesu F4 alebo tak, že zvolíme možnosť Zobrazenie/Obsah.
  • Ak je okno zmenšené, klikneme na malý trojuholník v jeho pravom hornom rohu.
  • Ak je zobrazené, môžeme ho zavrieť kliknutím na malý krížik, alebo ho zmenšíme kliknutím na trojuholník.
  • Ak je Obsah ukotvený, potiahnutím za vrchný pás ho uvoľníme a umiestnime na ľubovoľnú pozíciu.

Okno Obsah má tri časti, ako ukazuje nasledujúci obrázok:

  • Obsah obrázkov na prácu s obrázkami.
  • Obsah záberov na prácu so zábermi.
  • Obsah fáz na prácu s fázami.

Vzhľad a funkčnosť týchto častí závisí od toho, kde sme posledne klikli myšou (čiže kde je práve „fokus“), a tiež od toho, či je označený jeden alebo niekoľko obrázkov, záberov alebo fáz.

V Obsahu môžeme meniť poradie obrázkov na ploche, poradie záberov animovaného obrázka, a tiež poradie fáz v zábere. Navyše, môžeme tu aplikovať aj rôzne operácie a zmeny na jeden alebo niekoľko obrázkov, záberov alebo fáz.

Taktiež tu môžeme voliť niektoré nastavenia, ako opakovanie animácie, animovanie podľa smeru, základný uhol a niektoré ďalšie základné vlastnosti obrázka. Alebo si môžeme jednoducho zvoliť obrázok, vybrať si jeden jeho záber a jednu jeho fázu, ktorá sa zobrazí na stránke, takže s ňou môžeme pracovať.


Práca s obrázkami

V RNA môžeme mať na obrazovke otvorených niekoľko obrázkov. Vďaka tomu môžeme kopírovať časti jedného obrázka do iného, meniť viaceré obrázky rovnakým spôsobom v jedinom kroku, alebo tiež použiť zložené transformácie na všetky zábery a fázy týchto obrázkov súčasne.

Každý obrázok, ktorý sme otvorili, má svoju vlastnú záložku vo vrchnej časti okna Obsah. Táto záložka obsahuje meno otvoreného súboru.

Poznámka pre pokročilých používateľov: Každý obrázkový súbor formátu RNA a LGF môže v sebe obsahovať niekoľko obrázkov. Keď otvoríme takýto súbor, každý z obrázkov dostane svoju vlastnú záložku (s pripojeným číslom; pozri nasledujúcu ilustráciu) a obrázky prestanú byť spojené dokopy. Aby sme uložili niekoľko obrázkov do jediného súboru, musíme ich všetky označiť a zvoliť možnosť Uložiť ako… z ponuky Obsahu obrázkov.

  • Ponuka obsahu obrázkov
  • Obsah obrázkov s jedným zvoleným obrázkom
  • Obsah obrázkov s niekoľkými zvolenými obrázkami


Obsah obrázkov s jedným zvoleným obrázkom

Na ilustrácii je označený práve jeden z obrázkov. Zároveň je v Obsahu záberov označený prvý záber obrázka a v Obsahu fáz označená jeho prvá fáza.

V okne Obsah môžeme jednoducho meniť zoradenie obrázkov tak, že na záložke obrázka stlačíme tlačidlo myši a potiahneme ju na iné miesto.

Celý obrázok môžeme tiež Kopírovať a Vložiť ho:

  • ako kópiu nového obrázka, alebo
  • ako nový záber (cez ponuku Obsahu záberov), ak obrázok obsahuje viac záberov, vložia všetky zábery, alebo
  • ako novú fázu (cez ponuku Obsahu fáz), ak obrázok obsahuje viac fáz, vložia sa všetky fázy obrázka.


Obsah obrázkov s niekoľkými zvolenými obrázkami

Ak stlačíme kláves Shift a postupne klikneme na viacero záložiek v Obsahu obrázkov, označíme niekoľko za sebou idúcich obrázkov. V takomto prípade sa v Obsahu záberov nezobrazia žiadne zábery a v Obsahu fáz žiadne fázy.

Teraz môžeme presúvať celé skupiny obrázkov a meniť tak poradie ich záložiek. Môžeme tiež zvoliť ľubovoľný príkaz z ponuky Obsahu obrázkov, ktorá sa otvorí tak, že pravým tlačidlom myši klikneme na tieto záložky. Zvolený príkaz sa vykonaná pre všetky označené obrázky. Keď zvolíme príkaz Uložiť alebo Uložiť ako..., všetky označené obrázky sa uložia do jedného súboru.

Ak spustíme Ukážku animácie s viacerými označenými obrázkami, všetky fázy všetkých záberov týchto obrázkov sa postupne zobrazia v jedinom ukážkovom cykle, akoby boli spojené dokopy.


Ponuka Obsahu obrázkov

Keď klikneme pravým tlačidlom na záložku príslušného obrázka v Obsahu obrázkov, otvorí sa nám nasledujúca ponuka:

Umožňuje nám:

Nový

Ctrl+N

Rovnaké ako príkaz Súbor/Nový.

Otvoriť…

Ctrl+O

Rovnaké ako príkaz Súbor/Otvoriť….

Uložiť

Ctrl+S

Rovnaké ako príkaz Súbor/Uložiť.

Uložiť ako…

Alt+F2

Rovnaké ako príkaz Súbor/Uložiť ako….

Zatvoriť

Ctrl+F4

Rovnaké ako príkaz Súbor/Zatvoriť.

Úpravy

Ponuka Úpravy je rovnaká ako ponuka Úpravy v časti Obsah záberov. Jediným rozdielom je to, že tieto úpravy sa týkajú celého obrázka. Ak v tejto ponuke zvolíme Označiť všetko, označia sa všetky záložky. Ak zvolíme Kopírovať obrázok, môžeme ho:

  • Vložiť do Obsahu obrázkov, čo znamená, že vytvoríme novú záložku (alebo záložky) s presnou kópiou označeného obrázka (či obrázkov).
  • Vložiť (cez ponuku Obsahu záberov) do časti Obsah záberov, čo znamená, že sa sem vložia všetky zábery označených obrázkov.
  • Vložiť (cez ponuku Obsahu fáz) do časti Obsah fáz, čo znamená, že sa sem vložia všetky fázy všetkých záberov označených obrázkov.

Animácia

Ponuka Animácia je rovnaká ako ponuka Animácia v časti Obsah záberov. Jediným rozdielom je to, že tieto úpravy sa týkajú celého obrázka.


Práca so zábermi

Obsah záberov sa nachádza na ľavej strane okna Obsah, pod záložkami s menami otvorených obrázkov. Ak sú v Obsahu obrázkov práve otvorené rôzne obrázky, v Obsahu záberov bude v závislosti od označeného obrázka a jeho typu toto:

  • Ak je to fotografia, pozadie, alebo iný typ jednotlivého obrázka, v Obsahu záberov uvidíme jednoduché políčko.
  • Ak je označený obrázok typu animovanie podľa smeru a obsahuje niekoľko záberov, uvidíme tu kompas rozdelený na niekoľko úsekov.
  • Ak je označený obrázok typu animovanie podľa čísla záberu a obsahuje niekoľko záberov, alebo ak je označený obrázok napr. formátu GIF, uvidíme tu zoznam mien záberov v malých políčkach.
  • Ak je v Obsahu obrázkov označených niekoľko obrázkov, Obsah záberov bude prázdny.

Na týchto ilustráciách vidíme:

  • najprv označenú jednu fotografiu,
  • ďalej animovaný obrázok robota pozostávajúci zo štyroch záberov, ktorý je v režime animovanie podľa smeru,
  • potom jeden označený záber zo šiestich záberov z obrázka, ktorý je v režime animovanie podľa čísla záberu, a
  • na poslednom obrázku vidíme označené dva obrázky súčasne.

Pozri tiež:

  • Ponuka Obsahu záberov
  • Obsah záberov pre obrázok animovaný podľa smeru
  • Obsah záberov pre obrázok animovaný podľa čísla záberu


Obsah záberov pre obrázok animovaný podľa čísla záberu

Ak chceme prepnúť medzi animovaním podľa smeru a animovaním podľa čísla záberu, kliknime pravým tlačidlom myši do Obsahu záberov a v ponuke vypnime/zapnime Animovanie podľa smeru, alebo prepnime voľbu Animácia/Zábery/Animovať podľa smeru.

V tomto príklade sme označili jeden záber – v Obsahu fáz vidíme jeho fázy (v tomto prípade len jednu).

Ľahko môžeme zmeniť poradie záberov tým, že myšou potiahneme označený záber na iné miesto v zozname záberov. Kým hýbeme myšou, nová pozícia sa zobrazuje ako čierna čiara. Keď tlačidlo pustíme, záber sa premiestni na určené miesto a všetky zábery sa premenujú podľa nového poradia na Záber 1, Záber 2… atď.

Ak chceme označiť niekoľko za sebou idúcich záberov, kliknime na prvý z nich, potom stlačme kláves Shift a kliknime na posledný z nich.

Ak chceme označiť všetky zábery, môžeme:

  • Stlačiť Ctrl+A (ak sme v tejto časti), alebo
  • zvoliť príkaz Úpravy/Označiť všetko z ponuky Obsahu záberov, ktorá sa zobrazí, keď klikneme pravým tlačidlom do tejto časti Obsahu, alebo
  • kliknúť na prvý záber, stlačiť Shift a potom kliknúť sa posledný záber.

Príkazy, ktoré vykonáme po označení viacerých záberov, sa aplikujú na všetky fázy všetkých označených záberov.


Obsah záberov pre obrázok animovaný podľa smeru

Farba označeného záberu (a tiež rámika okolo jeho prvej fázy) je v tomto príklade bledá – znamená to, že práve teraz pracujeme s prvou fázou tohto záberu niekde inde, možno ju upravujeme na papieri alebo skúmame pod lupou...

Vidíme, že obrázok je typu animovanie podľa smeru a jeho základný uhol je 20° (namiesto zvyčajných 0°).

Farba označeného záberu je teraz tmavá, pretože sme práve klikli myšou do Obsahu záberov na úsek zodpovedajúci jeho smeru. Keď klikneme na hodnotu základného uhla, zmení sa tento prvok na editovacie okienko, takže doňho môžeme z klávesnice napísať novú hodnotu.
Môžeme tiež záber Vystrihnúť alebo Kopírovať (t.j. všetky jeho fázy), a potom ich Prilepiť buď do tejto časti ako zábery, alebo do časti Obsahu fáz (cez ponuku Obsahu fáz) ako fázy.

Keď myšou ťaháme tmavomodrý (označený) úsek po obvode kompasu, vystrihneme označený záber z jeho súčasnej pozície a presunieme ho na novú pozíciu medzi ostatné zábery obrázka. Pozícia vloženia sa vždy zobrazuje krátkou čiernou čiarou.

Ak stlačíme ktorýkoľvek z klávesov Shift, Ctrl alebo Alt a zároveň ťaháme myšou niektorý úsek po obvode kompasu, otáča sa celý kruh. Takto meníme základný uhol obrázka.

Teraz sú označené dva zábery v Obsahu záberov. Viacero záberov označujeme v Obsahu záberov tak, že klikneme na prvý z nich, stlačíme Shift a klikneme na posledný z tých, ktoré chceme označiť. Označia sa všetky úseky medzi prvým a posledným (v smere hodinových ručičiek). Nie je možné označiť zábery, ktoré nie sú susedné.

Ak je označených viacero záberov, Obsah fáz je prázdny. Takisto aj oblasť Papiera je prázdna (pokiaľ nie je zapnutá Ukážka animácie).

Ak chceme označiť všetky zábery, môžeme:

  • Zvoliť príkaz Úpravy/Označiť všetko z ponuky Obsah záberov, ktorá sa zobrazí, keď klikneme pravým tlačidlom do tejto časti Obsahu, alebo
  • stlačiť Ctrl+A (ak sme v tejto časti), alebo
  • kliknúť na ľubovoľný záber, stlačiť kláves Shift a potom kliknúť na predchádzajúci záber (t.j. na vedľajší záber proti smeru hodinových ručičiek).

Príkazy, ktoré vykonáme po označení viacerých záberov, sa aplikujú na všetky fázy všetkých záberov. Označenú skupinu záberov môžeme tiež Vystrihnúť alebo Kopírovať, a potom ju Prilepiť ako zábery, alebo ako fázy v Obsahu fáz.


Ponuka Obsahu záberov

Keď klikneme pravým tlačidlom na meno niektorého záberu alebo na kompas v Obsahu záberov, otvorí sa nám nasledujúca ponuka:

Umožňuje nám:

Opakovať animáciu

Zapne alebo vypne opakovanie animácie celého (označeného) obrázka.

Animovať podľa smeru

Zapne alebo vypne animovanie podľa smeru celého (označeného) obrázka, t.j. zmení ho na režim animovanie podľa čísla záberu alebo späť).

Nastaviť základný uhol…

Umožní nastaviť základný uhol celého (označeného) obrázka.

Zmeniť na fázy

Zmení všetky fázy všetkých záberov tohto obrázka na jediný záber obsahujúci všetky fázy v jednej dlhej sérii.

Úpravy

Umožní nám meniť postupnosť záberov príkazmi z ponuky Úpravy. Môžeme:

  • Vystrihnúť označený záber alebo označené zábery a dať ich do schránky.
  • Kopírovať označený záber alebo označené zábery do schránky.
  • Prilepiť pred alebo Prilepiť za záber alebo zábery zo schránky.
  • Vložiť nový záber pred alebo za označený.
  • Odstrániť označený záber alebo označené zábery.
  • Označiť všetky zábery pre ďalší príkaz.

Animácia

Ponúkne nám zoznam príkazov, ktoré možno vykonať pre všetky fázy označeného záberu alebo záberov. Môžeme:

  • Nastaviť novú dĺžku trvania pre všetky fázy označeného záberu alebo záberov.
  • Nastaviť základný bod pre všetky fázy označeného záberu alebo záberov.
  • Minimalizovať všetky fázy označeného záberu alebo záberov (rovnako ako príkazom Animácia/Minimalizovať alebo tlačidlom Minimalizovať na Hlavnom paneli).
  • Vytvoriť prelínanie (druh vizuálneho priemeru) pre každý pár za sebou idúcich fáz (rovnako ako príkazom Animácia/Vytvoriť prelínanie).
  • tvoriť dialógové okno Vytvoriť animáciu a generovať nové fázy podľa nastavení v ňom.
  • Prevrátiť poradie fáz označeného záberu alebo záberov.
  • Otvoriť dialógové okno Transformovať obrázok a vykonať niektorú zloženú transformáciu na všetky fázy označeného záberu alebo záberov.


Práca s fázami

Táto časť Obsahu nám pomáha vyznať sa a usporadúvať fázy označeného záberu. Zobrazuje buď:

  • Jednu fázu, ak je označený jednoduchý obrázok (fotografia, pozadie atď.) alebo ak zvolený záber obsahuje len jednu fázu, alebo
  • všetky fázy záberu zvoleného obrázka alebo animovaného GIF súboru či animovaného kurzora atď., alebo
  • nič, ak je označených viacero obrázkov alebo viacero záberov obrázka.

Pamätajme si, že vždy, keď záber obsahuje viac ako jednu fázu a neskôr tento obrázok použijeme ako tvar korytnačky v prostredí Imagine, fázy sa budú automaticky striedať ako v animovanom filme – prehrajú sa iba raz, ak obrázok nemá zapnuté opakovanie animácie, alebo sa budú hrať v nekonečnej slučke, ak má obrázok zapnuté opakovanie animácie. Všimnime si tiež, že séria fáz príslušného záberu síce súvisí s animovaním korytnačky, ale nesúvisí s tým, či je obrázok typu animovanie podľa smeru alebo animovanie podľa čísla záberu.

  • Ponuka obsahu fáz
  • Obsah fáz pri jednej označenej fáze
  • Obsah fáz pri viacerých označených fázach


Obsah fáz pri jednej označenej fáze

V časti Obsah fáz máme označenú jednu fázu. Zvolená fáza je zároveň zobrazená na ploche, takže ju môžeme upravovať.

Ľahko môžeme zmeniť poradie fáz tým, že potiahneme označenú fázu na iné miesto. Kým hýbeme myšou, nová pozícia je naznačená čiernou čiarou. Keď tlačidlo myši pustíme, fáza sa presunie na toto miesto.

Fázu môžeme aj Vystrihnúť alebo Kopírovať, a potom ju Prilepiť buď:

  • ako fázu, alebo
  • ako záber s jednou fázou (cez ponuku Obsah záberov) v časti Obsah záberov.

Na nasledujúcom obrázku vidíme, že každá fáza má pod sebou zobrazenú svoju dobu trvania. Môžeme ju zmeniť kliknutím na toto políčko a prepísaním hodnoty.

To isté môžeme urobiť, ak zvolíme príkaz Animácia/Nastaviť trvanie… v ponuke Obsah fáz, ktorú otvoríme kliknutím pravého tlačidla na danú fázu, alebo ak stlačíme klávesovú skratku Ctrl+D. V týchto prípadoch sa otvorí dialógové okno Dĺžka trvania.


Obsah fáz pri viacerých označených fázach

Ak chceme označiť viacero za sebou idúcich fáz, kliknime na prvú z nich, potom stlačme kláves Shift a kliknime na poslednú z nich. Ak chceme označiť všetky fázy, môžeme zvoliť príkaz Úpravy/Označiť všetko z ponuky Obsah záberov, ktorá sa objaví po kliknutí pravým tlačidlom na značku daného záberu, alebo ak stlačíme klávesovú skratku Ctrl+A. Ak je označených viacero fáz, Papier je prázdny (pokiaľ nie je zapnutá Ukážka animácie).

Poradie fáz môžeme zmeniť ťahaním označenej skupiny v Obsahu fáz. Môžeme tiež Vystrihnúť alebo Kopírovať celú skupinu a Prilepiť ju buď do tejto časti ako fázy, alebo do Obsahu záberov ako nový záber s označenými fázami (cez ponuku Obsahu záberov).


Ponuka Obsahu fáz

Keď klikneme pravým tlačidlom na Obsah fáz, otvorí sa takáto ponuka:

Umožňuje nám:

Zmeniť na zábery | Bez ohľadu na počet označených fáz môžeme zvoliť príkaz Zmeniť na zábery. Všetky fázy daného záberu sa vtedy zmenia na sekvenciu jednofázových záberov a nahradia práve označený záber. Oblasť Obsahu fáz bude teraz prázdna a novovytvorené zábery budú označené v Obsahu záberov.
Úpravy | Ponuka Úpravy je rovnaká ako ponuka Úpravy v časti Obsah záberov. Jediným rozdielom je to, že kým v Obsahu záberov sa všetky príkazy, ako Vystrihnúť alebo Prilepiť, aplikovali na označené zábery, tu sa tieto príkazy aplikujú na označené fázy.
Animácia | Ponuka Animácia je rovnaká ako ponuka Animácia v časti Obsah záberov. Jediným rozdielom je to, že kým v Obsahu záberov sa všetky príkazy, ako Nastaviť trvanie… alebo Minimalizovať, aplikovali na označené zábery, tu sa tieto príkazy aplikujú na označené fázy.

Ponuky Úpravy a Animácia umožňujú vykonať zložené úpravy na viacerých fázach súčasne.


Ukážka animácie

Oblasť stránky (pracovnú oblasť) hlavného okna RNA pokrýva:

  • Momentálne zvolená fáza upravovaného obrázka – buď zväčšeného/zmenšeného alebo v jeho normálnej veľkosti, alebo
  • Ukážka animácie momentálne zvoleného záberu (alebo niekoľkých záberov). Ak má označený záber niekoľko fáz, v animačnej slučke sa prehráva „film“ zložený zo všetkých zvolených fáz – alebo sa prehrá iba raz, ak nie je zapnutá voľba Opakovať animáciu.

Ak sa chceme prepnúť medzi režimom Maľovanie a Ukážka animácie, môžeme:

  • Stlačiť kláves F9, alebo
  • stlačiť tlačidlo Prehrať normálne alebo Prehrať odzadu na paneli Animácia, alebo
  • vybrať možnosť Zobrazenie/Ukážka animácie.

Kedykoľvek sa prepneme do režimu Ukážka animácie, obrázok (alebo obrázky) sa zobrazia v normálnej veľkosti (nezávisle od úrovne zväčšenia, ktorú práve používame v režime Maľovanie).

Ak sa chceme dozvedieť viac o ukážke animácie, pozrime si aj časti:

  • Panel Animácia
  • Umiestnenie obrázka
  • Ponuka v oblasti Ukážky animácie


Umiestnenie obrázka

Čo sa stane, ak klikneme ľavým tlačidlom do oblasti Ukážky animácie:

  • Ak krátko klikneme kamkoľvek do tejto oblasti, zobrazený obrázok preskočí na túto pozíciu.
  • Ak klikneme do oblasti Ukážky a potiahneme myšou, obrázok preskočí na túto pozíciu a nechá sa ťahať myšou po ploche (až dokým nepustíme tlačidlo myši). Takto môžeme obrázok premiestniť kamkoľvek v rámci oblasti ukážky.
  • Ak stlačíme kláves Ctrl a potiahneme myšou, obrázok preskočí na pozíciu, kde sme klikli a zostane tam. Ak budeme myš ďalej ťahať (bez prerušenia), z tejto pozície sa vynorí šedá šípka, ktorá bude svojím koncovým bodom sledovať kurzor myši.

  • Keď pustíme tlačidlo myši, šípka určí svojím smerom a dĺžkou (ako vektor) pohyb animovaného obrázka po obrazovke. Smer šípky určí smer tohto pohybu a dĺžka jeho rýchlosť. Ak znova klikneme do plochy, pohyb sa preruší.
  • Ak stlačíme klávesy Ctrl+Shift a potiahneme myšou, možné smery šedej šípky sa obmedzia na násobky 45 stupňov.


Ponuka v oblasti Ukážky animácie

Ak klikneme do oblasti Ukážka animácie pravým tlačidlom myši, otvorí sa menu s dvoma príkazmi:

Farba pozadia… | Otvorí farebnú paletu, z ktorej si môžeme vybrať farbu pozadia, ktorá sa použije v oblasti Ukážka animácie. To nám dovolí preveriť, ako bude obrázok vyzerať, keď ho neskôr (napr. ako tvar korytnačky) umiestnime na plochu určitej farbe. Táto farba pozadia nie je súčasťou obrázka a nesúvisí s nastavením farby pozadia pre papier.
Obrázok na pozadí… | Otvorí dialógové okno Obrázok na pozadí, v ktorom si môžeme vybrať súbor, ktorý sa zobrazí na pozadí oblasti Ukážka animácie. To nám dovolí preveriť, ako bude obrázok vyzerať, keď ho neskôr (napr. ako tvar korytnačky) použijeme na stránke s takýmto pozadím. Obrázok na pozadí nie je súčasťou obrázka a nesúvisí s obrázkom pozadia pri nastavení papiera.


Upravujeme prostredie RNA podľa svojich potrieb

Prostredie RNA si môžeme prispôsobiť podľa našich momentálnych potrieb a skúseností. Môžeme určiť:

  • Ktoré možnosti hlavnej ponuky a ktoré jednotlivé ponuky nám budú k dispozícii.
  • Ktoré panely a okná s nástrojmi budú používateľovi k dispozícii – buď štandardné, alebo vytvorené používateľom.
  • Aké vlastnosti majú mať panely a okná s nástrojmi (napr. akú veľkosť, ktorú pozíciu ukotvenia titulného riadku a pod.).
  • Ktoré položky budú prístupné v rámci každého panelu alebo okna s nástrojmi, ako budú usporiadané, aké budú ich dodatočné nastavenia a skratky.
  • Akú veľkosť majú mať viditeľné komponenty (ikony, nástroje, ...).

Svoje prispôsobenie prostredia (t.j. konfiguráciu) môžeme vytvoriť, pomenovať a uložiť pre budúce použitie. V RNA si môžeme vybrať jednu z troch preddefinovaných konfigurácií, ktoré zodpovedajú rozličným úrovniam našich skúseností:

  • Jednoduchá úroveň
  • Mierne pokročilá úroveň
  • Pokročilá úroveň

Tento zoznam ale môžeme rozšíriť o konfigurácie, ktoré si sami vytvoríme. Ak chceme zvoliť inú konfiguráciu:

  • Vyberme možnosť Zobrazenie/Iné/Nastavenia prostredia... alebo použime klávesovú skratku Ctrl+Alt+medzera a otvorí sa dialógové okno Nastavenie prostredia.
  • Presvedčme sa, že je zobrazená záložka Konfigurácie. Vyberme jednu z konfigurácii a kliknime na tlačidlo Použiť.

Tri vyššie spomínané prednastavené konfigurácie nemôžeme predefinovať. Ak si však niektorú z nich prispôsobíme, môžeme ju uložiť ako používateľskú konfiguráciu pod iným menom, pozri Vytváranie vlastnej konfigurácie: dialógové okno Nastavenie prostredia.

Pozri tiež:

  • RNA v príkazovom riadku


Jednoduchá úroveň

Toto je zjednodušená verzia (t.j. najjednoduchšie nastavenie) editora RNA, ktorá je vhodná pre začiatočníkov. Môžeme ju použiť na vytváranie obrázkov a malieb pomocou kreslenia od ruky, maľovania, pridávania tvarov a pridávania pečiatok. Na tejto úrovni RNA môžeme pracovať iba s jediným jednoduchým obrázkom (v ktoromkoľvek z prípustných formátov).

Jednoduchá úroveň RNA ponúka:

  • Obmedzenú hlavnú ponuku s nasledujúcimi možnosťami: Súbor so základnými funkciami; Úpravy s možnosťami Späť a Znovu; Zobrazenie s tlačidlom pre zobrazenie alebo skrytie Okna pečiatok, možnosťou Iné/Nastavenie prostredia... a možnosťou Nastaviť papier; Maľovanie; Ponuka Štetec obsahuje tri typy štetcov (pozri nižšie). Ponuka Tvar obsahuje Kreslenie od ruky/Čiara, Úsečka, Obvod a výplň elipsy, Obvod a výplň obdĺžnika, Obvod a výplň pravidelného mnohouholníka, Obvod a výplň hviezdy a Výplň. Ponuka Pečiatky obsahuje možnosti Náhodné rozmiestnenie a pomiešané. Poslednou možnosťou je príkaz Zmazať obrázok. Pomoc s možnosťami Ukázať pomocníka, Zobraziť domovskú stránku a O programe.
  • Obmedzený Hlavný panel so základnými funkciami (Otvoriť, Uložiť, Tlačiť) a ďalšími tlačidlami Zmazať obrázok, Nastaviť papier, Späť a znovu, niekoľkými užitočnými tvarmi a tlačidlami Výplň a Pečiatky.
  • Obmedzený panel Štetce s tromi typmi štetcov: kaligrafická fixka, temperová farba a vosková pastelka (kliknutím na šedé šípky alebo na šedý štetec meníme typ štetca). Každý typ štetca je k dispozícii v škále najpoužívanejších farieb. Kliknutím na určitú farbu v paneli ju zvolíme a môžeme ňou kresliť.
  • Zjednodušený Prehliadač pečiatok s jednoduchými kategóriami pečiatok. Vybranú pečiatku môžeme buď otlačiť na papier, alebo ňou kresliť.

Jednoduchá úroveň RNA nám nedovoľuje pracovať so sériami obrázkov (animáciami). Ak sa chceme naučiť viac o RNA, pozrime si aj jeho mierne pokročilú a pokročilú úroveň. Viac podrobností nájdeme v častiach:

  • Zoznamujeme sa s prostredím
  • Vytvárame a upravujeme obrázky
  • Skúmame pracovný priestor
  • Pracujeme s jednotlivým obrázkom
  • Pracujeme so sériou obrázkov. Animácie
  • Upravujeme prostredie RNA podľa svojich potrieb


Mierne pokročilá úroveň

Táto úroveň sa odporúča tým, ktorým je už jednoduchá úroveň dôverne známa a chcú používať viac nástrojov a možností pre vytváranie obrázkov. Mierne pokročilá úroveň je rozšírená úprava editoru RNA, ktorá nám ponúka všetky funkcie jednoduchej úrovne a nasledujúce rozšírenia:

  • Ponuka Úpravy obsahuje aj všetky možnosti pre prácu s oblasťou (ako napr. Vystrihnúť, Kopírovať, Prilepiť ).
  • Ponuka Zobrazenie nám umožňuje zobraziť/skryť viaceré okná a panely s nástrojmi (pozri nižšie), konkrétne Paletu, Hlavnú ponuku, panel Tvary a Hlavný panel. Tiež si v nej môžeme vybrať jeden z troch farebných modelov alebo použiť lupu.
  • Ponuka Maľovanie pridáva možnosť zapnutia alebo vypnutia vyhladzovania hrán a symetrie. Ponuka Štetce obsahuje úplnú súpravu štetcov RNA. Ponuka Tvar je rozšírená o možnosti Otvorená/Uzavretá/Vyplnená krivka, Otvorený/Uzavretý/Vyplnený mnohouholník a Text.
  • Hlavný panel je rozšírený a obsahuje všetky operácie so schránkou, všetky nastavenia symetrie, nástroj Nabrať farbu a tlačidlo Oblasť.
  • Panel Tvary je rozšírený a obsahuje krivky, mnohouholníky a pridávanie textu.
  • Panel Štetce je úplnou verziou panelu z pokročilej úrovne.
  • K dispozícii je panel Paleta

Ani na tejto úrovni nemôžeme pracovať so sériami obrázkov (animáciami). Ak sa chceme naučiť viac o RNA, pozrime si aj jeho pokročilú úroveň. Viac podrobností nájdeme v častiach:

  • Zoznamujeme sa s prostredím
  • Vytvárame a upravujeme obrázky
  • Skúmame pracovný priestor
  • Pracujeme s jednotlivým obrázkom
  • Pracujeme so sériou obrázkov. Animácie
  • Upravujeme prostredie RNA podľa svojich potrieb


Pokročilá úroveň

Táto úroveň je určená skúseným používateľom. Sú tu dostupné všetky možnosti ponúk a štandardných okien a panelov s nástrojmi. Táto príručka sa zaoberá práve pokročilou úrovňou. Ak sa chceme o práci s RNA naučiť viac, pozrime si aj časti:

  • Vytvárame a upravujeme obrázky
  • Skúmame pracovný priestor
  • Pracujeme s jednotlivým obrázkom
  • Pracujeme so sériou obrázkov. Animácie
  • Upravujeme prostredie RNA podľa svojich potrieb

Aj pre pokročilých používateľov môže byť užitočné vytvoriť si vlastný vzhľad prostredia tak, aby bol pre nich efektívny a vhodný na riešenie konkrétnych úloh:
Vytváranie vlastnej konfigurácie: dialógové okno Nastavenie prostredia.


Vytváranie vlastnej konfigurácie:

Vytváranie vlastnej konfigurácie: dialógové okno Nastavenie prostredia

Toto dialógové okno používame na prepínanie medzi jednotlivými konfiguráciami alebo na vytvorenie alebo preskúmanie niektorej vlastnej konfigurácie. Ak chceme otvoriť toto dialógové okno, zvoľme možnosť Zobrazenie/Iné/Nastavenie prostredia... alebo stlačme kombináciu klávesov Ctrl+Alt+medzera. Otvorí sa dialógové okno Nastavenie prostredia a RNA prejde do režimu Nastavenie prostredia. Teraz nemôžeme používať nástroje pre maľovanie a kreslenie a nemôžeme zvoliť možnosti z hlavnej ponuky. Môžeme však:

  • Určiť, ktoré možnosti ponuky sa majú používateľovi poskytnúť.
  • Zmeniť umiestnenie každého panelu alebo okna s nástrojmi v rámci obrazovky; vymazať ich alebo vytvoriť nové.
  • Preskúmať a/alebo upraviť vlastnosti panelov a okien s nástrojmi.
  • Preskupiť alebo upraviť komponenty, ktoré sú zobrazené na paneloch alebo oknách s nástrojmi.
  • Nastaviť veľkosť ikon a ostatné doplňujúce nastavenia.

(Uvedomme si: Aj keď nie je RNA v režime nastavenie prostredia, môžeme presúvať panely a okná s nástrojmi v rámci obrazovky, uložiť ich alebo ich nechať voľne položené – ak nie je uloženie zamknuté.)

Dialógové okno Nastavenie prostredia má päť záložiek:

  • Konfigurácie
  • Príkazy
  • Komponenty
  • Okná a panely
  • Iné


Konfigurácie

Keď otvoríme túto záložku, objaví sa nám zoznam aktuálne dostupných konfigurácií, napríklad:

1. Jednoduchá
2. Mierne pokročilá
3. Pokročilá
Mini
Úplná

Prvé tri konfigurácie sú prednastavené a nedajú sa meniť alebo presúvať. Všetky ďalšie konfigurácie (ak sa tu nejaké nachádzajú) sú definované používateľom – ich názov a obsah určil sám používateľ.

Použiť

Ak sa chceme prepnúť do inej konfigurácie, vyberme jej názov zo zoznamu a kliknime na tlačidlo Použiť. Potom zatvorme dialógové okno Nastavenie prostredia.

Uložiť

Predstavme si, že sme si práve prispôsobili prostredie RNA tak, ako to vyhovuje účelu, na ktorý ho chceme využiť. Keď toto nastavenie chceme uložiť pre ďalšiu prácu ako jedno z alternatívnych nastavení, kliknime na tlačidlo Uložiť a pomenujme našu novú používateľom definovanú konfiguráciu. Nemôžeme ale použiť meno žiadnej preddefinovanej konfigurácie (Jednoduchá, Mierne pokročilá, Pokročilá).

Ak sme práve prispôsobili prostredie RNA a zatvoríme okno Nastavenie prostredia bez toho, aby sme toto nastavenie uložili, zachová sa v RNA aj po jeho vypnutí a následnom zapnutí. Ak by sme však v prispôsobovaní chceli pokračovať, prechádzajúci stav prostredia sa stratí a musíme ho začať nastavovať odznova.

Odstrániť

Ak vyberieme jednu z prednastavených konfigurácií, tlačidlo Odstrániť sa nedá použiť (tieto konfigurácie nemôžeme odstrániť). Ak chceme odstrániť jednu z používateľom definovaných konfigurácií, označme ju kliknutím myšou a stlačme tlačidlo Odstrániť. RNA nás vyzve na potvrdenie tejto voľby. Používajme túto možnosť opatrne.


Príkazy

Záložku Príkazy používame, keď chceme označiť, ktoré príkazy ponuky majú byť k dispozícii v našej novej konfigurácií. Jednotlivé príkazy však nemôžeme presúvať z jednej ponuky do druhej, nemôžeme ani meniť poradie príkazov v rámci ponuky. Môžeme ale ukryť niektoré príkazy alebo celé vnorené ponuky. Úplný súbor príkazov ponuky nájdeme v pokročilej úrovni.

Ak chceme upraviť možnosti ponuky:

  • Otvorme záložku Príkazy v dialógovom okne Nastavenie prostredia a preskúmajme súčasnú úpravu.
  • Vymenovaných je tu šesť možností hlavnej ponuky – Súbor, Úpravy, Zobrazenie, Maľovanie, Animácia a Pomocník. Pri každej z nich sa nachádza značka +. Túto značku nájdeme aj pri tých možnostiach, ktoré ponúkajú ďalšiu (vnorenú) ponuku možností. Kliknutím na túto značku sa nám zobrazia všetky možnosti vnorenej ponuky.
  • Ak sa pri danej možnosti objaví tmavá kontrolná značka, znamená to, že bude k dispozícii (spolu s vnorenými možnosťami, ak nejaké má). Ak klikneme na tmavú kontrolnú značku, daná možnosť nebude v našej konfigurácii prístupná (so všetkými jej vnorenými možnosťami). Ak je pri možnosti svetlá kontrolná značka, znamená to, že niektoré z jej vnorených možností sú prístupné a iné nie. Preskúmajme celú štruktúru možností ponuky a označme alebo zrušme kontrolné značky.
  • Ak si vyberieme možnosť, ktorá už neobsahuje ďalšiu ponuku, v okienku klávesové skratky sa objaví jej klávesová skratka alebo skratky (ak nejaké má). Jednotlivým možnostiam môžeme priradiť aj vlastné klávesové skratky tak, že stlačíme tlačidlo Pridať a určíme vlastnú skratku. Ak chceme skratky vymazať, stlačíme tlačidlo Odstrániť. Ak sme zadali skratku, ktorá je už priradená inej možnosti, objaví sa správa s varovaním.
  • Skryté môžu byť všetky možnosti okrem Nastavenie prostredia – nikdy sa nemôže stať, že stratíme cestu k dialógovému oknu Nastavenie prostredia. Toto okno môžeme kedykoľvek otvoriť aj pomocou klávesovej skratky Ctrl+Alt+medzera.


Komponenty

Záložku Komponenty používame, keď chceme usporiadať zložky existujúcich okien a panelov s nástrojmi. Tieto zložky majú podobu ikon, čiže malých grafických objektov (napr. okienko lupy alebo textu), ovládacích prvkov (ponuka všetkých typov písma) a iných značiek so špeciálnym významom.

Všetky komponenty prístupné v RNA sú zaradené do šiestich skupín (viac-menej zodpovedajú možnostiam hlavnej ponuky) – Súbor, Úpravy, Zobrazenie, Maľovanie, Animácia a Iné. Za nimi sú štyri špeciálne prvky – Textový popis, Horizontálny oddeľovač, Vertikálny oddeľovač a Prázdne miesto.

Značka + sa objaví pri každej hlavnej skupine komponentov, a tiež pri ich podskupinách. Kliknime na ňu a objavia sa všetky podskupiny a komponenty, ktoré do nej patria. Ak chceme nájsť určitý komponent, prezerajme detailne celú štruktúru. Ak hľadáme napr. ponuku so všetkými typmi písma, prejdime do časti Kreslenie/Tvary/Text/Písmo.

Keď si vyberieme komponent (napr. Kreslenie/Štetce/Pripravené štetce/Gélová farba), v pravej časti okna sa tento komponent vytvorí a zobrazí. Niekedy sa pri komponente zobrazia aj ďalšie jeho nastavenia (ako napr. veľkosť hrotu alebo farba hrotu).

Pridávanie komponentu

Ak chceme pridať nejaký komponent do panelu alebo okna s nástrojmi:

  • Nájdime ho v štruktúre komponentov.
  • Ak má pri sebe aj ďalšie nastavenia, zvolíme ich hodnoty a myšou potiahnime komponent z okna Nastavenie prostredia na cieľový panel alebo okno s nástrojmi.
  • Ak komponent ukladáme na panel s nástrojmi, komponent ukladáme do jedného riadku alebo stĺpca.
  • Ak komponent ukladáme do okna s nástrojmi, komponent ukladáme do tzv. tabuľky.

Na paneloch s nástrojmi sú komponenty rozložené do jedného riadka alebo stĺpca. Usporiadanie, veľkosť a zarovnanie komponentu má za úlohu panel, v ktorom komponent leží.

Komponenty, ktoré ležia v oknách s nástrojmi, sú umiestnené v neviditeľných tabuľkách. Tabuľka v jednom okne môže obsahovať ďalšie vnorené tabuľky, tie môžu obsahovať ďalšie vnorené tabuľky atď. Obrysy tabuliek vidíme iba v režime Nastavenie prostredia a iba vtedy, keď sa snažíme umiestniť komponent do niektorého okna. Tabuľky sa v okne vytvárajú dynamicky podľa toho, na ktoré miesto okna komponent položíme.

Odstránenie komponentu

Ak je zapnutý režim Nastavenie prostredia, môžeme stlačiť tlačidlo myši na ktoromkoľvek komponente na paneli s nástrojmi alebo v okne s nástrojmi a potiahnuť ho preč. Komponent môžeme premiestniť na ktorýkoľvek iný panel alebo okno s nástrojmi. Keď ho potiahneme mimo akéhokoľvek okna alebo na pracovnú plochu a pustíme tlačidlo myši, komponent sa odstráni.

Zarovnanie a veľkosť komponentu

Ak je zapnutý režim Nastavenie prostredia, môžeme v okne s nástrojmi kliknúť pravým tlačidlom myši na ľubovoľný komponent. Otvorí sa menu, ktoré zodpovedá tomuto komponentu.

V skupinách zarovnanie určujeme, ako bude komponent v rámci svojej tabuľky zarovnaný. Možnosti sú zrovnať vľavo, vpravo hore, dolu alebo sa komponent prispôsobí veľkosti tabuľky .

Ďalšie príkazy určujú, či sa má komponent snažiť maximalizovať svoje rozmery na úkor ostaných komponentov alebo naopak, či sa má komponent snažiť svoje rozmery minimalizovať.


Okná a panely

Túto záložku používame, ak chceme vytvoriť alebo vymazať panely alebo okná s nástrojmi alebo ak chceme zmeniť ich vlastnosti. V ľavej časti je zoznam všetkých existujúcich panelov a okien s nástrojmi. Panely a okná môžeme rozlíšiť podľa jemne rozdielnych ikon. V pravej časti sú štyri tlačidlá: Nový panel, Nové okno, Odstrániť a Vlastnosti...

Nový panel

Kliknutím na toto tlačidlo vytvoríme nový, prázdny panel. Keď chceme spresniť jeho vlastnosti (pozri nižšie), prejdime do záložky Komponenty a pridajme do neho prvky. Veľkosť panelu je vždy určená prostredím RNA a nedá sa zmeniť. Závisí od veľkosti a typu jednotlivých prvkov a od vlastností, nastavení a momentálnej pozície panelu.

Každý panel, ktorý vytvoríme, dostane predvolený názov (napr. Panel 1). Tento názov sa ihneď objaví na zozname panelov a okien s nástrojmi. Tiež sa objaví ako položka v ponuke Zobrazenie/Iné, pomocou ktorej môžeme panel zobraziť alebo skryť. Ak ho chceme premenovať (napr. na Moje ceruzky), preskúmajme jeho vlastnosti.

Nové okno

Kliknutím na toto tlačidlo vytvoríme nové, prázdne okno. Teraz môžeme určiť jeho vlastnosti (pozri nižšie) a pridať doň prvky (v záložke komponenty). Môžeme meniť jeho veľkosť a určiť jeho pozíciu. Veľkosť a pozícia každého okna je jedným z nastavení, ktoré sa uložia v rámci konfigurácie.

Každé okno, ktoré vytvoríme, dostane predvolený názov (napr. Okno 4). Tento názov sa ihneď objaví na zozname panelov a okien s nástrojmi. Tiež sa objaví ako položka v ponuke Zobrazenie/Iné, pomocou ktorej môžeme okno zobraziť alebo skryť. Ak ho chceme premenovať (napr. na Moje nástroje), preskúmajme jeho vlastnosti.

Odstrániť

Ak chceme odstrániť niektorý panel alebo okno s nástrojmi z momentálnej konfigurácie, kliknime na jeho meno v zozname panelov a okien a kliknime na tlačidlo Odstrániť. Musíme si uvedomiť, že táto akcia je úplne odlišná od skrytia panelu alebo okna. Ak odstránime panel alebo okno, už nebudú existovať a neobjavia sa ani v ponuke Zobrazenie/Iné. Odstrániť môžeme všetky panely alebo okná z aktuálnej konfigurácie (aj tie najzákladnejšie).

Vlastnosti

Keď stlačíme toto tlačidlo, môžeme preskúmať alebo upraviť vlastnosti ktoréhokoľvek panelu alebo okna s nástrojmi. Najprv musíme kliknúť na panel alebo okno, ktoré chceme upraviť, potom kliknúť na tlačidlo Vlastnosti. Otvorí sa dialógové okno Vlastnosti s nasledujúcimi možnosťami nastavenia:

Nadpis, jeho umiestnenie a spôsob zobrazenia

Tu môžeme vidieť alebo upraviť nadpis okna alebo panelu. Môžeme tiež určiť, či sa má nadpis zobraziť vľavo, hore, vpravo alebo dolu. Môžeme tiež určiť, či má byť nadpis zobrazený, keď je okno ukotvené alebo voľné.

Rozloženie horizontálne alebo vertikálne

Každý panel a okno musí byť určené ako Horizontálne alebo Vertikálne. Ak je horizontálne, môžeme ho ukotviť iba k vrchnému a spodnému okraju hlavného okna. Ak je vertikálne, môžeme ho ukotviť iba k ľavému alebo pravému okraju hlavného okna.

Veľkosť

Pre každé okno môžeme určiť, či sa bude dať meniť jeho výška alebo šírka. Môžeme tiež určiť, či má byť okno zväčšené na maximum jeho šírky, keď je ukotvené pri vrchnom alebo spodnom okraji hlavného okna alebo či má byť zväčšené na maximum jeho výšky, keď je ukotvené pri ľavom alebo pravom okraji hlavného okna.

Pri paneloch tieto nastavenia nemôžeme použiť. Veľkosť každého panelu je totiž automaticky určená prostredím RNA a nedá sa zmeniť.

Viditeľnosť

Keď zvolíme túto možnosť, okná a panely s nástrojmi budú zobrazené, v opačnom prípade budú skryté. Viaceré okná môžeme zobraziť alebo skryť aj pomocou príkazov v hlavnej ponuke Zobrazenie/Iné.

Uloženie

Každý panel alebo okno môže byť týmto nastavením chránené proti neúmyselným zmenám. Pri zamknutom uložení nemôžeme s oknom alebo panelom hýbať, meniť jeho veľkosť, ukotviť ho (ak je voľné) alebo ho zmeniť na voľné (ak je ukotvené).

Správanie

Táto rolovacia ponuka obsahuje niekoľko možností. Prvá z nich, Obyčajný panel alebo okno, je predvolené správanie pre najbežnejšie alebo používateľom vytvorené panely a okná. Ale aj šesť štandardných panelov a okien (Štetce, Obsah, Paleta, Pečiatky, Nastavenia lupy a Text) má svoje predvolené (špeciálne) správanie. Tak napr. panel Štetce tu má nastavenú položku Štetce ako jeho správanie. Ak sme si vytvorili vlastný panel alebo okno a chceme, aby sa s ním zaobchádzalo napríklad ako s panelom Štetce, zvolíme položku Štetce ako jeho správanie. Podobne by sme postupovali, keby sme chceli, aby sa s našim panelom alebo oknom zaobchádzalo ako s ktorýmkoľvek iným štandardným oknom alebo panelom.


Iné

Túto záložku používame, ak chceme spresniť niektoré doplňujúce nastavenia.

Pracovať iba s jedným obrázkom

Táto možnosť sa odporúča iba začiatočníkom (je použitá v jednoduchej a mierne pokročilej úrovni). Ak vyberieme túto možnosť, nebudeme môcť otvoriť alebo vytvoriť viac ako jeden obrázok súčasne. To znamená, že Obsah by sa skladal iba z jednej položky (preto sa vôbec nezobrazí pri nastavení prostredia, ktoré používa možnosť Pracovať iba s jedným obrázkom).

Ak nie je táto možnosť označená, môžeme pracovať s viacerými obrázkami súčasne (pozrime časť Práca s niekoľkými obrázkami).

Priečinok pre pečiatky

Po kliknutí na tlačidlo ... sa otvorí dialógové okno Vyhľadať priečinok. V ňom môžeme zmeniť východiskový priečinok pre Prehliadač pečiatok. Ak sa chceme vrátiť k predvolenej zložke, kliknime na tlačidlo X.

Táto voľba môže byť v rôznych konfiguráciách odlišná. Keď otvoríme Prehliadač pečiatok, zobrazí sa momentálny obsah určeného priečinku a rolovacia ponuka jeho kategórií – t.j. názvov všetkých priečinkov vložených vo východiskovom priečinku.

Veľkosť ikon

Vhodným číslom môžeme určiť primeranú veľkosť ikon vo všetkých paneloch a oknách nástrojov. Pre skúsenejších používateľov sa odporúča veľkosť okolo 33%, pre mladších žiakov je vhodná veľkosť okolo 50% a viac. Veľkosť každej ikony zvlášť zmeniť nemôžeme, lebo toto nastavenie je spoločné pre všetky ikony.

Dekorácia

Môžeme určiť netradičný vizuálny štýl alebo dekoráciu hlavného okna a všetkých okien a panelov s nástrojmi. Po kliknutí na tlačidlo ... sa otvorí dialógové okno Otvoriť, v ktorom môžeme zvoliť dekoráciu. Ako dekoráciu môžeme použiť akýkoľvek obrázok vo formáte *.DIB alebo *.BMP. Ak sa nechceme používať žiadnu dekoráciu, kliknime na tlačidlo X.


Tabuľka klávesových skratiek

Toto je zoznam obvyklých (prednastavených) klávesových skratiek k príkazom a tlačidlám. Všimnime si však, že si môžeme prispôsobovať aj klávesové skratky. Okrem toho si pamätajme, že niektoré príkazy majú viacero prednastavených klávesových skratiek. Napríklad, keď stlačíme Ctrl+O alebo F3, vykoná sa príkaz Súbor/Otvoriť….

Skratka | Príkaz v ponuke | Tlačidlo na paneli alebo okne
[ | Maľovanie/Oblasť/Transformácie/ Otočiť o 270° |
] | Maľovanie/Oblasť/Transformácie/Otočiť o 90° |
Alt+BackSpace | Úpravy/Späť <čo> | Hlavný panel/Späť
Alt+F2 | Úpravy/Uložiť ako... |
Alt+F3 | Súbor/Zatvoriť |
Alt+F7 | Zobrazenie/Iné/Farba |
Alt+G | Animácia/Vytvoriť animáciu... |
Alt+T | Animácia/Transformovať... |
Alt+X | Súbor/Ukončiť |
Ctrl+` | Maľovanie/Oblasť/Zachovať priesvitnosť |
Ctrl+A | Úpravy/Označiť všetko |
Ctrl+Alt+Medzera | Zobrazenie/Iné/Nastavenie prostredia… |
Ctrl+B | Animácia/Vytvoriť prelínanie |
Ctrl+C | Úpravy/Kopírovať | Hlavný panel/Kopírovať
Ctrl+D | Animácia/Nastaviť trvanie... |
Ctrl+F4 | Súbor/Zatvoriť |
Ctrl+F7 | Zobrazenie/Iné/Nastavenie farieb |
Ctrl+H | Animácia/Nastaviť základný bod... |
Ctrl+Insert | Úpravy/Kopírovať | Hlavný panel/Kopírovať
Ctrl+M | Animácia/Minimalizovať | Panel Animácia/Minimalizovať obrázok
Ctrl+N | Súbor/Nový |
Ctrl+Num - | Zobrazenie/Lupa/Zmenšiť |
Ctrl+Num * | Zobrazenie/Lupa/Zobraziť normálne |
Ctrl+Num + | Zobrazenie/Lupa/Zväčšiť |
Ctrl+O | Súbor/Otvoriť… | Hlavný panel/Otvoriť
Ctrl+P | Súbor/Tlačiť…. | Hlavný panel/Tlačiť…
Ctrl+Q | Zobrazenie/Lupa/Zmenšiť |
Ctrl+R | Animácia/Prevrátiť poradie |
Ctrl+S | Súbor/Uložiť | Hlavný panel/Uložiť
Ctrl+V | Úpravy/Prilepiť alebo Úpravy/Prilepiť za | Hlavný panel/Prilepiť
Ctrl+W | Zobrazenie/Lupa/ Zväčšiť |
Ctrl+X | Úpravy/Vystrihnúť | Hlavný panel/Vystrihnúť
Ctrl+Z | Úpravy/Späť <čo> | Hlavný panel/Späť <čo>
Del | Úpravy/Odstrániť |
F1 | Pomoc/Revelation Natural Art |
F11 | Zobrazenie/Pečiatky | Hlavný panel/Pečiatky
F2 | Súbor/Uložiť |
F3 | Súbor/Otvoriť… |
F4 | Zobrazenie/Obsah |
F5 | Zobrazenie/Štetce |
F6 | Zobrazenie/Iné/Nastavenie nástrojov |
F7 | Zobrazenie/Paleta |
F8 | Zobrazenie/Nastavenia lupy |
F9 | Zobrazenie/Ukážka animácie |
Ins | Úpravy/Vložiť za |
Shift+Ctrl+Z | Úpravy/Znovu <čo> |
Shift+Ctrl+Z | Úpravy/Späť <čo> | Hlavný panel/Znovu
Shift+Delete | Úpravy/Vystrihnúť | Hlavný panel/Vystrihnúť
Shift+Insert | Úpravy/Prilepiť alebo Úpravy/Prilepiť za | Hlavný panel/Prilepiť
X |  | Panel Animácia/Nasledujúca fáza
Z |  | Panel Animácia/Predchádzajúca fáza


RNA v príkazovom riadku

Rôzne vlastnosti programu RNA a jeho ďalšie správanie môžeme ovplyvniť pomocou prepínačov a parametrov. Používame ich pri spustení programu z príkazového riadka, alebo prostredníctvom zástupcu v ponuke Štart, alebo na Pracovnej ploche Windows. V nasledujúcej tabuľke je uvedený stručný prehľad všetkých používaných prepínačov a parametrov.

Nezabudnime:

  • Ak sa v názve súboru alebo priečinka nachádza medzera, treba toto meno v príkazovom riadku uvádzať v úvodzovkách – je to vlastnosť operačného systému, ktorý potom odovzdá takýto názov ako jeden parameter pre program, a nie ako viacero samostatných parametrov.
  • Niektoré prepínače majú aj ďalší parameter, ktorý nasleduje tesne za dvojbodkou.
  • Ak program RNA spustíme bez parametrov, očakáva, že súbory s konfiguráciou sú umiestnené v adresári
    C:\Documents and Settings\<username>\Application Data\RevelationNaturalArt\ Konfiguracie
  • Ak takýto adresár neexistuje, program sa snaží použiť vnorený adresár Konfiguracie toho adresára, v ktorom sa nachádza súbor RevelationNaturalArt.EXE.
  • Ak program RNA spustíme bez parametrov, očakáva, že súbory s kresbami sú umiestnené v adresári
    C:\Documents and Settings\<username>\Documents\Moje obrazky.
  • Ak takýto adresár neexistuje, program sa snaží použiť vnorený adresár Moje obrazky toho adresára, v ktorom je RevelationNaturalArt.EXE.

Otvorenie súboru

Parameter:

názov_súboru
"názov súboru"

Popis:

Otvorí jeden alebo viacero súborov. Súbory sú oddelené medzerami (jeden súbor = jeden parameter). Ak sa v súbore alebo ceste k súboru vyskytujú medzery, treba meno alebo cestu dať do úvodzoviek.

Príklad:

RevelationNaturalArt.exe Obrazok.rna
RevelationNaturalArt.exe D:\Obrazok.rna
RevelationNaturalArt.exe "C:\My Documents\Obrazok.rna"

Spustenie v konfigurácii

Prepínač:

/CFG:názov_súboru_s_konfiguráciou
/CFG:"názov súboru s konfiguráciou"

Popis:

Spustí RNA v zadanej konfigurácii. Dá sa uviesť iba názov konfigurácie, relatívna cesta alebo absolútna cesta ku konfigurácii. RNA sa pokúša hľadať konfiguráciu v aktuálnom adresári, ak ju tam nenájde, RNA sa pokúša hľadať konfiguráciu v adresári s konfiguráciami.

Na veľkosti písmen nezáleží, dôležitá je lomka na začiatku a dvojbodka za CFG.

Príklad:

RevelationNaturalArt.exe /CFG:"1. Jednoducha.cfg"
RevelationNaturalArt.exe /CFG:"C:\Moje nastavenia\3. Pokrocila.cfg"

Spustenie programu bez úvodnej obrazovky

Prepínač:

/NoSplashScreen

Popis:

Spustí RNA bez úvodnej obrazovky. To má za následok rýchlejšie spustenie programu.

Na veľkosti písmen nezáleží, dôležitá je lomka na začiatku.

Príklad:

RevelationNaturalArt.exe /NoSplashScreen

Presmerovanie do adresára s EXE

Prepínač:

/GoToExeDir

Popis:

Presmeruje prácu programu RNA do adresára, v ktorom sa nachádza EXE tohto programu. V adresári by mali byť podadresáre s konfiguráciami a vlastnými obrázkami, t.j. adresár vyzerá takto:

Konfiguracie | adresár
Dokumentacia | adresár
Hroty | adresár
Ikony | adresár
Motivy | adresár
Moje obrazky | adresár
Peciatky | adresár
Povrchy | adresár
RevelationNaturalArt.exe | aplikácia

Tento prepínač je užitočný pre tých, ktorí chcú mať program, konfigurácie a obrázky pohromade.

Na veľkosti písmen nezáleží, dôležitá je lomka na začiatku.

Príklad:

RevelationNaturalArt.exe /GoToExeDir

Presmerovanie programu do iného pracovného adresára

Prepínač:

/GoTo:názov_pracovného_adresára
/GoTo:"názov pracovného adresára"

Popis:

Presmeruje prácu programu Revelation Natural Art do zadaného adresára. V adresári by mali byť podadresáre s konfiguráciami a vlastnými obrázkami, t.j. adresár vyzerá takto:

Konfiguracie | adresár
Moje obrazky | adresár

Tento prepínač je výhodný pre sieťové inštalácie a inštalácie v školách, kde majú používatelia uložené svoje údaje v iných neštandardných adresároch.

Na veľkosti písmen nezáleží, dôležitá je lomka na začiatku a dvojbodka za GoTo.

Príklad:

RevelationNaturalArt.exe /GoTo:"H:\RNA"

Nastavenie adresára s konfiguráciami

Prepínač:

/CFGDir:názov_adresára_s_konfiguráciami
/CFGDir:"názov adresára s konfiguráciami"

Popis:

Určí adresár s konfiguráciami. Tento prepínač je výhodný pre sieťové inštalácie a inštalácie v školách, kde majú používatelia uložené svoje konfigurácie v neštandardných adresároch.

Na veľkosti písmen nezáleží, dôležitá je lomka na začiatku a dvojbodka za CFGDir.

Príklad:

RevelationNaturalArt.exe /CFGDir:"H:\RNA\Konfiguracie"

Dialógy v ostatne použitom adresári

Prepínač:

/UseLastDir

Popis:

Súborové dialógy („Otvoriť“ a „Uložiť“ dialógy) RNA neotvorí v adresári „Moje obrazky“, ale v tom adresári, z ktorého sa ostatne otváral obrázok, alebo sa doň obrázok ukladal.

Tento prepínač je výhodný pre pokročilých používateľov, ktorí nechcú zakaždým prechádzať adresáre od „Moje obrazky“, ale vyhovuje im, že program si pamätá adresáre, v ktorých ostatne pracovali.

Na veľkosti písmen nezáleží, dôležitá je lomka na začiatku.

Príklad:

RevelationNaturalArt.exe /UseLastDir
RevelationNaturalArt.exe /GoToExeDir /UseLastDir

Zakázanie behu viacerých inštancií RNA

Prepínač:

/SingleInstance

Popis:

Dovolí, aby v jednom okamihu bežal program RNA iba raz. Tento prepínač je výhodný pre používateľov, ktorým vyhovuje, že program sa nespúšťa veľakrát.

Na veľkosti písmen nezáleží, dôležitá je lomka na začiatku.

Príklad:

RevelationNaturalArt.exe /SingleInstance
RevelationNaturalArt.exe /SingleInstance "Obrazok 1.jpg"


Pečiatky, F11

Otvorí alebo skryje okno Pečiatky.